Recovery image for one plus 8 pro

Hi All, The easy installer failed twice so I switched to a manual mode. Now I can get to fastboot but nothing else. I managed to successfully flash dtbo.img and boot.img. I have tried to flash and boot twrp recovery & recovery-e-1.6-s-20221201239247-dev-instantnoodlep.img. But all I ever gt is the fastboot menu. When I say fastboot, the term “fastboot” does not show on the phone but I can access it from from the command prompt on my laptop using fastboot commands. Any helpers? Thanks

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I have the same problem with a Oneplus Nord. I fould a possible solution but I haven’t tried it yet:
Have a look at this link. No promises. I am a noob and don’t know anything, but this looks promising

Thanks, but this seems to reference adb. I cant get to an adb menu only fastboot

Scroll down to the video on how to flash stockrom via fastboot. It’s there.

You can also look in this thread for tips and sugestions: Oneplus Nord manual installation problems - #19 by aibd
Aidb and horntot try to help me te recover my device. This first posts are irrelevant. The last ones are about my bricked device. I think you may have gone down the same path as I have, resulting in a phone that only has a fastboot screen :wink:

to a phone

Thanks for this. I downloaded the files and then tried the first command: fastboot flash aop aop.img but I am given the message “FAILED (remote: Flashing is not allowed in Lock State)”

I tried fastboot flashing unlock AND fastboot flashing unlock_critical but got the message “Flashing Unlock is not allowed”

Any more suggestions please?


Nope. I tried the solution of the customdroid and I ended up with a dead phone. I don’t recommend trying what I did. Guess I’ll have to buy a new phone :frowning:
Oneplus Nord manual installation problems
Update: The device came to life again as I was not watching, but the excercise was not succesful. At least I’m back in fastboot mode, so I can try something else.

He Jimmy,
I took the risk of using the MSM method to reinstall the whole andriod system and it worked. I now have a working phone with Android 105.2. Stil no /e/ OS but at least it’s unbricked. In fact it was not that much work, but I had to read a lot before starting. If you want to do thius, it may be wise to read the posts about it in this thread: Oneplus Nord manual installation problems - #37 by aibd
And read these two guides: Guide to Unbrick OnePlus Nord from a Hard-Bricked State using MSMDownload Tool
OnePlus Community
The first read is clear, but the oneplus community thread gives some extra info and explains a few things that are left out in the customdroid guide. I would ask aidb for some advise before doing this, but good luck!

Thanks for the update langedarm, did you manage to boot to EDL mode? Or did you manage to get the device drivers set up so that the windows machine recognized your device. Neither of those two things is working for me!

Hi @jimmy I dumped the TCD link here without any introduction ! Sometimes it helps to read instructions in different words; perhaps you might try reading from XDA author @Some_Random_Username

[OP8PRO][OOS 11AA/BA/DA] Unbrick tool to restore your device to OxygenOS

Hi Jimmy,
Yes I managed to get into EDL mode. Just powering the device off and holding the volume up button for 5 seconds and connecting to my pc at the same time did the trick. On your phone you should hold both up an down volume buttons for 5 seconds after powering down completely. The device showed only black screen, but the pc could find it. I could see it when I opened the device manager on my pc under “other devices” (i think).I showed up as QHUSB_BULK, so I followed this guide to install de Qualcom USB drivers: Qualcomm HS-USB QDLoader 9008 Drivers: Download and Installation Guide
On the XDA forum in a faq I found this:
My device isn’t detected (in EDL mode)

Go to device manager and make sure your phone shows up as QDLOADER 9008.
If it shows up as QHUSB_BULK, it means Qualcomm driver wasn’t installed automatically by Windows Update. Download the latest one from Microsoft website at… (source hs usb 9008 ) and install it manually by right clicking on QHUSB_BULK and selecting “Update driver software” and “Browse my computer for driver software” to where you downloaded CAB file.

Hope this helps.

I also finally managed to get the msm tool to work. The problem I had was finding the correct drivers. Now the phone is back on oxygenOS and I wont risk e-os again. Thanks langedarm, thanks qualcomm

Hello everybody.
The only thing the easy installer did for me was unlocking the bootloader and very easily bricked my Oneplus 8 pro to the state that only the bootloader was working.
Installing recovery and via fastboot did not work.
I had to boot Windows 10 and followed the best and most straightforward method I found on the oneplus community site:

There is a link to the “unbrick tool” for different devices which includes the ROM file and the MSM download tool for EU, Global and Indian versions, along with the link to the Qualcomm Drivers.

Also helpful is the following video and the description on XDA developers. However, I did not use the files from the XDA forum post, but from Oneplus community, which indeed worked flawlessly.

I first downloaded the tool for EU region, and MSM tool stopped with an error message “unsupported target”. Apparently I had bought a Global version without knowing, and successfully repeated the procedure with the Global MSM download tool.