Samsung A510F Stuck at /e/ logo on first boot

TWRP successfully installed (Ver for samsung A510F).
Then installed e-0.7-p-2020012238465-dev-a5xelte zip via TWRP
Booted system, /e/ logo shows but then returns to TWRP after 5 mins.

I have looked at posts with similar problem and the common solution is that /e/ needs to be installed over an Android 7 nougat installation i.e. not Oreo.
However, I checked and the phone was running nougat (Kernal 3.10.61-12236002) before I flashed /e/ (e-0.7-p-2020012238465-dev-a5xelte) so now I need some other pointers as to where the error might come from.

Anyone can help?

This issue doesn’t show up on my Samsung Galaxy A5 (2016) SM-A510F “a5xelte”

For the SM-A510F were officially only provided by Samsung: StockROM Android 5.1.1, 6.0.1 and 7.0.0. An official Oreo 8.0.0 is not available - in any country, from any carrier.

I recommend an absolutely clean installation, which means …

After TWRP booted …

  1. click on “Wipe”

  2. Click on “Format Data”

  3. Type “yes” and confirm format action

  4. Once format data is done click on the “Back” button

  5. Now click in TWRP on “Advanced Wipe”

  6. Select Partitions to Wipe and check the checkbox:

    ✓ Dalvic / ART Cache
    ✓ System
    ✓ Cache
    ✓ data
    ✓ Internal Storage

  7. Swipe to confirm wipe action

  8. Once wipe is done, click on the back button to go back to TWRPs main screen. Click on the “Reboot” button.

  9. Click on “Recovery”, after that “Swipe to Reboot”.

  10. Wait until your device rebooted into TWRP Recovery, now you can flash the awesome /e/ OS ROM dev 9-pie.

PS. I have read your three postings here and here and here and am somewhat surprised by your observations and assessments.

1 Like

Yes I understand that, but I think you misunderstood me, I wasn’t trying to get Oreo - other posts on similar problems mentioned the need to install /e/ over Nougat. At the time I wasn’t sure what the phone was previously running because I had just brought it so had to go back to stock backup and check. As you say it was Nougat so that obviously is not my problem.

Yeah I am a bit confused by this and what variant I actually have. The Phone is an SM-A510F but the boot screen shows A5-6 which I read at the bottom of the download page (I think) is not supported.

I have successfully installed Lineage OS on it, yet Lineage for MicroG fails with the same error as /e/ so I wonder if it is MicroG that’s causing it (MircoG is included in /e/ right?).

Thank you very much for taking the time to comment.

It has actually been a few years since I dabbled in custom roms, wasn’t actually wanting to get into it again as lack the time but sailfish OS won’t sell internationally and really liked the sound of /e/ so decided to try it. I read something earlier on when I was looking at /e/ that said root access was required, and that may have gotten me mildly confused between root and unlocking BL - hence my first comment which was obviously miss placed.

I stand by my comment about the approved device list needing more detail on variants that aren’t actually supported because most people (Including me) have no idea all the small variants out there i.e. the A5 2016 model has many including this A5-6 which doesn’t seems to even relate to hardware as it is still labelled A510-F.

I have tried a complete format and wipe as you suggest but sadly it looks like I still have the same boot loop. I am giving it a bit of time first though in case it is a slow 1st boot.

Once again , thanks for the help but it looks like I may have to just use Lineage or get another phone.

That is correct so. The ➅ stands for the year 2016. The model name is only displayed under Settings > About phone SM-A510F (Device name).

My /e/ phone SM-A510F works fine - yours doesn’t. So it will be solely due to the hardware.

If the above mentioned radical erase tour does not help, try it additionally:

Format the /data partition with another file format and then back to the original file format.

TWRP Recovery > Wipe > Advanced Wipe > select Partition Data > Repair or change file system > Change file system > select exFAT

Then select the original file format ext4 again.

Now install the /e/ OS ROM again.

NB: You should be able to use exFAT and ext4 on a microSD card as well.

Great so I do actually have an A5-510F, so installing /e/ should have worked :frowning:

Ok I have to try the file format you suggest. Fingers Crossed!

Sigh’… Nope it has just returned to the recovery after trying the file system change and format/wipe etc.

Lineage works but is a bit limited for what I wanted.

It is exactly the same phone as yours based on the picture you sent. Very frustrating because as I said I only brought this phone to run /e/ :disappointed_relieved:

Hmm, LOS 16.0 build for a5xelte and LineageOS-16.0-for-microG I wanted to suggest you to try them out.

Well, slowly but surely I’m at my wit’s end. But I would give it one last try: Back to StockROM Android 7.0 and then the whole procedure again from the beginning …

Hi again
Ok I will go back to the stock rom and do everything again as it’s worth a try.
Lineage 14.1 for A5 works no problem.
Lineage 16 for MicroG fails same as /e/


Ok Archje. I tried and failed.

I have an interesting observation though. Every time I try to load a ROM based on Lineage 16 it fails. I have tried Lineage 16, Lineage 16 for MicroG and several builds of /e/ which if I am not mistaken are based on Lineage 16 as well. All failed.

But when I tried Lineage 14.1 and 15.1 everything works fine.
I really want to try /e/ as the whole concept appeals but I guess I will have to wait for another build and hope it works.

It’s curios. My flash process lasted only a few minutes and running without any problems: no error messages, no bootloop, TWRP only starts when I want it to. At the moment I can’t think of anything else - except: an unofficial → testbuild based on 9-pie from the time before the official release of /e/ OS ROM dev (pie) …

Woo Hoo, I got it successfully loaded and it’s fantastic.
After trying your suggestions I spent hours longer trying different versions of stock and lineage to see what worked and what didn’t. After each install I would then try loading /e/ with various combinations of wipe first (and some times no wipe).

What seemed to have worked is loading a nightly build of Lineage (lineage-16.0-20200205-nightly-a5xelte-signed) followed by an advanced wipe of all partitions and then a format. After that I tried /e/ again and was very shocked that it actually started.

I really appreciate your time helping on this Archje.

Long last is finally good. Good things come to those who wait. All’s well that ends well, so to say. However, that may be: Welcome to the /e/ club, @Killjoy

/e/ for a5xelte dev (pie) e-0.8-p-2020041649926- now with Android security patch level April 5, 2020.
The recently integrated Pdf Viewer Plus is suddenly no longer pre-installed
The Pdf Viewer Plus icon is no longer on the home screen.

Are you sure it’s not pre-installed anymore ? I thought only the icon in the homescreen was removed.

You’re right. It is still pre-installed, only the icon is no longer on the home screen. “App info” shows “Installed” > v3.2

1 Like

If u are installing with twrp after flashing ur ROM twrp will take u back to auto install twrp just click on "do not install " now ur ROM wlll boot up. To install any builds just follow this tips.