Samsung Galaxy builds for unsupported devices suggestions

This is what I found in the XDA forums and could give I try if there is interest…

For eOS Q
*** Samsung Galaxy Tab S 8.4 WiFi (klimtwifi) SM-T700** DONE
*** Samsung Galaxy Tab S 8.4 LTE (klimtlte) SM-T705** DONE
*** Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805** DONE
*** Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-800** DONE

For eOS T, but this will be a challenge:

Galaxy Tab S6 Lite 2022 (Qualcomm)

Samsung Galaxy S20 5G (x1s)

Samsung Galaxy S20 FE

Also open for other suggestions. I can port to Q/R/S or T. however I would need the sources and a manifest file…

Maybe also A73 5G (T) and Samsung Galaxy Tab A 10.1" (2016) (S).

#Samsung Galaxy S20 FE build was successful for eOS-S
# Galaxy Tab S6 Lite 2022 (Qualcomm) was successful for eOS-T
# Samsung Galaxy S20 5G (x1s) was successful for eOS-R and eOS-S

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


I would be keen to give a eOS q a try on my Tab S 8.4 wifi sm-t700

you can try now :slight_smile: I uploaded Q builds on unsupported tablet forum

Hi, unfortunately the Tab sm-t700 eOS q 1.15 build failed to boot, stuck on the Samsung logo.

did you a clean install ?

Hi, yes did a clean install, have you got it to boot?

/e/OS T on any of the Samsung Galaxy S20 models would be a very good idea - S10 is old enough that you can’t find any in good nick around, so S20 would be the only valid option for somebody who wants to stick with Samsungs (due to their features, support base, etc.) and wants /e/OS (like me).

Please see the source information

Can you try to rest and boot a second time or flash again. I recently had the case with a Q build:


  • The rom bootloops only after clean flashing. Force rebooting allows it to boot properly the second time and every time afterwards.

Might be the same here?

I have now tried rebooting once and then second time with no luck. I then tried a fresh install of lineage 17 followed by dirty flash of e1.15 and still stuck on Samsung logo

If you want you can also try this:

:white_check_mark: My solution to the problem:

Unfortunately still no success in booting, after trying above suggestions, will be interested to hear if anyone else has better success.

Does respective LOS-17.1 build work?

Yes I have had lineage-17.1-20221017-Unofficial-klimtwifi and lineage-17.1-20230802-Unofficial-klimtwifi, and also crDroidAndroid-10.0-20220618-klimtwifi-v6.27-LuisRom running on my device

I tried now also 18.1 LOS sources for R build, but got to many errors during build I cannot address

I made builds for S20 for R and S… T will be challenging tough

There are some more and in case of

Samsung Galaxy Tab E 9.6 SM-T560 [gtelwifiue]

, I’d be keen to see a new built( has roomservice file)

This would a be very cool version – it only ever got some rather strange version called dotOS

Samsung Galaxy Tab E 9.6 SM-T560 [gtelwifi]


SM-T560 (gtelwifi, Spreadtrum CPU)
SM-T560NU (gtelwifiue, Qualcomm CPU).

Sorry, I can’t build for versions prior to LOS-17 / Android Q.
Android 7 (Nougat) is not maintained any more. So even if you will be able to build for a newer Nougat version it will be outdated.
I also could not find newer ROMs for this device on XDA forum as LOS 14.1

But I can compile a how-to to build with repo way if you are interested and want to try yourself?

Yes, thank you. I should be getting a Workstation, with 32gb RAM pretty soon.
I do run freeBSD servers, jails, vlan, OPNsense, local f-droid repo and so on, so outdated but same or similar UI can be very useful! Plus offline content on large SDcards is still a thing – for us at least.