Samsung Galaxy S3 I9300 OEM Unlock

Hi, I like to install /e/ on my SGS3 I9300 and startet with the attempt to install twrp recovery.
We are talking about an I9300 with Android 4.3 in factory reset, no root, completely original. Developer options are activated, but OEM unlock option is not visible. USB debugging checked.

When connected to a Windows 7 machine, the S3 is visible in adb. But when I try “reboot bootloader”, the phone reboots the Android 4.3. instead of reboot in download mode.
The same behaviour when I try this on a linux mint machine.

After manually activated download mode I tried “fastboot flash recovery twrp.img”, it says “waiting for device” and nothing else happens.

I tried to connect the phone with Odin 3.04 or 3.13 on a Windows 7 machine, Odin gets no connection to the phone while in download mode.

I tried heimdall (1.4.0) “print-pit” in manually activated download mode, it says “Failed to detect compatible download-mode device”.

It seems, the OEM Lock is the problem, but how to unlock it? I cant find any other way. The OEM unlock option is not visible in the developers options.

??? Any ideas?

Thank you for any help

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @kpt-fish,
i9300 do not have OEM lock so do not have OEM unlock option.
In W7, are Samsung drivers:

  • well installed to use with Odin,
  • or well cleaned to be used with Heimdal/Zadig drivers ?

If there is no OEM Lock, what else is the reason. Odin does not communicate with the S3.
I used heimdall on a Linux Mint machine, but installed Samsung drivers.
What you mean with well cleaned to be used with heimdall?

Samsung’s Android 4.3 does not yet have an OEM lockout feature. Ignore the hint in the installation instructions. The hint is wrong for the device!

Samsung can’t see Fastboot commands, only ADB!

TWRP Recovery must be flashed with Heimdall 1.4.2 or Odin 3.14.4

Ok, thanks. I used Heimdall 1.4.0, that was the most actual I could find for the I9300. Do you have a source, where to get 1.4.2.

The blue text in archje’s post is a link

@lionel.smith has recently installed /e/ on his i9300, he may help you…

With Heimdal under Windows you need to use Zadig’ driver (heimdall-suite-1.4.0-win32/Heimdall Suite/Drivers)

Host machine under Wind°ws is the best and easiest application Odin 3.14.4 flashing twrp-3.3.1-0-i9300.img.tar

HI,

could you use one of your friend’s PC running Linux for flashing TWRP ?

Remember you have to do all Samsung uptades for your i9300 before flashing TWRP…

Édit : do all Samsung uptades for your i9300 before running the /e/ install process
(witch start with TWRP flashing) in a way to benefit of the last baseband (modem) firmware

OK it’s done.

Edit bis : with TWRP, backup your stock-rom before installing /e/.

Edit ter : some users reports problems using the last version of TWRP on olds Samsung devices, if you got errors (in red) when installing /e/ with TWRP, try with an older version.

On what grounds do you support this thesis?


The Galaxy S III GT-I9300 was released in 2012 with Android™ 4.0.4 (Ice Cream Sandwich), got a major update to version 4.1.1 and with Android™ 4.3 (Jelly Bean) in 2014, the official support was over.

The only reason to use the last StockROM Android™ 4.3 is the included baseband firmware 4.3.

For the installation of TWRP Recovery it’s irrelevant whether Android™ 4.0.4 or 4.1.1 or 4.3 is installed.

Hi@kpt-fish
I was a complete beginner but managed to get /e/ on my SGS3 i9300 from 4.3 more by not giving up than following the instructions which are not simple to follow. I tried but could not get Windows to work I have Windows 10. What finally put me onto Linux is there is no release of Heimdall for windows you have to build it. I also found the device dropped out using windows
Ignore anything to do with OEM unlock it was not loaded on the S3. I used an SD card to load TWRP twrp-3.3.1-0-i9300.img that worked for me.
Heimdall installed easily follwing the e doccumentation for our phone.
Install e from custom recovery, ie set the phone to recovery home, vol UP and power. Sideload as they suggest was the only way it worked. Load the file onto the linux computer, I used
e-0.9-n-2020051153544-dev-i9300.zip on the computer and side loaded on the second page of options on the device, do one then the other with the lead attached. Whatever you do before wiping, make a backup copy of the rom, I did not and nearly bricked the phone.
When you have it, updating is easy, put a copy of the new ROM on the SD card, use the backup and recovery from the device and choose the SD card, then restore, it works.
Good luck let me know if you get stuck.
I was worried about downloading a custom recovery from terminal emulator or adb shell but I found a superb website with line to line instructions, I’ve spent the last 48 hours trying to find it but can’t.

Hi Lionel, thanks for your reply and the others too.
I tried heimdall (1.4.0) “print-pit” in manually activated download mode, it says “Failed to detect compatible download-mode device”.

@Archje, you wrote, I have to use Heimdall 1.4.2 , but I have no idea, how to install it. There is a zip file behind your link, but I dont know, how to install that on a Linux MInt System. In the repositories is only 1.4.0 available.Unfortunately I am not experienced user of terminal commands, just able to follow guidelines.
Maybe you guys can provide the way to install that Heimdall 1.4.2.

I’m primarily Wind°ws user and work with Odin 3, try to get ahead with this first…


([HOWTO] Install /e/ on a Samsung smartphone with Windows easily)

(Install latest /e/OS ROM on your OnePlus 5 aka. cheeseburger using GNU/Linux)

@kpt-fish, for i9300 Heimdall 1.4.0 works fine as Odin do.
If you have Windows, for your first flash, use Odin.
Be sure Samsung’s driver are well installed, boot your phone in Download Mode, connect it to your computer and flash TWRP 3.2.3.0 (here https://dl.twrp.me/i9300/)
Reboot in recovery mode, with an sdcard containing /e/ zip file and flash it.
You should be done !!

Sorry, but no. Heimdall 1.4.0 does not work in my case nore Odin. Meanwhile I tried Heimdall 1.4.1 on a fresh installed Linux Mint, but the same result.
When I run Heimdall “print-pit” while S3 I9300 in Download Mode, it replies with “Failed to detect compatible download-mode device”.
@lionel.smith, did I understand right, you flashed TWRP from sd-card?
Can you describe how?

Kpt-fish
Are you using windows still? I could not get Windows to recognize the phone from Odin.
My advice is use Linux, I use Ubuntu 16.04. Go to https://doc.e.foundation/devices/i9300/install and follow instructions. Choose “Get started”, “Download the files”, drop down the list and choose “Samsung Galaxy S III (International)” and click on I9300. Choose the first option “Install” and “click here”

  1. First thing to do “Preparing to install” Heimdall" Click on “Install Heimdall”. Under “Download Heimdall Binaries” Click “here”. Choose the Ubuntu file, do the sha256 sum and put the file in “Home”. The file was Heimdall 1.42 for me. Putting in Home means access is /name/home/file name. The name is the name of the computer owner.
  2. Next under "Installing a custom recovery Click on “TWRP”, download the latest .img file and place it in “Home”
  3. Under" Download /e/ for i9300" click on “Dev” Download the latest .img file check the sha256 sum and place in “Home”.
    Use the Sideload method , it does work. If you don’t understand, do a search for precisely what you want to do. If you get stuck somewhere let us know where. Remember to plug the USB lead in only when they tell you.
    Veil Gluck

Hi,

Are you shure of your cable ?
And of your exact phone model code ?

@kpt-fish did you read this it is a long try and fail and re- try and … success journey !
Be confident, you’re not the first one to flash /e/ into an i9300, it really works.

@kpt-fish
Have you succeeded yet have you tried running Ubuntu from a disc virtually on your Windows PC?