Samsung J7 2015(sm-j700h j7elte): /e/os not loading after sideload

Hi everyone,
I’m trying to install /e/os on my phone. Previously, I was using LineageOS up to the latest update they had available until they discontinued support for this model. Because they’ve discontinued support, I decided to jump ship to /e/os in order to get more recent security patches.

I downloaded the /e/os rom for my phone here and saved it to my pc. Then I rebooted my phone to TWRP (3.7.0), wiped dalvik+cache+data+internal storage+system, then sideloaded the rom, and finally rebooted the phone after sideloading completed. However, after rebooting, my phone is stuck at the screen with the e and the bouncing dot under it. The instructions said it may take 5-10 minutes, so I waited, but at some point it automatically rebooted back to TWRP. I suppose this is what they call a boot loop, although I’m not so sure about that. Either way, I’m now stuck with my phone not booting into an OS for the time being and I need help fixing this.

Besides the above, I’ve also tried saving the rom image to my sd card. In this case, after doing the above wipes, I go to the Install option in TWRP and pick the rom image there. I get the same result: stuck on the booting screen. At one point, I also tried flashing the /e/os recovery rom using Heimdall, but when I did that, I can’t even boot into recovery mode anymore (blank screen after the Samsung logo), so I switched back to TWRP. If I do the above procedure with the LineageOS rom, my phone boots into the newly installed OS just fine, although this rom is probably even more behind on updates than the one I used previously. I wanna get /e/os working here and I’m out of ideas at this point so I hope someone out there can help me.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @prince_zardos welcome to this forum

It may have problem during the download, please retry to download the file, and/or better, compare the md5 sum

I used sha256sum to verify the downloaded file and the result matched with the corresponding textfile. Is that the same as md5?

Different tools for the same goal

Did your change from LineageOS to /e/OS involve a change of Android version ?

If yes it is possible format data might be required.

When loading Android 10, I might try TWRP 3.6, in fact just checked I am Using TWRP 3.5 with Samsung A3 (2016)

1 Like

I think /e/ and LineageOS are both the same on Android 10 (/e/os website says Q). I will try TWRP 3.6 since it’s an option I haven’t touched yet. I hope Heimdall cooperates because it sometimes decides to give me an error and not flash anything at all on the exact same command that worked last time (it happened when I flashed /e/recovery, and it happened again when I tried to go back to TWRP 3.7).

TWRP can install itself any other TWRP version or recovery-e .IMG
But recovery-e can only manage .ZIP

You may have to unplug replug between each heimdall attempt

This bootloop error usually means that you need to format the data partition, not just wipe it.

1 Like

Okay, so after reading the last couple of replies, I’ve since changed my installation process from wipe to using format instead (in TWRP I have to type yes before proceeding), and tried it on TWRP versions 3.6.2 and 3.5.2. I’m still stuck at the same result.

Please try TWRP 3.3.1-0 related to this 2015 device…

I tried TWRP and I still got the same result. Also, this version keeps asking whether I want to install the TWRP app which is annoying.

Maybe TWRP is not the problem. TWRP installs the LineageOS rom correctly without problems. Also, one time I was checking folders in TWRP’s file manager in between installation steps. After wipe/format, some folders like /bin would not have any files anymore. Then I check these folders again after installing the /e/os rom, and I see files where there weren’t any, so I think the install process works.

As I said in the first post, I flashed /e/recovery on this phone at one point, but booting into it results in a black screen after the Samsung logo for me. Maybe the images generated by the /e/os team have assumptions about my hardware that my phone isn’t holding true. I remember having a different problem back when I jumped from stock OS to LineageOS. LineageOS booted into a black screen after the boot animation. It turned out that I needed to flash stock firmware with Android 6.0.1 first before installing LineageOS; my phone was at Android 5.1.1 at the time. Maybe I’m facing a similar problem here, where the /e/os rom is expecting some specific version of whatever that my phone is currently not sitting on. Then again, the 6.0.1 firmware is the latest for this model, and I don’t know if flashing back version 5.1.1 would do any good. I’m just throwing ideas out there at this point hoping something would be useful.

Since it has become apparent that this problem might take a while to reach a solution, I’m considering installing some unofficial rom from xda-developers so I can at least have a working phone in the meantime. I’m not yet giving up on /e/os because I prefer to have ota updates and official support from maintainers and all that good stuff. My question is if I manage to install a rom with higher Android version than /e/os, would that potentially make installing /e/os later more problematic than it currently is?

Have you tried to reflash Samsung firmware and then /e/ ?
(a clean install from scratch)


Last idea : have you tried an older /e/ build ?

I notice that the Lineage device tree is on Android 11 (R).

If your phone was once on Android 11, I would have expected TWRP to perhaps fail to downgrade to Android 10 (Q), but I would have also expected TWRP to have reported the issue.

Maybe this is the issue you face now (although no evidence to support this).

As more general advice if performing an Android version downgrade, it can be beneficial (older Samsung) to Use ODIN to restore the phone to the final software revision.

To stop us all having to guess (and then hopefully give you useful advice), it might be good to share your old installed version described as

and linking your proposed new


I actually tried that just in case maybe the /e/os rom is expecting more recent firmware for my device. I flashed J700HXXU3BVH1 firmware dated 2022 (the previous firmware was dated 2019-ish but I don’t have that file anymore so I can’t say for sure). They were both Android 6.0.1 so I don’t know if the newer date makes a difference. Anyway, it still didn’t work.

edit: I’ve also tried installing an older /e/os build, but the oldest available on the official website is 1.8 so that’s as old as I have available right now.

The old version I had was That was the last version before it was discontinued, and the version that was lost due to wiping then overwritten by /e/os. I would prefer to go back to this version if possible, but I don’t think the official site carries this rom anymore. I’m pretty sure it was Android 10 because I remember LineageOS’s discontinue announcement saying it was too different or whatever to upgrade to Android 11 which is the minimum version they want to support. I haven’t decided which rom I want to use yet due to the concern I mentioned, but for now let’s suppose I want this unofficial LineageOS 20 just because it also specifies which version of TWRP it wants me to use.

I do not see any bugs filed Gitlab issues - j7elte + bug so you might consider to report an issue. It was once reported Week 16 : 2021: Development and Testing Updates that an issue existed due to lack dedicated ROM Maintainers. I do not know if this is still the case with this device.

As you have had no luck with these builds, I can see that you would experiment, perhaps I should add e/OS + Android OS version names and numbers? - #3 by aibd otherwise,

1 Like

There could be conflict between security patch date

Hi everyone,

Thanks for all the advice so far. I’ve definitely tried some options that I would’ve missed if not for all your input. Unfortunately, at this point I still could not get /e/os installed on my device.

I figured I’d report the issue as user @aibd kindly linked in their reply, what with this whole thread being easy to link to for details into the issue. But it appears to me that the user registration procedure won’t let me use my email address to register. It said something about using work email or whatever error that was. I have no such email, and even if I did, I’d only use it if this whole thing was for official business of whatever company would’ve been providing me that address, which is not the case here since I’m using it for my personal phone. So I guess I’m not reporting any issue at the end of the day.

I’m not giving up on install /e/os on my device, but for now I have to move on to looking for a working rom to install on my phone in the meantime since it has been out of operation for too long. I will still check on this thread every now and then and hopefully run into something that finally works. It’s just that by then, it won’t just be as simple as format and flash because I’d probably have to do backups and stuff again before I can get to installation.

There is an anti spam measure mentioned in the Report an issue link !

Getting an error message in new ID creation on /e/OS Gitlab?

This topic was automatically closed after 180 days. New replies are no longer allowed.