[SOLVED] Fp3 - gps/location never working

about phone: FP3
/e/os version: 1.6-r-20221129238947-stable-FP3


i’ve read about the issues some people are having with advanced privacy (when turned on) ranging from very slow/nonexistent internet connection to impossibility of using maps apps.

and im also aware that it is still a work in progress so im happy to wait for more update to fully embrace it.

however, the problem im having with gps/location happen anytime, even if the advanced privacy is off.

basically, my phone has always been slow in finding my location and such, but now it just doesn’t find me at all.
i turn it on and wait for a looong time and yet no apps manage to locate me.
not even the native magic earth!

is it a problem someone else is encountering too?
can anyone help?

Rebooting the phone doesn’t help?

Else … [HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc


tried rebooting and it didnt work.

ive updated the original post with what i believe are the necessary info.
please, let me know if you need more.

1 Like

I don’t have this problem on 1.6-s-20221201239247-dev-FP3, and when I was on 1.5-r briefly I didn’t encounter it either.
If occasionally location didn’t seem to work for me in the past, a reboot fixed it for me (on other phones and OSes, too).

You can also try to turn off the phone (no reboot, real shutdown) and turn it on again. I’ve seen real shutdowns make a difference with network hickups of several sorts when reboots didn’t help, so who knows.

GPS only without other means of locating like cell towers or Wi-Fi networks can be slow to get a first location fix (up to quite a few minutes).

For testing be sure to be outside ideally or at least at a window with a healthy chunk of visible sky.

Check that all is ok in Settings - System - microG - Self-Check, especially the location-related permissions in section “Permissions granted”.
Check that Settings - System - microG - Location modules - Mozilla Location Service is enabled (unless you disabled it deliberately).

Check that Settings - Location - Use location is enabled.
Check that Settings - Location - Location Services - Wi-Fi scanning is enabled (unless you disabled it deliberately).
Check that Settings - Location - App location permissions lists the Apps you want to use with location under Allowed (it’s “Allowed only while in use” for me) … else enable Settings - Apps - See all … apps - (the App in question) - Permissions - Location - Allow (probably “Allow only while using the app”).

You can try whether turning on Advanced Privacy, setting the “Manage my location” setting to “Use my real location”, then turning Advanced Privacy off again makes a difference.


i shut it down and turned that on (which i don’t know why it was off in the first place, and location is now working again!

thank you very much! :smiling_face: