[SOLVED] No sound in Xiaomi MI A1

I’m instaling my “new” xianomi MI A1 and it has no sound in calls. Any adeas?

Try a bluetooth headset?

Found the solution in XDA on this link

Thank you very much

Super, everything ok now?

Hi @Erekoze please can you share some more details to understand what you were trying to do when this issue happened. Was this the first time you flashed on top of the stock Oreo ROM or was it on the Stock Pie ROM. Also is the issue now resolved?

I Just get the device so… the first thing to do is flash /e/ on it. No special circunstances.

Which was the version of the operating system on the phone when you flashed /e/

I belive it was Android P. Didn’t see the need to check it.:no_mouth:

I guessed so. Pie once installed on the MiA1 makes the device misbehave when reinstalling Oreo or Nougat. Had this same issue when reverting from Pie . There is a test Pi/e/ build for MiA1 which I am using in case you want to try it out or In case your Oreo build is working perfectly you can stay on with that.

Ok I’m gonna try it.

I had the same problem and this solution worked for me to. But, after the last update i coudnt make calls again, i went to the build.prop and it is a blanck doc… Can anyone share the content?

Sorry, I have problems with my device. May @Manoj could help you with this.

I am on a test Pie version that will not work. You will have to check for the build.prop from an oreo device

A different solution was proposed by @Phie from the /e/ Dev team …check the thread here a different TWRP solved the issue for him.

1 Like

First time poster here, with the same problem of not hearing any sound during calls with a Mi A1.

The phone is not rooted, but I have been trying to follow the method highlighted by @Erekoze in a reply on Jun 11, '19. It appears that /system/build.prop can be pulled, edited locally on the PC, then pushed back to the phone and without requiring root access.

I have an authorization problem that is preventing me from doing this.

The phone is recognized by adb devices when the phone is booted normally. I selected Always accept connections when asked to do so. However, when the phone is booted in recovery mode, adb devices shows that the device is unauthorized. It’s very strange. Without authorization, I cannot pull or push files to/from the phone. I’ve been going around in circles wondering why the phone is not recognized in recovery mode, but is recognized when booted normally.

I’m stuck with a silent phone until I can solve this.

My other option is to root the phone, but I am not confident about doing this and do not want to wipe the phone if I can avoid it. This is the reason why I have been pursuing the option of editing /system/build.prop.

Do you have a suggestion about how to fix this authorization problem?

Phone is running Android 8.1.0 / LineageOS 0.7-o-2019122435222-dev-tissot according to the recovery screen.


I got exactly the same error with the same file dated 24/12/2019 Oreo. I upgraded to pie and everything is working fine, @YZkFixye

Thanks, @Erekoze. That’s good to know. It appears that version upgrades (eg Oreo to Pie) are not handled OTA, so I’ll follow the wiki instructions. I hope this will not require wiping the phone … deep breath :slight_smile:

I’m a bit confused about the exact process to upgrade. This thread indicates the need to upgrade Mi A1 firmware, and flash a stock Pie ROM prior to installing LineageOS/Pie. The wiki mentions none of this and I do not know whether the prior requirements have been superseded by a newer ROM version.

I’ll be using the ROM image mentioned in this thread unless you can suggest a more suitable one.

Thanks for your help with this. You have saved me a lot of time and frustration!

Hi @YZkFixye the upgrade to stock Pie is required if you are moving from nougat /Oreo builds to /e/ Pie. This is because there are firmware updates required to make the /e/ Pie run correctly.
It is not covered in the wiki because the official build of /e/ is still running on Oreo.
Downgrading the MiA1 from Pie to Oreo does not work and can cause issues.
So if you are currently running stock Pie build on your MiA1 do not flash /e/ Oreo builds on it. You would need to flash a Pie build on it . Currently we only have unofficial Pie builds for MiA1.
Official OS upgrades is planned for most devices but currently under testing.

Hi @Manoj, and thanks for your reply. Phone is running Android 8.1.0 / LineageOS 0.7-o-2019122435222-dev-tissot, so I guess not “Stock” Oreo.

Is this the upgrade process then?

  1. Upgrade firmware
  2. Flash Stock Pie (overwriting LineageOS Oreo)
  3. Flash new LineageOS Pie ROM (e-0.7-p-20191024-UNOFFICIAL-tissot)

Is step 1 still required if firmware updates are included in the Stock Pie ROM?

Will all this completely wipe my phone, or are the OS changes happening in a separate partition from my data? (I know it’s important to backup first, and I have done so.)

Sorry for the noob questions.


Flashing the stock Pie ROM will update the firmware. Post that you can flash the /e/ Pie unofficial ROM