[SOLVED] No sound in Xiaomi MI A1

OK. And will this completely wipe the phone?

When I tested this out the step that I followed are documented here. As mentioned there I formatted and then wiped system + data + cache before the install.

Flashing a StockROM firmware deletes everything on the device irrevocably.

It’s therefore necessary to back up your important personal data before flashing.

Thanks. I’ll proceed with caution :cold_sweat:

Not a great start. I’m stuck in a boot loop after flashing the phone with the fastboot image from tissot_images_V10.0.16.0.PDHMIXM_20191206.0000.00_9.0_494f11505e.tgz using MiFlash 2018.5.28.0.

The phone is now in fastboot mode waiting for my next move. Right now, it is winning and I am losing.

What should I do next?

Is the 10.0.16 the latest stock build for the MiA1 ? Try with the latest stock and MiFlash…the guide was written some time back and they were the latest versions then.

10.0.16 is the latest fastboot image available from this site.

There is a newer MiFlash (20191206) available here. I’ve installed it but it generates an error during the early stages of flashing “couldn’t find script” when I select the “save user data” option, as directed by the installation instructions.

Just mentioned in passing: There are also TWRP Flashable Firmware *.zips available for the Xiaomi Mi A1.

I found a twrp flashable zip and start with it. It was a pie december updated

Thanks @archie and @Erekoze , but I don’t have TWRP installed. Is there an advantage in doing so? Being a noob, I’m trying to stick to specific instructions like these rather than using methods that rely on a level of overall understanding that I do not yet possess. :slight_smile: Happy to pursue a TWRP option if you think it will help.

If the method of flashing works as @Erekoze mentions then no harm in trying it out.

TWRP installation must be done anyway to receive /e/ OS ROM OTA updates in the future. And he touch operation is very easy for everyone …

Update
I didn’t express myself clearly and correctly: TWRP isn’t necessary for downloading OTA updates, but for installing the OTA Updater automatically. Read more …

Well, that settles it. I’ll install TWRP and use the TWRP ROM to install Stock Pie. Thanks.

TWRP installation is also not going well. The boot-loop phone is now in Fastboot mode but is not recognized by adb devices, so I cannot begin to install TWRP. My sense of panic and defeat is overwhelming.

Yes, the idea of flashing with StockROM via TWRP came at a bad time. Nevertheless: Don’t give up - keep going, keep going … Can you try (Popular Links) → Xiaomi Flashing Tool Miflash v2018.5.28.0 Portable

Did you try rebooting your device directliy on fastboot mode

On a terminal type adb reboot bootloader
it gotta say you’re in fastboot mode
type ‘fastboot devices’ to ‘see’ your device
after that you can instal twrp .img

Maybe the first thing you wish to do is to flash twrp.XXXXXX.zip via sideload

**"after that you can sideload the stock rom using sideload or from your internal memory (if you copied before all this) " Forget it. I was not thinking clearly when you sideload the stock rom it brings the stock recovery, sorry.

(Sorry for the delay in responding. I used up my new user allocation of posts yesterday!)

TL;DR It’s now working! :beers:

Drying my eyes :cry:, I returned to the idea of flashing the Stock image using the MiFlash tool 2019.12.6.

The previously-noted “couldn’t find script” error is trivial to solve and it was my own mistake for not noticing this. MiFlash has a terrible user interface: unlike the previous version of the tool which shows only three radio buttons (‘clean all’, ‘save user data’ and ‘clean all and lock’), this new version also has a dropdown dialog where you must select the batch file name (!). If you click on a radio button but leave the dropdown blank, it will generate the “couldn’t find script” error. The batch file names are not intuitive and are also not related to your radio button selection. All round, a confusing mess!

I selected _Flash_erase_userdata.bat and it appeared to be doing something. After a very long wait, the phone eventually finished its reboot sequence and booted into Stock Android 9 Pie. It was quite a shock to see all those Google Apps staring back at me because I want to get as far away from them as I can :slight_smile:

I’ve checked that sound is working during calls. This was the problem in the first place that I am trying to fix. Sounds works fine for incoming and outgoing calls. :+1:t2:

I continued to follow @Manoj’s instructions , enabled developer options on the phone, rebooted to Fastboot, then booted into the latest twrp-3.3.1-0-tissot.img from here. From the TWRP screen (on the phone), I tapped format data, then wipe system + data + cache (ignoring the ‘failed to mount /vendor’ errors). I downloaded a /e/ Pie image for the Mi A1 (tissot) e-0.7-p-20191024-UNOFFICIAL-tissot.zip and sideloaded it to the phone … then rebooted.

/e/ booted successfully and I have spent the last hours reinstalling apps and updating settings. I even received a voice call that worked!

Noob question about backup and restore
I backed up the phone under Oreo prior to wiping it (heart racing) using adb backup -apk -shared -all -f my-backup.ab. After upgrading to Pie, I restored the data using adb restore my-backup.ab … but nothing really seemed to happen on the phone, even after rebooting it. I’d expect that settings, apps and documents (e.g. photos) would be restored to the phone but nothing seems to have happened. What should I expect to see after a restore? Do backup and restore work properly across Android versions, or are they intended only to be used within Oreo or Pie and not between them?

It’s not a showstopper in this case because I kept very little on the phone that could not be recreated from other sources. It’s just a question for future reference.

So, my Xiaomi Mi A1 is working as a phone again, sending and receiving voice calls. It’s been a high adrenaline couple of days. Thanks to everyone who responded to my noob questions so readily and thoughtfully. Thank you all!!

Hi @YZkFixye good to hear that you were finally able to get the /e/ ROM on your phone. Flashing ROM’s no matter how many times you do it has to be done carefully. You never know which step may go wrong. Hopefully we should have the official Pie builds flowing out for most devices soon which will be OTA. Again you will have to flash one official build manually and then the subsequent builds will update OTA.
On the backup issue - I am not sure as I have never tried it - or rather never got an opportunity to try it as I have to flash test ROM’s frequently and keep wiping the whole phone :frowning:

1 Like