[SOLVED] Problem in the /e/ installation procedure for my Samsung S4 mini

I’m blocked in the /e/ installation procedure for my Samsung S4 mini from a Windows 10 PC in the build of Heimdall. The console message is the following:

cmake -G “MSYS Makefiles” -DCMAKE_BUILD_TYPE=Release -DQt5Widgets_DIR=/c/msys64/mingw64/qt5-static/lib/cmake/Qt5Widgets …
– The Fortran compiler identification is unknown
CMake Error at CMakeLists.txt:5 (project):
No CMAKE_Fortran_COMPILER could be found.

Tell CMake where to find the compiler by setting either the environment
variable “FC” or the CMake cache entry CMAKE_Fortran_COMPILER to the full
path to the compiler, or to the compiler name if it is in the PATH.

– Configuring incomplete, errors occurred!
See also “C:/msys64/home/xxxxxxxxxxxx/build/CMakeFiles/CMakeOutput.log”.
See also “C:/msys64/home/xxxxxxxxxxxx/build/CMakeFiles/CMakeError.log”.

May somebody help me?

There are several posts here in forum.regarding this issue.
Could you please use TWRP like described here ?Heimdall VS Adb


If you have Windows, this procedure is easier :

Using the open source Heimdall with Windows has many pitfalls. I recommend to use → Samsung’s Odin3 v3.14.1. I’ve made best experiences with it.

Thank you very much.

Yes ,the procedure through Odin is really easier. But it failed for me because once is TWRP mode and after the “Swipe to Wipe” I discover I lost the USB connection with my smartphone. So it was impossible to download the /e/ zip and install it (It should be better to copy the file before) I decided to put it on a microSD but now I fail to go back to TWRP mode after the smartphone switch off then on.

Yes, storing the necessary files on an external mircoSD card and installing from there is a secure way.

When you boot into TWRP Recovery Mode by pressing a key combination on the S4 mini - what happens? Which messages are displayed?

I have only the Samsung Galaxy S4 logo …

Okay, that’s not bad! There are several possibilities TeamWin - TWRP to flash. Here is an absolutely safe variant.

A) twrp.img.tar is stored on the microSD.

B) Start Odin3 in admin mode.

C) UN-check “Auto Reboot” under "Options

D) Launch the S4mini into “Samsung download mode” by pressing a key combination

E) Connect the S4mini to the Windows PC via USB cable

F) If the S4mini is recognized by Odin3, add in Odin under “AP”: twrp.img.tar - Click in Odin 3 “Start”

If the operation was successful …

  1. disconnect the S4mini from the Windows PC

  2. remove the battery for a few seconds

  3. insert the battery as described above and start the S4mini in TWRT mode by pressing the key combination on the S4mini.

  4. now we make a so called “clean flash”.
    4.1 Tick (check on): Dalvik/Cache | System | Data | Cache
    4.2 After ticking: Swipe below to “Wipe”
    4.2.2 Optional, depending on your needs: “Format data”
    4.3 Once the wipe has completed return to “Menu”
    4.4 Flash /e/ OS ROM *.zip from the microSD via “Install”.
    4.5.Penultimate step: Wipe Dalvik/Cache

  5. Last step: “Reboot” your System

Now the system should be reinitializing itself. Just wait until the animated e-logo is displayed.

Yes it works !!!
Thank you very much

Great! Welcome to /e/ club, @plloyd

I have very similar issue with my Samsung Galaxy S4 mini LTE smartphone.
I used on this phone the LineageOS before and want to install the /e/ system on it.
So I have already installed TWRP version 3.3.1-0 installed with the twrp-3.3.1-0-serranoltexx.img.
I used to use adb -t with this phone, but some days I don’t.
I do not know what happen.
From my Xubuntu 18.04 I can’t use adb to reach my smartphone any more whether in download, or in recovery mode.
Also after I plug in smartphone in to USB of my laptop the Xubuntu system recognized it and I can read/write to its sd cards ( two of them - one for the LineageOS and other just for storage ). But some days I can’t use my smartphone like this. The icon does not appeares any more on my desktop.
lsusb does not show my phone anymore.

So I copy the e-0.7-n-2020021541379-dev-serranoltexx.zip to the external sd card in my phone like this: I removed the card from the phone, put it in to an adapter and attached this to the computer. This way I can copy the ZIP file to the sd card.

After this I put the card back into the phone. In TWRP recovery mode did “clean flash” and try to flash the zip file via “Install”.
But the slider stops before the end and freeze out there.

At this step I can only Power Off my phone with Power button and go back in to TWRP.
I can’t use LineageOS any more because I delete it’s zip file from the sd card.

Why stops the installation process before the end?
How can I solve this issue?

Best, Paul

my recommendation for the Samsung Galaxy S4 Mini (International LTE) - “serranoltexx” GT-I9195

Go back to StockROM KitKat Android 4.4.2 and install TWRP Recovery and then via TWRP > “Format data” (max. “clean install”). Now install cleanly /e/ OS ROM for /e/ for serranoltexx dev (nougat).

1 Like

I solved my issue with a cord - an USB cable - which I change and after that I can run adb commands to my phone.
Just finished the adb sideload, and just rebooted to /e/ system.
So far I can see only the /e/ logo on my phone, but hope in that that it will go on automatically and start the /e/ system on my phone.
Success here!

Yes, the original USB cables work best.

Is the /e/ logo animated on your phone?

The first initialization may take some time and may be unsteady. Just wait for a while …

Yes, the /e/ logo animated on my phone.

Btw seeing that you are using nougat version, there is an unofficial pi/e/ version for the s4mini, which can be found here

And - what is the situation?

Is the /e/ OS ROM completely and successfully installed and working as desired?

Yes, the /e/ OS ROM is completely and successfully installed and working as desired.
Thank you very much for help!

Well done. Very nice - one /e/ user more. Welcome to the /e/ club.

Could you pls add [SOLVED] to the headline of your first post ? Thx