[SOLVED] Problems with FP2 Update from Q to R

I’ve installed 0.18 R on an unencrypted FP2 running 0.18 Q following documentation /e/ OS Version Upgrade.
But when starting the device after the manual R installation the phone tried some time to boot and then rebooted into recovery.
Doing a factory reset made the device boot successfully.
After restoring my backed up data the FP2 with 0.18 R is now running fine.
Did someone else succeed with the upgrade without doing a factory reset (i.e. without wiping data)?

1 Like

I debugged that one. The exception is fixable in code by forward porting changes done in the past from Q to R… so users not wanting to reset can wait until this is fixed… or use the workaround


Will this fix also work for FP2?

problem exists independent of device


Thanks, what a great solution/workaround! :+1:
I can confirm that it also works for FP2. Removing the mentioned lineageossettings.db also made the update from Q to R work an my FP2! :slight_smile:
Hope the fix will soon by productive.
Will update the GitLab topic accordingly.

1 Like

Until the fix has been included, this post describes how to ‘do it yourself’ and ‘dirty flash’ an R build over a Q build without losing data: