Sony Xperia XA2 your device is corrupted and cannot be trusted. Your device will shutdown in 5 seconds

You don’t want to try and permanantly install twrp, even though some instructions seem to point to it.

Trying to understand your steps so far…

If you followed these steps

“Once booted, navigate to the Advanced > Install Recovery Ramdisk option. This will ask you to select the image you want to install TWRP from. Select the TWRP image you just downloaded and copied into device storage. Proceed to install this image.”

I wouldn’t know how to help.

I followed the instructions up to that point.

I should be able to fix this when I reflash with Emma or not?

You ‘proceeded to install’ the image you had copied to device?? and then tried to ‘fix recovery bootloop’ etc? Is that right?

If yes, then carrying on might end up in a mess. But emma can help if that happens.

Yes, that is right, i did so.

Should I reset the phone completely with the help of Emma?

OK, got it.

Up to you , might be worth a shot proceeding, I don’t know.

With twrp up, next step would be the copy partitions step on LOS instructions…

Followed by, wiping procedure in /e/ instructions (cos e has it right for twrp)

Then sideload the OS zip

And if you get as far as twrp shows sideloading completed I would recommend the following steps

unplug phone and on twrp select reboot > recovery

The phone will then reboot hopefully into LOS recovery where you can reboot system.

It is the first time I do something like this so: What is LOS Recovery?

Sorry, LineageOS recovery. the recovery that comes in the /e/os. I’ts lineage. As /e/ is derived from lineage.

My experience with xa2 is that going to recovery first helps sometimes. It can point up problems and solutions…sometimes. where booting straight into system from twrp doesn’t.

Got to go now, but I can be back in about 30 mins if you wanted more :wink:

I was about to do Reboot to Recovery, however I am confused because it says:
"No Os Installed! Are you sure you wish to reboot?"

That message will always be there at this point, ignore.

Bootloop, perchance?

just in case you didn’t know…and excuse me if you did.

If you need to force power off and power button on its own won’t do it, then use combination button press :

gently hold power button + vol.up, wait for 1 vibrate followed by three quick vibrations and release buttons, phone powers off.

When you have twrp installed for the first time reboot phone into twrp again even if it said no is installed. Just make sure you reboot into twrp, then flash /e/ on you phone and reboot normally. Done!

Thank you for all the replies. I got /e/os installed yesterday and everything works. Yesterday I could no longer reply because it said I had already reached the maximum number of replies for one day as a new user.
However, the fingerprint sensor is not recognized, so I can not store a fingerprint, does anyone have an idea how I can fix this?

Well done for getting eOS onto your phone!
Which os version are you currently on and was it installed at the end of that last session?
Or did you have to go back to emma?
Answers will help narrow down the options.

Currently I have /e/OS 0.13(Android 8.1.0).
I went back to Emma as I did not want to take any risks.

Good move :slightly_smiling_face:

Can’t help with the sensor but I seem to recall it worked on e-oreo, if a bit unreliable; had to keep resetting it. However that was back in July last year: version 0.9.


I ran the pie testbuilds from July to the end of the year; very stable and fingerprint sensor good nearly all the way.

There should be an upgrade to Q for the XA2 early next month

Both would be best with a return to emma for 50.2.A firmware before installing.

Ok, then I wait for the Android Q update at the beginning of February.