Sony Xperia XZ1 compact

My english is not very good and I don’t know anything about smartphones. But I have a really great small phone, Sony Xperia XZ1 compact G8441

  • Android versions (that I know of) : Oreo and Pie
  • It seems to be on Havoc but I’m not sure. Int’s not on LineageOS though.

Sorry I have nothing else to give you but I would be very happy if it could run on /e/ OS.
Thank you

1 Like

Bonjour ou bonsoir, est-il possible de basculer le XZ1 compact sur le nouveau système ? Merci pour la réponse.

Pas pour le moment malheureusement je crois

Good work. Would definitely love to have an up to date XZ1 Compact. Cheers!!

Thanks a lot, that’s a very good news !
Let us know when you’ve tried it

When I got my XZ1, I didn’t use my unofficial build. Instead I used A GSI built by @harvey186. See this thread for details of what I did.
His latest images are at, and the one to use for the XZ1 Compact is

I think that image is unencrypted, so it should be possible to backup your apps and data (using TWRP) if a later build becomes available

The one I used worked pretty well except for making and receiving calls, where I ran into problems. In the end, I think those problems are caused by defective hardware (the problems also occur using a Stock firmware, and a Lineage ROM). When a replacement arrives, I’m not sure whether to go with the GSI, or with a device-specific unofficial build (mostly because the GSI is 2 months old, and I would prefer a more recent version of /e/)

More background to my experiences in this thread

Hi @petefoth neither your unofficial pie build for XZ1C nor the GSI version did work for me. It did not boot, so I tried instead the LOS17 you posted. This works fine so far.

See this thread for more details of my experience with XZ1C and GSIs. I am currently running one of @harvey186’s Pie GSI builds from here which runs OK. I’m still hoping to see a working device specific /e/ build sometime, but I don’t have time at the moment to try and build one myself

Is the camera working OK with that build?

Thanks for the info about GSI. I never tried anything with GSIs. I’ll try to understand in a few days.
Yes, my camera is working OK with LOS17. I use it with the app “simple camera”.

Good morning everybody!
Are there any news regarding /e/ support for the Sony XZ1 Compact? It’s really a nice and handy mobile and it would be a pity, if there is no /e/ support for this lovely machine. Thnks! regards!

1 Like

I read all threads about XZ1 compact and I’m a little confused.
As a newbie I installed /e/OS official on a Samsung A5, following official documentation.
I expect the Xperia not to be as easy to install.

It seems to me /e/OS is only available in GSI.
Is there anywhere a how-to as easy to follow as official one ?

If not available, do you advice me to install LineageOS as a first step to un-googleize the XZ1 ?

Thank you very much.
Thank you.


I’ve spent some time trying to get /e/ running on XZ1 Compact - I’m the one who started a lot of the threads you’ve been getting confused by.

The only build of /e/ that I have had running on my XZ1C devices was a nougat-based GSI built by @harvey186 quite a while ago. It worked pretty well - thanks @harvey186 - but i really wanted something a bit more up-to-date :slight_smile:

I succeeded in building an unofficial /e/ pie ROM but I couldn’t make it work - my device kept boot looping.

I have also tried some of @harvey186’s GSIs (pie and Android 10 / Q), both /e/ and his own LeOS. These builds have run successfully on many devices but I don’t know if anyone has got hem to work on a XZ1C - I certainly haven’t. I think there is just a problem with XZ1C and Android 10 GSIs - as discussed here. Or maybe I’m just unlucky!

I have managed to get a couple of Android 10 ROMs working:

  • I currently have HavocOS 3.10 Official with NanoDroid running on my ‘daily driver’. (I started with v.3.09 and upgraded - by dirty-flashing - to 3.10 with no problems. I tried a couple of days ago to upgrade to v3.11: it seemed to work OK, but it wouldn’t play nicely with my backed-up apps and data, so I rolled back to 3.10 as I can’t be bothered to set up all my apps from scratch).
  • I have also tried out an unofficial Lineage17.1 ROM on my spare device, and that seemed to work OK too. I had to apply a signature spoofing patch to the ROM as described in this post to get the latest microG working.

I am currently trying to build a LineageOS for microG 17.1 ROM. Yesterday the build got to 99% before running out of disc space. 'Ive freed up some space and it’s now at 96% \0/ If it builds, I will test it and report back in the Unofficial Builds category.

As soon as a working Docker image is made available I plan to try an /e/ Android 10 / Q build. Again I’ll report back as to how it goes. I may also have a try at building without Docker, but there’s a bit of learning fro me to do there, so don’t hold your breath :slight_smile:

If you wanted to make a start immediately, then I would go with the Havoc OS / NanoDroid mix or, if you’re comfortable running the patcher script, the Lineage 17.1 / NanoDroid. Or you can wait and see if I (or any of the other unofficial ROM builders) get lucky with an /e/ Q ROM.

I hope that helps, and good luck! :slight_smile:

1 Like

Sadly the LOS4microG build failed - see this post

Tomorrow I’ll have a try at building a Q /e/ ROM without Docker

1 Like

Well it took a bit longer that I thought, but I finally have a build which seems to work :slight_smile:

Details in this post.

Feedback welcomed :slight_smile:

1 Like

This device is now officially supported. :slight_smile:

e-0.15-q build, along with installation instructions is available here

1 Like

This is an excellent news. Thank you so much.
I’m really bad with all this but I can’t seem to be able do download the /e/ OS build :frowning:
The page is unavailable for me…
It says I don’t have permission to access on my server.
Does anyone have any idea why ? And how can I download it ?
Thank you

There’s a problem for me too. I’ll try and get it sorted but it may not happen over the weekend. Sorry!

Waouh thank you very much and no problem I am not in a hurry :wink: