Teracube 2e easy installer restart error

I recently purchased a Teracube 2e from the teracube website. I have been attempting to flash /e/os onto it (from windows 10) for the past couple of days, but am experiencing an error with both the easy-installer and my attempts at manually flashing it over using the command console.
I installed drivers for the device, turned on dev mode, USB debugging and unlocked it. I have been able to get the PC to detect the phone while in fastboot mode, and begin the process of transferring the image files to it without problem. Both times the error seems to happen when the phone attempts to reboot into fastboot mode (AFTER flashing some of the images onto it.), rather than booting straight to fastboot, the phone will boot to a graphical menu who’s options are to reboot the phone, boot to recovery, boot to bootloader, or power off the phone. The easy installer will then wait for the phone indefinitely, while the bar still slowly fills. If I choose to load into bootloader, it will restart and load to fastboot, but the installer with throw an error. (I can try again when I get home and upload the log file here.)

When attempting to manually flash, I run the line

fastboot reboot fastboot
and it boots into the same menu. when I get it into the fastboot mode, the console returns the error
“fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable”
and then refuses any further instructions. The phone is similarly unresponsive, and If restarted it enters a bootloop where it says the phone cannot be trusted and restarts, and I am forced to flash android back onto it.

This is my first time flashing an OS to a smartphone, so I am not sure how to troubleshoot this issue myself, and I have been unable to find anyone else experiencing this issue. Help would be appreciated, and if there is any further information I could provide I will do my absolute best to help you help me.

Hi @MathiasV welcome to /e/ community.

Are you aware of fastbootd?

You might check this link:

Bon chance

I had assumed fastbootd was the same as fastboot. I will read through that thread and see if I can solve my problem with the advice given there. Thank you for the lead.

I have same problem. After first restart phone boot into recovery mode and fall to error.
I try to install manually and found problem on step 7 of official installation manual (Install /e/ on a Teracube Teracube 2e - “2e”) Problem with mounting system partition. Fastboot and recovery mode can’t find that partition.
Solution it is.

  1. Did first 6th steps from official manual.
  2. Reboot to Recovery mode by press Volume plus + Power simultaneously
  3. Choose menu Enable ADB
  4. In your terminal on computer type adb shell
  5. Then enter command chmod -R 777 /system in opened shell
  6. On the phone choose menu Mount /system twice.
  7. Choose menu Enter Fastboot
  8. Do 8-11 steps of official manual.
# fastboot reboot fastboot

command doesnt work from root on linux with fastboot version 1:8.1.0+r23-5ubuntu2. hm…

Thanks for replying Ivan. I will try that and post results.

What would a fastbootd screen look like? My phone boots to this, which I have found out is close to what e recovery looks like.

After trying what Ivan suggested, on step 8. entering the command

fastboot flash system system.img

command prompt returned with

Sending sparse ‘system’ 1/13 (131068 KB) OKAY [3.010s]
Writing ‘system’ FAILED (remote: ‘This partition doesn’t exist’)
fastboot: error: Command failed

So no dice.
Still trying to figure out how to get it to load into fastbootd by trying to read the other thread. I dont think my problem is an out of date fastboot bundled with ubuntu, as I am on windows 10 and installed fastboot only 2 days ago.
My fastboot version is 31.0.3-7562133

It is fastboot already on the screen! I hope you mount system partition before as from step 4-6?

Sending sparse ‘system’ 1/13 (131068 KB) OKAY [3.010s]
Writing ‘system’ FAILED (remote: ‘This partition doesn’t exist’)
fastboot: error: Command failed

1/13? Very strange. My stdout is saying 1/4 system…
Are you download original eOS img from here?
https://images.ecloud.global/stable/2e/
And, you are nt installed another OS like iodeOS before? Phone is factory clean? I recommend to you flash phone to factory android and then try install again.

… and did you already try (quoting myself in the link above)

I have to say that my “latest” platform tools did not reliably reach fastbootd, but I learned to run as root:

# fastboot reboot fastboot

Edit, unhelpful suggestion, after post #14

If it is at all reassuring, this is the error I saw when I failed to get into fastbootd - or “moving Fastboot to Userspace” :slight_smile:

Well I tried using a VM running Linux to install it, and while doing that, I figured out that whenever I reached that menu screen, windows thought that the phone that was connected was a Google Nexus 4, and the error was caused by not having a driver for that device. I went and installed the driver from the link below, and all of the sudden the Easy Installer worked fine on windows 10 for me. Seems totally bizarre and I have no idea why that was happening. But I have e/OS working fine on my Teracube 2e now!

I’m having this same issue and also first time flashing an OS to smartphone.
Just did step 7 fastboot reboot fastboot and…yep, same results.
This is the scientific method eh?

Using Windows 10 and recent drivers.

What menu - phone or computer? I’m not seeing either option :woman_facepalming:

I’m going to try this! Did you have to uninstall all ADB drivers like some of the comments said? Windows is not letting me select this driver for my Teracube 2e.

Hi @cc7 there is a very informative new post here in documentation suggestions post #28

When using Windows and you are unsure if drivers are an issue you can open a Windows device manager window before you connect your device. Now connect the device. you will be looking for the device appear “healthy” or with a :warning: indicating drivers required.

Windows update should fix this for you. Please refer to the subject of updating drivers on a Fairphone if you need help with this.

Continue with your install instructions with the device manager window open. There is the possibility that Windows will have installed a driver that works in the mode where the device was introduced, but fails in a subsequent booting mode. Should :warning: reappear ask Windows update to fix it for you.

On phone after boot into Recovery. Menu Advanced → Enable ADB

@aibd, thanks for mentioning my post above (“here in documentation suggestions post #28”). @cc7, I would highly encourage you to read the post because I had the same experience with the This partition doesn't exist error, both with easy-installer and the manual installation method. However, I discovered a way to get the installation to work, which I outlined under A Solution at the bottom of post #28. I’ll summarize here to get you started.

  • Fastbootd exists in the Teracube 2e stock OS in its recovery.img file
  • The step of flashing recovery.img with the /e/OS easy-installer or during manual /e/OS installation overwrites this
  • The new /e/OS recovery.img file does not have Fastbootd, which is what causes easy-installer to hang with the phone showing a recovery screen, and prevents manual flashing of the system.img, product.img, and vendor.img files
  • The Teracube 2e stock OS recovery.img file has to be flashed back to the phone using fastboot flash recovery recovery.img before proceeding again with a manual /e/OS installation attempt (easy-installer can’t be used because it will again overwrite the recovery.img file and hang)
  • Download the stock OS from the appropriate link below to obtain the stock recovery.img file
    Teracube 2e factory SW - US,Canada and Rest of the World (link)
    Teracube 2e factory SW - EU (link)
    NOTE: The two download links above are taken from https://community.myteracube.com/t/advanced-installing-an-android-image-w-sp-flash/1003, but you don’t need any of the instructions from there
  • After reflashing the stock recovery.img file, proceed with the manual e/OS/ installation method, but instead flash recovery.img last after all other e/OS/ *.img files
1 Like

Thank you @aibd for linking to @prflsjn’s very informative post, and thank you @prflsjn for providing so much detailed information! That was the fix for me.

When the phone got to fastbootd mode I did need the driver MathiasV linked to, and Window finally allowed me to install it.

The bold commands below failed for me… how important are those for the future of this phone? It started fine so hopefully not important.

Hi @cc7
That is great to hear you have /e/ running! :slight_smile: I no longer have a device with a super partition so I cannot test, but when you say that

adb reboot bootloader
fastboot flash recovery recovery.img

failed, it seems the device was unwilling to reboot out of fastbootd back into regular fastboot then if the second command indeed did fail, the flash of the /e/ recovery failed.

In that event, I would hope/expect that /e/ is intact and you have the “stock” recovey which you started with.

This may work fine. If and when an OTA update comes along, it will contain a spoiler to say that you will need to have a “suitable” recovery in order for the OTA update to work.

As it is quite hard to find good information about devices with super partition this blog post TWRP + Android 10 + super partition indicates some of the difficulties faced in producing a “modern” recovery.

When the difficulty here is clear, I expect this issue will need to be referred back to devs.

Thanks, @Ivan, I see that is not part of the solution in this case! :slight_smile: (Unfortunately that post is now too old for me to delete.)

Hi @cc7
I am also glad to hear that you got /e/OS running! Regarding the two commands that didn’t work, sorry about that. Because you already ran the rest of the process, I don’t think we can revisit the full sequence I gave to see if we can adjust those commands. However, it would be very useful to know which of the two commands failed specifically at the time. If the first command

adb reboot bootloader

was the one that failed, it is possible that it actually needs to be

fastboot reboot bootloader

because adb perhaps doesn’t work from fastbootd. If the first command did work, you should have gotten back to the bootloader screen, which means the second command

fastboot flash recovery recovery.img

didn’t work. Because the bootloader is where you would have flashed boot.img and the three vbmeta images at the beginning of the process, there shouldn’t be any issue with flashing recovery.img. If this was indeed the command that failed, it would be interesting to know what the error message was. Maybe fastboot flashing unlock has to be run again or recovery.img was not in the location it was expected to be found in.

In any case, you should still be able to flash recovery.img by itself from regular fastboot. While testing to discover the source of the missing fastbootd, I actually flashed recovery several times going back and forth between the stock recovery.img and the /e/OS recovery.img by following the standard Teracube 2e /e/OS installation sequence, minus fastboot flash boot boot.img that comes right before fastboot flash recovery recovery.img, and stopping after recovery was flashed. Of course, you have to be careful about which recovery.img file you are actually using because I did accidentally flash recovery with the exact same file on a couple of occasions. I hope you can get recovery flashed to achieve a full installation.

2 Likes