Teracube VoLTE problem on AT&T in USA

I have a Teracube 2e that has stopped making or receiving calls. SMS and data work fine.
My network is AT&T (USA), via Tracfone as an MVNO.
The problem arose on March 17, 2022, apparently after 3G services were discontinued.
From searches on the AT&T forum it looks like the problem is that AT&T has custom standards for VoLTE that my phone is not using. AT&T lists Teracube 2e as an allowed device.

My guess is that Teracube has incorporated AT&T’s VoLTE protocols but that /e/ has not.

I have tried setting up a new APN as described in the teracube forum here:

Is anyone else experiencing this problem? Has anyone found a solution?


I have the same issue. I currently get around it by disabling LTE, and enabling 3G (which actually shows as 4G on the top of the phone. I think the issue is that new phones have to have HD audio capability to work with LTE. I have that option in Developer Options, but it is grayed out. I cannot turn it on.

This is the same reason I had to get rid of my Galaxy S7. I fully expected my Teracube 2e to work.
This obviously is not a long term fix, when 3G gets shut down in my area.

Edit: I tried my IMEI number on Cricketi’s website and the Teracbe 2 e comes up okay. Maybe only with stock Android.

I was able to fix the problem by adding a new access point name:
Name = ims
APN = ims
MCC = 310
MNC = 150
APN type = ims
APN protocol = IPv4/IPv6
APN roaming protocol = IPv4/IPv6
APN enable/disable = APN enabled

1 Like

Thanks for the replies. I had managed the same thing you did with using the 3G, so I’m surviving for now, but as you say, it’s not a long term fix. I wasn’t able to set up that APN. It did not like MNC = 150, so I’ll keep fiddling with it.

How did you choose those settings?

We have a build which should work on the 2e on the AT&T network for VoLTE

Wanted to check if there are users who can help us test this build ?

If you have a 2e and are on the AT&T network in the US do send a mail to testing@e.email

I have the same issue with the Teracube 2e. However my network is T-Mobile (USA), via Tracfone as an MVNO (specifically their subsidiary Straight Talk).

I was literally on the phone today with Straight Talk’s customer service representatives for two hours today unsuccessfully trying to trouble shoot this problem. So it’s quite a relief to find this thread.

For me the problem happens intermittently. I have yet to determine a pattern though. My IMEI also comes up as supported. I also adjusted my APN settings which did not seem to help at first.

It’s currently in a working mood at the moment after the customer service rep told me to turn it off then on again for the 7th time. Glad to have the 3G option as a backup plan now though.

@Manoj I would also definitely be willing to try the new build if you think it would work in my case as well.

HI @Jojo214 you can send a mail with the details to testing@e.email and the team will take it further.
Testing volunteers are always welcome.

Apparently issues with AT&T has become an issue with Teracube in general. See this post…


Thank you so much for that info on the APN davking my teracube works on cricket now. I was about ready to give up and send my teracube back to get my refund. I’m going to post a link to this on the my teracube community forum.

Glad I was able to help.

Att is using manual whitelist for the devices so they can track each user, and the coverage is lkmited due to the modem that omly works with a few att bands.
Just pick any tmovile mvno and all your problems would be gone.

Here is my manual on how to get best mvno from tmobile coverage

1.gota have an iphone
2. When ordering sim type in imei from that iphone.
3. Mvno will accept your emei
4. Once you receive sim just plug in your fp or teracube

Problem. Gone.

I just upgraded to the latest OS, 1.12.3-r-2023061429963
Now my access point settings have reverted to default, and I am unable to edit them, or add a new access point. The settings are not correct, and I am unable to make calls.

EDIT: I don’t know if folks are still having issues with AT&T. I’m still with Cricket.

1 Like

Not sure if these will help but…

Loss of LTE after latest S/W update to 1.12.3 - Teracube 2e - Teracube Community

Advisory - [US] Issues related to AT&T / Cricket (or other ATT based MVNOs) - April 2022 - Announcements - Teracube Community

Although the latter thread closed in October there might be a tip or two to try.


Great link from @marcdw btw … in addition, and having read that …

  1. My experience is that good online access is required any time you want to adjust / edit / create new APN. My experience is that APN settings do not save unless the user provides the full, verifiable, set of APN – these seem to be verified to exist or else they fail to save. If correct, this means a user probably cannot save an APN file incrementally, it should be saved “complete”.

  2. As an alternative to Edit APN are you able to use + at the very top of the APN page, to Add a new set.

Same experience here, after update VolLTE is non-functional. I’m using AT&T .
Data (internet, video calls, etc) works fine.
I looked at @marcdw first posts , after a reset still same behavior.

In APN settings there is a default profile that cannot be edited or deleted.
In order to be able to SAVE a new APN setting I need to be in airplane mode and then select it strangely it would go into modifying/ rewrite itself to deliver the same behavior.

Can I rollback the update?

I’m also having the same problem starting today I just finished posting it here: phone-calls-not-working-teracube 2e e/OS/ 1.12

I see on the teracube forums that last year Sharad stated "Going ahead, we are removing AT&T as a supported carrier " Link

Sure enough, in the current FAQ on teracube’s website all the carriers are T-mobile based.

Does this mean all of us teracube owners where T-mobile is not an option are now the owners of very expensive bricks?

Thanks for the bit of information. Didn’t know that!
I see this going forward with no further troubleshooting or support of the AT&T network and its resellers. Now that’s Teracube firmware, /e/ is a different spinoff. That announcement was last year, since then /e/'s VolLTE support has been working fine for me.

I have been able to save the APN in the past, but this time, it will not save. I cannot edit one, either. Oddly, an extra default shows up called mht. I cannot edit this one, or the one called internet. The setting buttons don’t respond to touch. A new entry will not save, either.
I have reset network settings, factory refresh, removing then adding the sim, to no avail. I’m thinking I might have to revert to e OS 1.10, which was the last one to work. I managed to skip 1.11.