[UNOFFICIAL BUILD] Android R build for Sony Xperia XZ1 Compact (lilac)

Here is an unofficial R build for lilac. It is built from the v0.19-r tag, (because 0.20 isn’t working for R yet)

Release notes for v0.19-q are here

Please read the following, and please make sure you have a full backup (boot, system & data partitions) of your current setup before you try to install this build.

  • Clean flash seems to work fine - I tested basic functionality: standard apps, EN Framework can be installed. The necessary sequence to flash with TWRP is
    1. Wipe cache, dalvik, system
    2. Format data
    3. Install ROM
    4. Format data again
    5. Boot
  • The build contains only the /e/ Camera app: it does not contain the Sony stock camera app, which does not yet work on this device under Android R.
  • I tried using TWRP to restore data from a Q build backup, but I couldn’t get it to work. I tried different options - with/without screen lock and booting before restore - but it always failed (in an interesting variety of ways). I got it to boot successfully once, but the 'Home, Back and Recents` buttons weren’t visible so navigation was impossible. So I gave up on TWRP Restore.
  • My failed attempts also caused the phone to stop detecting my SIM, even after wiping and reflashing. The only way to fix it was to re-install v0.19-Q (using the steps above),then go through the full install sequence again
  • I did have some success using ‘Android Backup and Restore’ scripts (see this post in another thread) to restore apps and data from a Q build. Several apps worked perfectly, others lost their data (including QKSMS, so if your text messages and call logs matter to you, I suggest using SMS Backup and Restore app from Aurora Store, before flashing this ROM)

The build is available here:

I am very happy to receive any feedback. If there is enough positive feedback, it may be possible that lilac can become an officially supported /e/ device again, now that the Sony Camera app isn’t there to confuse users :wink:


Thanks for the work, Pete. For now, I’m undecided about trying it out. :wink:

Fair enough. No problem sticking with the Q build - I intend to continue unofficially maintaining that for some time to come :slight_smile:

1 Like

There’s something not right about this build at the moment: it works OK after first install and boot, but backup/restore and/or wipe/format data will cause it to no longer detect the SIM. I’m pretty sure it’s something to do with which modem it uses, but I can’t see any way to switch modem. In my unofficial Q builds there is an Xperia Parts settings view that allows switching modem, but that’s not present in this R build.

So I’ve got to do some more digging into how to switch modems - any ideas very welcome, as I am getting a bit out of my depth :frowning:

On a fresh Q install, after first boot of (or after formatting data), and completing Setup Wizard, the device displays a message saying “the phone will now restart to be optimized for your network”, then reboots itself.

In this R build, the first time the phone boots after first installing the ROM, the “phone will reboot” is briefly displayed at the first screen before you press start to run the setup wizard, and the phone reboots. After reboot the setup wizard runs, and the SIM is detected. All is then fine until you restore backed up data, or wipe or format data. After doing that

  • after restore, the navigation buttons are invisible, and the phone is unusable
  • after wipe / format, the SIM is not detected, the “phone will reboot” message is not shown, and the phone does not reboot itself.

At this point, the only way to get the phone working properly is to wipe and format data, install the Q ROM, complete setup wizard and let the phone reboot. Installing this R ROM will then succeed, the phone reboots from the first screen, the SIM is detected and all is well.

So, I need to start digging into modem configurations, and the differences between the Q and R ROMs to work out what is going on (and - I hope - find a fix). In the meantime, any ideas gratefully received.

So, I have made a new build from the v1.0-r tag (see next post), and similar problems occur after restoring a backup. Theses problems are not caused by /e/OS or by my building, as they are present with the upstream unofficial LOS 18 ROM as well. If you search for backup in that thread you’ll find out lots more :slight_smile:

The good news is that there is a workaround which allows you to use this ROM (or the upstream LOS 18 ROM) and make TWRP backups which can be restored without killing the phone. The process isn’t pretty, but it seems to work (both in /e/OS and in LOS) :slight_smile: To make the backup

  1. Remove any screen locks (pattern, PIN or password): Settings | Security | Screen lock
  2. Make the backup as normal with TWRP

When you restore the backup, the phone boots but the navigation buttons (Back, Home & Recents) are not present. To get them back, you need to force stop Trebuchet, clear its storage, and reboot. So when you first boot after restoring the backup

  • open Settings | Apps and notifications
  • choose ‘See all apps’
  • choose ‘Show system’ from the ‘three dots’ menu
  • scroll down to Trebuchet and select it (this step isn’t necessary in LOS as Trebuchet isn’t a system app)
  • select ‘Force stop’ and confirm
  • select storage & cache
  • select ‘Clear storage’ and confirm
  • reboot the device

Note that I have only tried this workaround with my new v1.0 build. It may work with the v0.23-r build but I haven’t tested that (and I’m not going to - life is too short :slight_smile:)

So Android 11 / r / LOS 18.1 ROMs are usable on this device but like the upstream developer I will continue to use and work with the Android 10 / q / LOS 17.1 builds as they seem to be more stable, and I like the stock Sony Camera app

1 Like

Here’s a new Android 11 / r build, built from the v1.0-r tag:

I have tried and briefly tested it and key functions seem to work, but I don’t use it in my daily driver so there may be problemes I haven’t run into. My testing was done on a clean flash: dirty flashing, or restoring a backup from the previous build, will break it as described in the previous posts, though the workaround (remove screen lock before backing up or dirty flashing) may work, although I haven’t tried it.

My personal recommendation is to stick with the Android 10 /q build, which is more stable, better tested and has more users.

Please note that I probably won’t be building any more unofficial or custom /e/OS ROMs for this or other devices. With luck, /e/ will continue to make q builds available for this device.

I intend to focus on producing custom builds of Lineage for microG, that will get updates of the OS and the apps as long as they are available from upstream, without needing to be merged into /e/'s forked components. I will post more details when I have them.

1 Like

im getting the no mirrors message when trying to download

Looks like a general problem with AndroidFileHost: I can’t download anything at the moment. Maybe try again later, or tomorrow.

If that doesn’t work, I’m sorry but I no longer have a local copy of the ROM, so if it can’t be accessed at AFH, then I’m afraid it’s gone for good.

Mind, you, I don’t think it’s a great loss: from what I see in the forums and in Telegram, v.1.0 is very buggy, especially the Advanced Privacy stuff which was added to v1.0 without any testing on v0.nn builds, and App Lounge which had only limited testing. If I were using /e/ in my daily driver, I would definitely stick with v0.23: my unofficial R build e-0.23-r-20220421-UNOFFICIAL-lilac.zip does seem to be downloadable:

I am trying to find out how many people use /e/OS on this device. Please see this post

Please note: details of more recent builds for this device are posted in this thread

I am closing this thread

1 Like