[UNOFFICIAL BUILD] e-0.18-r (Red_velvet_cake/android_11_based) for Galaxy s4mini LTE (serranoltexx) GT-I9195

Notifications don’t seem to work after all. I’m not even getting SMS notifications. I’ve tried to fix this for a while, but microG Cloud Messaging just seems to not work. Or it’s a problem with something else relating to push notifications.

Edit: I tried the Android 10 one too, with the same result. I guess I’m gonna have to go back on the official Nougat.

Just to say I own several S4 mini and I’m sad to see them stuck in 0.13 so I would gladly support any new /e/ releases. I would even put a few bucks on the table to see it officially supported.

Incomming calls black screen solution :

try using the “Simple Dialer - Manage your phone calls easily” application (orange and white icon), available in Apps.
Open this application and select it to be the default Phone application.
Then go to the application settings and activate the “Disable proximity sensor during calls” option.

Hi, I installed this rom on my device but i 'v go two problems :
first, it seems that I’m on read only on the internal memory of the phone. For exemple, I cant take picture and save it.
How could i Check if I m on read only ?

I did import my sms and mms, using the tool sms Import / Export from my previous device (android). My sms were imported but not my MMS (that includes photo).
Did anyone have this problem ?

Thank you for you help.

The /e/OS version for this device is pretty oudated. You might try LineageOS for a newer version

@piero : maybe you want to build a new Q or R version for this device. I tried build today but got too many errors…

1 Like

serranovelte gt-i9195i s4miniVE “Value Edtion” is different.

serranovelte gt-i9195i is covered by another devicecodename with another CHIPSET different than
serranolte gt-i9195, incompatible with serranoltexx (including 3 variants)

But yes, i want to build an updated e-1.15-r version
for the serranolte gt-i9195
( or serranoltexx if possible including 2 other devices serranoltespr and serranolteuc ),
thank you for trying, system size is a known issue we have to pass.

sorry i have not seen this on my two i9195 devices nor on my i9195X ( demo version without GSM modem but fonctionnal WIFI)

i don’t know / use this feature.

→ settings → application → permissions
does camera have permission to read/write into internal storage ?

Please note it is also Not an Unofficial Build, it is an experimental Custom Build with modifications to allow for the small system partition. Credit and kudos to @piero who inspired this enterprise; would you care to test this please @piero.


The sha256sum is:

The build is based on the original Lineage sources https://wiki.lineageos.org/devices/serranoltexx/ with the substitution of kernel from sileshn.

This build is much reduced from the standard /e/ MINIMAL_APPS, the list of apps not found in this CUSTOM_SLIM build.

eSpeakTTS Camera Message Mail Browser BrowserWebView AdvancedPrivacy MagicEarth PdfViewer.

The build is made from the same recipe as the July tested [CUSTROM_SLIM] OnePlus One bacon.

What next

We can experiment further with the optimum choice of included apps – serranoltexx has a slightly larger available system partition than bacon so we can hope for a better populated build next time.

1 Like

hello, thank you for your help.
I did install the rom you gave me.

Installation is ok.
I’m Now testing.
There is a problem with the phone application.
Incoming and outcoming calls works fine but when the conversation starts, the only way to hear is to use HP function. Without HP, I can’t hear any sound.
I Tried with another application ( Simple Composeur / simple Dialer) but the problem is the same. Would anyone have advices to solve this problem ?

The problem I used to have about read only seems ok. Pictures car be taken and saved in the internal memory.

about the last part of your post (after What Next) , I’m not sur I understood well what you meant.

1 Like

Thank you so much @renton for testing this experimental build.

Did you see the tip in Post #12 using Simple dialer and “Disable proximity sensor during calls” ?

Sorry about the vauge “what next” content. It has been @piero’s ambition (mentioned in the link) for a long time to build a serranoltexx ROM. I hope he can pick up this “proof of concept” and continue the development.

here are some news.

Unfortunately, the option “Disable proximity sensor during calls” doesn’t fix the problem with the HP when making calls. At this point this is the main bug. It does make the device quite unusable for everyday use.

For the rest, here what i could test :
Bluetooth is ok . I used it on my car and could make calls.
mms is ok. and i recieve attached files as pictures.

I tryed to install application such as leboncoin or sncf-connect with aurora . Installation is ok but application crash when launching. Do you know if I’ve got something more (such as microg) to install ?

If you have a rom that would correct the problems, let met know. I would try it and make you a return as complete as possible.

Let me know.
thanks for your help.

Many thanks indeed for your report. I am sorry to hear that the dialer is not fixed with this kernel. Please can you explain the term “HP function” differently ?

This first build is an engineering build so it may be hard for some “financial” apps to work nicely. However you can check in

Settings > Apps and notifications > See all … apps > microG Services for its presence.
I expect you to have Version (63b1553)-noen

There is [LIST] Banking Apps on /e/OS but in a quick search I do not find leboncoin or sncf-connect. It can be useful to check the privacy friendliness of app you intend to use with Exodus. I saw this thread Site web bloqué (leboncoin) sur FF et Browser.

about the HP thing.

When a call arrive, I hang on : I can’t hear anything.
I touch the HP bouton (loud speaker) and i can hear the person who is calling.
I means the communication between my phone and the on who call me is ok. But I can only hear what people says when I use the loud speaker and not when my phone is stucked to my ear.

THe other point is that I 'd like to install application from the play store, but by using aurora. ( you can find that app on F Droid, it’s made to donwload app from play store without google account (witch I don’t have))
For my example, I’d like two apps : Leboncoin (2nd hand sale) and SNCF-connect (main train provider in France)

these two apps correctly installs using aurora but both crash when I launch them. I But it’s because they need some google services and, as /e/ user, I don’t have them.

MircroG is the version you expects :

hello @renton i have “leboncoin” working on my daily “e-0.18-r-20210814-UNOFFICIAL_MINI-serranoltexx”

just tested “e-1.15-r-20230920-CUSTOM_SLIM-serranoltexx” on a speare device…

  1. same problem with “leboncoin” but i don’t think that “microG” is the cause as it works with the same versions on my official s4active device e-1.15-r-20230916331434-dev-jactivelte).
    note : using a previous installed 18 month old app leboncoin i was abble to open the app but not to connect to my account. but after updating it the app crash
  2. i have called my “message box” and i can ear it without external speaker using both dialer apps
1 Like

Thanks for clarifying HP. With this experimental build you would have had to install your own browser. Which browser did you install ? Did you also install a system webview ? This may affect some apps, I think.

Edit, I have gone on to test leboncoin on my OnePlus One bacon; the app fails to open.

@piero, thank you for testing.

I use Firefox as web Browser ( but to be honest, I don’t really understand why you ask )

Did you also install a system webview?

I 'm not really sure what answer you expect. I check on the web what a webview is.
I did not intentionally install one . Maybe is there one installed by default ?
Otherwise, could you advice me one on F droid ?

Could it be a reason that make the app (the show information from the website) crash ?

Let me know and I ll test.

That is what I thought might be happening.

However I run the same build and I do have F-Droid Bromite System Webview manually installed from F-Droid; leboncoin still fails to open and run.

You might read this https://www.lifewire.com/what-is-android-system-webview-7107919 to help decide if a system webview would be important or useful for you.

i just get a booting e-1.17-r-20231106-CUSTOM_MINI-test-serranoltexx.zip build that i already think better for average user because it contain more basic apps as Camera Message Mail Browser BrowserWebView.

  • Because of /system partition too small,
    It dont include :

App_Lounge (for now replaced by F-droid and Aurora Store)
Advanced_Privacy (for now unfortunatly my main goal is to incude it even by removing other apps)

Maps (you can add Magic-Earth from Aurora Store)

PdfViewer (you can add one from F-droid Store)
Pico TTS


Hi Piero
Glad that you are still trying to update this… I’m using e-018 on one of my S4 minis.

I also still use it too, on my main phone.

i have installed e-1.17-r on a spear device (bloken glass / screen fonctionnal) but actually have only one working battery (in my main) and cannot take the time to test further. …