[UNOFFICIAL BUILD] Sony Xperia XZ1 Compact (lilac) e-1.3-q Post #212

@petefoth Hi Pete. With regard to @Xyguma’s wish to return to stock do you know if newflasher is good for lilac?
Thanks, Chris.

I’m afraid I don’t know. I’ve only ever used FlashTool, and that’s not working now on my Mac anymore because 32 bit Mono no longer works.
According to this post in the LOS Unofficial ROM Thread on XDA, it should work

OK, Thanks.Shame about your mac.
I’ve seen reports on xda also of people using newflasher successfully.
Reassuring, thanks.

@petefoth do you think it’s possible my sim didn’t work because I was on Android 9 before flashing ?

I really don’t think so. Android 9 was the latest Sony stock firmware, and I’m pretty sure I flashed a Q (Android 10, LOS 17.1) ROM on top of that, so I don’t see why it would be a problem. The XDA thread for the unofficial LOS ROM says it should be flashed over firmware build which is Android 9 (pie). Flashing over Android 8 (oreo) might have caused problems but you didn’t do that.

Have you tried installing the LOS 18.1 ROM from the XDA thread? That’s Android 11, R. The only problem with trying that is that I don’t know how easy it is to go back to Android 10 / Q / LOS 17 from there, without reflashing the stock ROM first

Apart from that I really am out of ideas - sorry

Ah ok.
Well maybe I was under Android 8, it seems strange but maybe it’s this, since LineageOS16 works fine for me.
I could stay with it but I really prefer /e/.
Thanks for everything

I found something and it’s working I’ve got signal.
I found this apparently there is a bug. My prefered network was set on 4G, you have to set it on 3G reboot your phone and put it back on 4G and it worked.
Thanks a lot to everyone. I’m going to start using my phone with /e/ !!

Good find - well done!

Here’s a new build based on the v0.17.1-q tag. It’s had only very basic testing - it boots and runs. As always, use at your own risk

No release notes for the v0.17-q tag but release notes for v0.17-nougat are here

  • Xperia XZ1C lilac

The functionality to enable Exposure Notifications in MicroG does not work. If you want / need to enable this, then please install this .apk file https://ecloud.global/s/WGf4kCnnSeaKixT

I just joined the forum to deliver a big Thank You to you, @petefoth. I’m so glad I found this thread and your work. I’ve been wanting to de-google my Androids forever, but didn’t have the courage to try a custom ROM installation. Turns out it was easier than I thought; now I’m running e-0.17-q-20210612 on my 6-month-old XZ1c…and with the actual Sony camera software intact, no less.

I do have probably the same LTE problem as @Xyguma, though. I start with no connection, toggle to 3G to get the connection (although “4G” is displayed in the notification area…possibly meaning “3G+”?), then toggling to LTE, “LTE” returns to the notification area…at which point I don’t necessarily have an actual connection. I’m using a U.S. MVNO that runs on AT&T.

I’m doing a test right now: I inserted a (defunct) T-mobile SIM, which triggered a network reconfig/optimization and restart. (By the way, the VoLTE setting gets added to the Network menu automatically when using a T-mobile, or T-mobile-based MVNO SIM. The VoLTE setting is not present when using an AT&T-based SIM. This is expected behavior.)

Following that, I powered down, inserted the AT&T SIM again, restarted, triggered another network reconfig, and selected LTE Preferred. The connection seems to be stable now; I’ll monitor it for a while and then report back here.

Can you clarify for me: Will I need to reinstall the OS to get any system/security updates? If so, is there an easy way to keep all my installed applications (from F-Droid) and settings intact?

Thanks again for your excellent work, Pete!
Edit: And to the entire /e/ team, of course.

1 Like

Hi Taurus

I’m glad the builds are working for you :slight_smile:

At the moment I’m afraid you will need to manually flash new builds using TWRP as they appear, which is usually shortly after the official /e/ builds appear. The good news is that ‘dirty flashing’ seems to work: install a new build using TWRP without wiping data, and - with luck - when you reboot, all your apps and data should be as they were.

However, I pretty much always do a TWRP backup of the data partition before I install a new build. If the build doesn’t want to play after a dirty flash, then I

  • format the data partition (in TWRP, Wipe | Format data),
  • do a clean install
  • wipe Dalvik and cache
  • reboot the new installation and go through the setup wizard ,making sure to set any screen protection (pattern, PIN) to exactly what it was on your old build (so that TWRP can decrypt your backups)
  • In TWRP restore the backed up data partition

That pretty much always gives me a working phone with installed apps and data all present and correct, though app permissions sometimes get removed, and have to be granted again.

I plan to look into providing OTA updates for my builds, which would simplify the installation of updates. But it’s not trivial to do and it may not ever happen, so please don’t hold your breath :slight_smile:

1 Like

Great! Thanks, Pete. That works for me. Bookmarking this page for future reference.
P.S. Is there a place to donate money to support your work?

No thank you. I do this for fun, in my spare time when I’m not playing golf. I don’t want or need payment :slight_smile:
If you really want to express your appreciation with money, then please donate something to a charity local to you, or donate to /e/, or pay /e/ for an upgraded account with more storage.


Thanks for the new build. Everything seems to work.
I still have my issue with the network connection, I just need to put it on 3G before turning off the phone otherwise when I turn on my phone again I have no connection.
And sometimes the connection is lost with no reason so I have to put it on 3G and reboot the phone.
But everything else is working fine for me.
Thanks a lot


I’m having the same problem, but once I have the LTE connection again it remains stable, as far as I can tell. I can work around it for now.

@petefoth, not to stray too far off-topic, but have you ever made a build for the XZ1 dual SIM? I’ve got one of those in addition to my XZ1 Compact.

I haven’t but I could give it a go if there is a LineageOS 17.1 (unofficial or official) available for it. Do you know of such a thing?

1 Like

I don’t, but I can look around. If I find something, I’ll start a different thread. Thanks, Pete!

@Xyguma, apologies for accidentally replying to your comment above.

1 Like

After one month with /e/ on my XZ1c I’m happy to report that I couldn’t be happier with it. After I set it up with my preferred launcher, apps, and F-Droid, everything works great, with the exception of the LTE/3G toggle issue described above. (I’m content to work around that.)

And I have detected no tracker activity going on behind the scenes. :slight_smile:

Edit: I should add that I’m not using /e/cloud.