[Unofficial Build] Xiaomi Redmi K20 Pro Mi9T Pro raphael e-OS Q-build

Generally I would use the same tool you used to unlock the device.

I also had a problem replying; there may be some other issue than you being “new” ! and perhaps you should avoid alternating between two threads – idk.

My mistake, avoid version 3.4 that was buggy, better 3.3 or 3.6

Back to the situation.

I couldn’t answer yesterday, I was blocked by the forum CMS because, as a newbie, I had reached the maximum number of public and private messages possible. I had to wait for 20 hours…

@aibd Xiaomi phones do not require a tool to unlock, it happens directly from the OS itself.

I downloaded the latest available package miui_RAPHAELEEAGlobal_V12.5.1.0.RFKEUXM_dd92b7128a_11.0.zip for my phone version and imported it via TWRP. The installation went well. MIUI launches, asks me to restore the device, and then Google goes to work. And when I get to the last screen, I do Done, the screen turns white and then comes back to this last screen, I’m stuck in a kind of loop and I don’t know how to get out of it.

And no, it’s not the fact of answering to other subjects, it’s really a limitation of the CMS managing the forum, the error message is quite explicit.

@piero OK, I’ll try with the twrp-3.3.1-32-raphael-raphaelin-mauronofrio.img version found via [TWRP][3.4.0-10][raphael]Off/Unoff TWRP for Xiaomi Mi 9T Pro/Redmi K20 Pro (Stable) | XDA Forums

For information yesterday, I managed to install the normal MIUI 12.5.1.0 RFKEUXM version.

Here is the method:

  • I tried reinstalling the official ROM by going through TWRP and installing the Recovery version.
  • I tried via adb sideload but the ZIP import (2+GB) crashed.
  • Thanks to a friend’s advice, I did an adb push miui_RAPHAELEEAGlobal_V12.5.1.0.RFKEUXM_dd92b7128a_11.0.zip /sdcard to add the ZIP file to the sdcard folder on your phone and then I went through the TWRP installation.
  • On reboot, I was well on MIUI 12.5 but, after identifying Xiaomi then Google to restore the backups, at the end of the Google process, I do Finish, white screen then I fall back on the window to finish the process. And so on, a loop.
  • In desperation, I say to myself that I have to redo everything. In the middle of all the tools (Xiaomi Tools, Flash etc), the friend in question finds me a magic tutorial How to flash MIUI Fastboot ROM from Linux · GitHub which I test.
  • You have to download the fastboot version (not recovery as I did before) of the MIUI ROM and then run the script that takes care of everything. A few long and stressful minutes later, the phone reboots and, slowly but surely, displays the MIUI home screen to start installing the OS.
  • And this time, with less manipulation, the system is stable.

Next step on my side, now that I’ve got my MIUI session clean:

  1. Make a backup of the system via TWRP
  2. Attempt a downgrade to Android 10 by cheating with the system as shown here Xiaomi Poco X3 Pro | Downgrade MIUI 12.5 to MIUI 12 | Locked Bootloader | NO TWRP | Without Computer - YouTube
  3. Attempting to install again starting from TWRP 3.3.1-32 (@piero if you have a newer one and not 3.4, let me know) but when I’m calm, which is in about 10 days. And if anything goes wrong, I’ll have my backup created just to make sure I don’t have to run the script listed over Jithin Jith (j-jith).

That’s all folks, thanks for the help.

Hi there.

This little thing seems to be a pain in the ass to achieve. I’m talking about saving via TWRP.

Every time, I get the same error (which seems to be classic and common to many):

Backup start: backup folder: /data/media/0/TWRP/BACKUPS/b5baf749/2022-05-01-12-29-01
Can not create "/data/media/0/TWRP’ folder (required key not available).
Failed to make backup folder.

What I did to try something else:

  • Remove the PIN from the phone (no, the /data partition is not encrypted at all whether the phone is PIN protected or not)
  • Try other versions of TWRP (3.3.1-32, 3.4.0-10 and the current latest I think 3.6.1_9-0)

I don’t have an SD card slot. Is there any other way to make a backup of the current system before attempting a new migration to Murena?

Kind regards :sunny:

Hi,

Maybe you could try OrangeFox ?

Hi @smu44 thanks for the try but I did it :smile:

A look back at the situation :grimacing:

I tried to make a TWRP backup but I still had this error:

Can not create "/data/media/0/TWRP' folder (required key not available).

A possibility found in a tutorial was via TWRP to :

  • Disable the PIN code that is supposed to encrypt the partition. Or avoid the security pattern in favour of a PIN. Bullshit. No result.
  • Try to repair the partition. No result.
  • Switch the partition to EXT2 and then back to EXT4. I finally manage to make a backup but the next step will tell me that it is not a stable backup.

I restart the laptop and I arrive on the MIUI installation screen… So the switch to EXT2 then EXT4 corrupted the data partition, I did a classic format. The rage :dizzy_face:

I go back to flash the image then I reinstall the backup which is almost 3GB. And on reboot, I still have the MIUI installation screen… So the backup is corrupted. I’m in front of a formatted phone once again when I try to make a backup instead… :rage:

It doesn’t matter, I only lost a few hours during which I had managed my applications (personal and professional profiles), there are more dramatic things in life. I’m struggling to find a Wi-Fi, I ask my neighbour to let me access his hotspot to activate my device.

And then my friend, @marmotte32 the one who had already helped me in the past and who had unfortunately shown me this tutorial for changing the type of partition, sends me another tutorial for making a backup. Except I have nothing left to save. And in another message, he tells me:

So you can start downgrading to MIUI 12.0, right?

Why not :roll_eyes: Since I’ve already formatted the phone, all I have to do is test the downgrade. This is the method I used. Because yes, I did it! :innocent:

  1. I install MIUI in light version, I unlock the developer access, I start the USB debugging then I try the downgrade manipulation Xiaomi Poco X3 Pro | Downgrade MIUI 12.5 to MIUI 12 | Locked Bootloader | NO TWRP | Without Computer - Invidious to go from the recovery archive miui_RAPHAELEEAGlobal_V12. 5.1.0.RFKEUXM_dd92b7128a_11.0.zip to miui_RAPHAELEEAGlobal_V12.0.4.0.QFKEUXM_4087debc4c_10.0.zip

And the downgrade works! :arrow_double_down:

  1. Android 10 freshly installed, I go back to my neighbour to get his hotspot. I activate my device, it’s 10pm. And I say to myself, I might as well give it a try.

  2. I follow the tutorial Install /e/ on a Xiaomi Redmi K20 / Mi 9T - “davinci” that I’m starting to know by heart:

A few minutes later, the Grail is there: the device reboots and I discover with wonder a new wallpaper. I managed to install /e on my Xiaomi Mi 9T Pro. I can enjoy my free phone :sunny:

Well done to all those who make it possible to free our phones :pray: :clap: :kissing_heart:

If you want to free your Xiaomi Mi 9T Pro, remember 3 things:

  • To be able to install the current versions of /e, it is imperative to downgrade to Android 10 :arrow_double_down:

This is possible from the MIUI settings directly by having the developer option. We play with the system by following the video Xiaomi Poco X3 Pro | Downgrade MIUI 12.5 to MIUI 12 | Locked Bootloader | NO TWRP | Without Computer - Invidious and it works.

  • Error 7 in TWRP seems impossible to solve.

So you have to go for it and have previously backed up everything that can be (files, passwords, 2FA via Aegis, open source, which allows an import and export for example…)

  • If you have any problems and need to get back to the default MIUI operating system, there is an easy and safe solution.

Download the fastboot file Redmi K20 Pro/Mi 9T Pro (raphael) MIUI Downloads | Xiaomi Firmware Updater corresponding to the version of your MIUI system previously installed (for my part, French version Mi 9T Pro EEA indicated by the reference MIUI V12.5.1.0.RFKEUXM) and follow this tutorial How to flash MIUI Fastboot ROM from Linux · GitHub

And that’s it!

3 Likes

To add to this for future troubleshootings, when I was doing this installation, I prepared for the worst case scenario where I had to do everything again. In case anything went wrong, i would have used a little program specifically for Xiaomi devices that allows you to flash stock roms and other adb/fastboot tasks. I think it just downloads the official ROM from an official archive and does the flashing for you. I did not have to use this, but I can imagine that this might make the process of recovery a bit easier. It is quite similar to what Parhit did in the end, just with a user interface.

I also used this in the past to remove bloatware through adb before I installed /e/os

2 Likes

Hello.

I wanted to tell you about two bugs I am currently experiencing with this unofficial ROM.

  1. Some applications do not launch or crash. These are:

I tried to update them, to have them on the personal or professional profile (via Insular), nothing happens.

  1. The professional profile crashes randomly or seems to be unstable.
  • When I go to activate it, I enter the PIN then the phone does a semi reboot but loops. It puts back the splash screen My data is my data with the logo then goes to the home screen then back to the splash screen and back to the home… The only solution I found was to simply reboot.
  • This profile cannot be managed by a pattern. It is mandatory to use a password or a PIN code. If I put the pattern, it systematically puts back the previous unlocking system installed. I tried to put a pattern on the personal profile but it does not change anything.
  • When I add a new application via Insular, thus managed by the professional profile, the app icon does not appear on the desktop. The application is well installed, I can launch it but no icon. I have to restart for the icon to appear. Probably a problem with the Bliss launcher.

Hi

I have at my disposal my fixed computer with a 2TB disk and I was wondering if I could compile an update of /e/os for the Xiaomi Mi 9T Pro.

Namely that the current version of /e is beyond version 1 when you are still stuck, due to the lack of unofficial ROM, at version 0.17… In other words, far behind!

I found this tutorial to compile How to Build the /e/ ROM? but I guess I need some elements to compile. Where do I find them? Could someone please PM me if this is too sensitive? @piero ?

Thanks :pray:

Hello.

Really no one can tell me how to build an updated version of /e /os on Mi 9T Pro? This model has no official ROM, and the latest one (0.17) is full of bugs (apps impossible to use, MMS not received, desktop issues…).

It’s really useful and relevant to see about making an update. How to do it? @piero @fabien.l14 Thank you.

I have not yet starting to attempt to build,
Last month, I have bought an old powerfull machine for that but it is not yet complete (i still need memory and graphic card)
Have a look to @petefoth 's how to

Details of the unofficial LOS 18 build can be found on XDA Forums

Usually you can find the device and kernel trees in the ROM developer’s github account, but for this ROM it is available as a zip file, as are required firmware and vendor blobs. This guy doesn’lt seem to do things the ‘normal’ way, as his instructions talk about flashing firmware and vendor blobs separately from the ROM. So you may have to do some more digging to build a flashable /e/OS ROM

Have fun, and good luck

Proprietary blobs not available at The Muppets :frowning:

You may find this of interest : raphael-development · GitHub