[UNOFFICIAL BUILDS] Samsung Galaxy S7 / S7 Egde for /e/OS S and /e/OS r

Yes, it’s a tripple check in one go WiFi, Camera, QR scanner :wink:

Just now, I also used an app password QR code from Murena.io to set up Nextcloud app that way, worked too.

1 Like

ok great. I presumed that it might not work. Did a build for the S7 Edge now too

You might check out the scripts within docker here https://gitlab.e.foundation/e/os/docker-lineage-cicd/
You might try this method to check out the underlying repo build scripts.

$ mkdir Build_Primer
$ cd Build_Primer/

$ repo init -u https://gitlab.e.foundation/e/os/releases.git -b v1-t
Downloading Repo source from https://gerrit.googlesource.com/git-repo

Your identity is: make-nz <you@example.com>
If you want to change this, please re-run 'repo init' with --config-name

repo has been initialized in ~/Build_Primer

$ cd .repo
$ mkdir local_manifests

Write / copy a one project manifest; SaveAs .repo/local_manifests/build.xml
Using as our source: https://github.com/LineageOS/android_build/

<?xml version="1.0" encoding="UTF-8"?>
  <project name="LineageOS/android_build/" path="build" remote="github" />

Then you can

$ repo sync LineageOS/android_build/
Fetching: 100% (1/1), done in 16.450s
repo sync has finished successfully.

Now you have two folders with stacks of scripts and READMEs without the distraction of trying to build a ROM ! :sunny:

@aibd This is great thank you!

@ronnz98 as I have not just one S7 and S7edge, I would like to build for them, too.
I’m still wondering, what the missing parts were, which stop it from booting!?

I dont know. I’m not a developer. But the T version works right?

But you know, what you changed before!?

I did not change the build. The respective sources are different for R,S and T for this device. The patch can only be applied on S and T. To understand why it does not boot one need to debug

So, now I got it, I think… I wasn’t sure anymore what was in the builds that did not boot and thought you fixed something in the same version.

It’s kind a safe to assume something did not get back ported for version R…
And in any way, having the newer Android version run on the S7 – with blueooth working, better WiFi and better battery life – is awesome!

Hope we will not here a:

This is Major Ron to Ground Control
I’m stepping through the door…


Thanks again @ronnz98

Yes, it boot and working fine

:clap: Congratulations ‘Major Ron’

Hello all,
@make-nz , @anon29344687 do you still use your S7 with the T build from @ronnz98 ?
If yes can you confirm me that your phone is working fine or if you found some issues ?
Thank you for you answers.

Updated version available:



First I installed @ronnz98’s build e-1.15-s-20230919-UNOFFICIAL-herolte_by_ronnz98.zip with e-Recovery, and from there I manually updated to new @ronnz98 build e-1.16.1-t-20231028-UNOFFICIAL-herolte_by_ronnz98.zip, which worked fine.

Since the e-Recovery allows the manual update via adb sideload from the microSD card, i.e. without an additional PC, the update is as easy as an OTA update.

@ronnz98, all system apps, including Battery + Display + Notifications + Sound & vibration as well as Fingerprint (home button) work flawlessly :white_check_mark:

@ronnz98, you are great. Thank you very much.

:cyclone: Very advantageous for future @ronnz98’s updates:
Updating can be done without a PC, as the e-recovery allows ‘adb sideload’ from the microSD card.


Install a custom recovery with Odin on Windows OS:

Simply unzip @roonz98’s e-1.16.1-t-20231028-UNOFFICIAL-herolte_by_ronnz98.zip and use file recovery.img. Open a command prompt and convert the file "recovery.img to “recovery.tar” with the command:

/e/OS documentation

Installing a custom recovery using Odin

  1. Rename the downloaded image to “recovery.img”, open a Command Prompt and TAR the file by running

tar -cvf %USERPROFILE%\Downloads\recovery.tar %USERPROFILE%\Downloads\recovery.img

Tip: The path may vary depending on where you download the recovery image.

:free: or use this e-recovery .md5 generated by me [ 41.3 MB ]: recovery.tar.md5

1 Like


From the above it seems one should pass a local_manifests folder to docker run
In my case:

docker run \
-v “/home/make/e/src:/srv/src” \
-v “/home/make/e/zips:/srv/zips” \
-v “/home/make/e/logs:/srv/logs” \
-v “/home/make/e/local_manifests:/srv/local_manifests” \
-v “/home/make/e/keys:/srv/keys” \
-v “/home/make/e/ccache:/srv/ccache” \

[Mon Oct 30 15:21:50 UTC 2023] Copying ‘/srv/local_manifests/*.xml’ to ‘.repo/local_manifests/’

Just wannted to add this

@ronnz98 How did you pass this into your build, please?
Are there some docs, howto on what you can set?
Does it just come from your test-keys or user name?

I suppose this is the linux user name of the system used for building

Yes, was thinking that too — and edited post, while you answered.

The only ROM I build does say root there, but I’m using docker. I your user name ronnz on your notebook/pc?

Yes, ronnz is my username for my laptop as well as for my PC.
One of the disadvantages that docker has is that it runs as root, or at least I dont know to run docker without sudo…

It’s pretty straightforward. This page from the Docker docs explains how to do it


It’s a bit of a faff, specially if you have already run a few times: there will be directories owned by root that you wont be able to access as non-root. Some judicious work* with 'sudo, chown, rm -rf will make it all good, But it’s well worth doing

* Sorry I can’t remember the exact details of what I had to do

Well, I run a minimal Ubuntu Server and docker is a snap, so it has good isolation.

With tmux, mc, htop, iftop, ncdu, snap I have not much on that system anyway.

/e/OS-S-1.17 Update:

Samsung Galaxy S7 (herolte)

Samsung Galaxy S7 Edge (hero2lte)

T versions will follow