[UNOFFICIAL BUILDS] Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805 / Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-T800 for eOS Q

Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805 / Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-T800 for eOS Q-1.15

Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805

Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-T800

Please see sources and install instructions including recovery here:

Use it at you own risk!
Please support the developer(s)!

New updates for Samsung Tab S:



Please note feedback to get it work:
after first boot let it boot for a minute then vol down power hard turn off and let it restart then it will boot to setup !

chagalllte might not work as I had to tweak recovery image size for successful build…

updates for /e/OS-R.1.17:



Thanks very much. Seem to work well on chagallwifi

1 Like

By chance found my SM-T800 in a box and wanted to try e-1.17-r-20231114-UNOFFICIAL-chagallwifi.zip on it. For some reason wifi networks are found but will not connect, tried both regular AP and phone hotspot, but no connection. Any ideas what I might have missed?

Some old devices have issues with WPA3? Maybe your router uses WPA3 only?

My AP has mixed WPA2/WPA3. Set up an extra WPA2 only net and it connects. Thanks!
I did download the zip from original Samsung fw over the mixed WPA2/WPA3 AP, so problems with WPA3 related to /e/OS?

I dont know-sorry. Might be also LineageOS related

Updates for /e/OS-R 1.18:



I made final updates for /e/OS Q 1.17:



Updates for /e/OS-R 1.19:



Updates for /e/OS-R 1.20:



1 Like

I have tried this builde-1.20-r-20240223-UNOFFICIAL-chagalllte.zip, but it has trouble booting, sometimes it boots and other times it will not.
I have found if I do a TWRP backup using the newest TWRP after the backup has finished, when I try to reboot from TWRP it will never reboot.

Also when I try to turn off the tablet pressing power+updown it does not turn off instead it just tries to reboot but always fails.

I had some troubles with the one of the partition image size for chagalllte. Maybe you stay at the last version that is working for you

Hi Ronald,

I tried /e-1.17-q-20240110-UNOFFICIAL-chagalllte.zip which just did not boot at all, then I tried e-1.19.1-r-20240112-UNOFFICIAL-chagalllte.zip. This version boots from the time it is installed but on subsequent boots it fails to boot more or less the same as e-1.20-r-20240223-UNOFFICIAL-chagallwifi.zip .

If I reboot into TWRP and try to resize the system which also tries to repair the system I see this :-

Then if I try to repair the system partition it does repair then afterwards if I try to reboot sometimes it will reboot into ‘E’ and sometimes not.

It seems as though ‘E’ is conflicting with TWRP.

Thanks for all your efforts it is very much appreciated, I will keep watching for further updates.

I forgot to mention after the first successful boot and after an attempt to reboot it fails to boot again and then the SM-T805 will not turn off when you press up-down and power. Instead it tries to reboot again. The only way to stop this behaviour is to reboot back into recovery,

Can you check the comments here, some of the users could successfully install chagalllte:


Hi Ronald,
I tried the suggestions made in the link you pointed me to, but the os e-1.19.1-r-20240112-UNOFFICIAL-chagalllte.zip and e-1.20-r-20240223-UNOFFICIAL-chagallwifi.zip only booted once and then after that it just bootloops. TWRP says the system partition is corrupted. I can repair the system partition in TWRP, but it then sometimes boots one more time, then bootloops again.

I made Q builds with different sources, please try:



I have feedback from XDA that chagalllte works :slight_smile:

Good morning Ronald,

Firstly thank you for the effort you are putting into this project. I will try the new build and report back to you. I don’t know if you have noticed I have been asking for the option to automatically record calls similar to that which is available in Crdroid, they must use a modified com.android.dialer, I have provided a screenshot below, you will be able to see the option added to the bottom of the page.

This option is something I find exceptionally useful so it would be fantastic if this could be included at some later date.

Thanks again