Wi-fi calling switch button not found

On the r/LineageOS, I have found the following suggestion:
Dial code * # * # 4636 # * # * then choose ‘Phone Information’ and you shall see it the option.
Unfortunately, it did not work for me. The option for wifi calling is greyed out and I cannot turn it on.


Thanks for that. I tried it, and like you, the option for WiFi calling is greyed out.

I unfortunately got the same problem with my refurbished S7.
I was hoping that an OS update would solve the problem, but one year after and still the “wifi call” in the * # * # 4636 # * # * menu is greyed out.

Someone got any news regarding this bug? Should I contact /e/ for a particular fix on the OS?
Thanks in advance!

I apologize for the necro-bump of this thread, but my provider (AT&T) just made Wi-Fi Calling available and I was curious as to whether or not any further work was done on enabling this capability. I have confirmed with AT&T that they have provisioned the device, but like the other users above, the “Wifi Calling Provisioned” option is greyed out.

According to the Reddit thread mentioned above, certain lines must be added/edited to “build.prop” for it to work:


Does anyone happen to know if this is something that can be done at the user level? Thanks!

EDIT: I have the Samsung S9 with the latest /e/OS Q build.

I think this is more of a service provider related issue…of late I am seeing a wifi calling sign when I make calls on my phone.
The only thing I did was enable the option available under

Settings >>  Network and Internet >> Mobile Network >> Advanced >> Wi-fi calling 

This feature was enabled earlier as well but started seeing this ‘wificalling’ text recently.
A few weeks back I started getting these messages from my Network Provider that wifi calling has been enabled in my area .
The phone on which I am testing is a whyred with the Q test build.
Pl can you raise an issue in Gitlab giving details of the code that needs to be checked. Since it is working on the Q builds not sure if this is OS specific on /e/. With a bug in place can have the developer check it and get it updated.

@Manoj Thanks much for the quick reply, most appreciated!

I checked the Settings prior to making the post as shown below:

but the options do not exist for me, despite the carrier’s statement that it WiFi Calling was enabled. I will raise an issue in Gitlab as you recommended and we’ll see how things go.

Thanks again and have a good day!

EDIT: I updated an existing issue here.

My phone doesn’t support wifi calling but I use a diy solution. First, get a free SIP account. Then install a SIP client and set it up with your new account. Finally put diverts on your mobile number to the SIP account for when unreachable. You can then make and receive calls on wifi when not connected to the mobile network.

My experience (on different devices):

  • If the device supports WiFi calling, when the phone starts up for the first time with a new SIM, then before the phone starts properly I see a message saying ‘Your device will now restart to be optimized for your network operator’.

    (This may be at the end of first time processing with a fresh install, or immediately after unlocking the first time the phone is booted with a SIM from a different operator)

  • After this, the WiFi Calling settings dialog is there, and with my SIMs, is always active.

  • If the device doesn’t support WiFi calling, then the phone doesn’t restart.

  • I’m not sure what happens if the device supports WiFi calling, but the SIM / Network operator does not - all my SIMs do support it :slight_smile:

  • This isn’t specific to /e/ - I see exactly the same behaviour with a LineageOS for microG ROM.

So it looks like the presence or otherwise of this setting is definitely depends on the device, and mat also depend on the network operator / SIM

Hello everyone,

Zac C (@konverts) at Gitlab confirmed the “Reddit” fix. He was able to enable Wi-fi Calling on his dual-sim S9 by edit/adding these lines to the /system/build.prop file using adb in recovery:

  • persist.data.iwlan.enable=true
  • persist.dbg.wfc_avail_ovr=1

Now, off to the next hurdle: Is there anyone who would be so kind as to point me in the right direction as to editing build.prop within recovery?

  • I can access the device via adb from my PC
  • I have TWRP recovery loaded.

Stumbling block: I do not know the command(s) to copy the current build.prop to PC for editing purposes and then the command to push the edited build.prop back to the device. Now onto search “ADB Commands”!

Also, @manoj perhaps there is a way for this fix to be integrated into future builds- that would be awesome.

Thanks again,


Hi @Vaughan,

Thank you for taking the time to respond, most appreciated!

I spent the day looking at SIP providers and clients and I must admit that I am not sure how to configure a DIY solution as you outlined above. It’s seems so simple, and yet I feel like I’m missing crucial pieces of the puzzle :laughing:

I did, however, come across linphone which I set up and configured on two devices to test- very nice, but it doesn’t seem to help me with the above- if it does I would appreciate a nudge in the right direction! :sweat_smile:

Not that you need any more work, but I’m sure many in the /e/ community would be grateful if you were to create a [HOWTO] for this process! I know I would be first in line to test it out on my S6, which I do not believe supports Wi-Fi calling officially.

There’s not much to it really. First get a free sip account. This must be one which provides a phone number. It won’t work if you have only a sip address. I use Sipgate but others are available. Once you have this, enter the details into your sip client app. Your sip provider probably has a guide for popular apps.
When you have sip set up and working, go into the native dialer app and set a divert to the sip number for when unreachable. When this is done, any calls which can’t reach you due to lack of mobile signal will be diverted to the sip number and, if you are on wifi, cause your sip app to ring. Outgoing calls will be made with the sip app.
Be aware that there will be charges on the sip account for outgoing calls.

For those of you on Linux, here are the instructions as graciously provided by @konverts at Gitlab:

  • adb reboot recovery
  • [mount system folder within TWRP]
  • adb pull /system/build.prop [destination]
  • [edit file and save]
  • adb push [destination]/build.prop /system/build.prop
  • adb reboot

I am still researching how to do this in Windows.

@Vaughan If I can’t adequately address this issue via “build.prop” I’m going to circle back to this. For example, I’m not sure where in the /e/ Phone app I set up the call to “divert” to the SIP number as you describe but I suspect it is in Settings/Calling Accounts/SIP Settings/SIP Accounts. I wonder if I would need a separate SIP client at all- perhaps just enter the account info here… :thinking:

Settings>Calls>GSM call settings>Call forwarding

Thanks for your quick reply, @Vaughan most appreciated! I don’t have that setting… I searched for “GSM” and “forwarding” and no bueno. Perhaps we have different /e/OS versions: my S9 has /e/OS Q loaded.

I’m using a S5, /e/OS 9. It’s in the dialer settings, not the phone settings. I’d be surprised if it’s not on Q.

Checked in Phone/Device Settings and in Phone App Settings. Build version 23.0 of the Phone App in /e/OS Q does not have those options.

Perhaps the option appears only if the carrier allows redirections.

That is entirely possible and just may be the most likely answer.

I’m sorry to have raised your hopes. Maybe the idea will help someone else though.