Xiaomi Mi A1: Install experience

xiaomi
user-experience

#1

Have installed and currently using /e/ on a xiaomi Mi A1 I bought cheap. This was intended as a test project as I seek to move from iOS, but 2 days in and it looks like it will be my primary phone going forward. Installing was easy for someone who hasn’t dabbled in that area but I do have a programming/game development background so not unfamiliar with brute force when things hiccup on the way. I installed e using osx and got adb by installing android studio which I found easier than trying to get it independently, overall its pretty smooth and fast to install. I did run into a issue during install where I was stuck with a loading screen telling you the “bootloader is unlocked and can’t verify” which blocked fastboot opening when wiping the data using TWIP which I solved by smashing the volume and power buttons until fastboot opened again so I can resume the install. Not sure if anyone else had a similar issue and that there is a button combo to disable that I didn’t notice. Overall I like it, tho I have a affinity to raw projects like this and look forward to helping it move forward!


#2

Thank you for sharing your experience.
The problem, you ran into with fastboot during the installation process should probably be mentioned on the installation documentation. If you want to help and improve /e/, please raise an issue on the bugtracker about the documentation as explained here.


#3

Hi @television is this the screen you are referring to


this screen appears if you have unlocked your bootloader. The first reboot after a system flash it takes some time to get past this screen but eventually it does get past :slight_smile: . You would see this screen at every reboot or system start…if this is what you are seeing then it is nothing to worry just Xiaomi’s way of warning you about the unlocked bootloader.


#4

Yes that is the screen, which I looked into and noticed it was fine, what I was referring to was after completing the step where you wipe the data from your phone using TWIP and reboot I ran into this issue of that screen looping. I thought I may have made a mistake during install but after pressing the volume buttons a bunch of times I got fastboot to launch. I’m in the process of writing a more detailed description for a issue report.