Xiaomi - POCO M2 Pro / Redmi Note 9S / Redmi Note 9 Pro / Redmi Note 9 Pro Max - miatoll - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

1 Like

The install documentation at Install /e/ on a Xiaomi POCO M2 Pro / Redmi Note 9S / Redmi Note 9 Pro / Redmi Note 9 Pro Max - “miatoll” suggests to download the recovery-e-0.18-r-20211017141319-dev-miatoll.img recovery, however that does not replace the stock recovery which does not allow sideloads.

I followed the joyeuse telegram group (specific for Redmi 9 Note Pro mods), which suggested to use the OrangeFox recovery (enter #flashing and the bot will answer). I was successful to flash the e image with the OrangeFox recovery. Here are some more details: Xiaomi Redmi Note 9 Pro (#8) · Issues · alton / smartphone · GitLab

1 Like

I struggled a lot to Unlock my Redmi Note 9 Pro Joyeuse, (I probably missed some things) here is how I worked it out :

1 Like

I replaced Orangefox recovery by “recovery-e-0.21-r…dev-miatoll” before updating to /e/ 0.21 R OTA it worked perfectly fine

1 Like

Hi there,
I’ve installed /e/ on redmi note 9 pro miatoll yesterday succesfully.
I’ve used the /e/ wiki documentation with ubuntu linux.
I’ve had just a problem after the recovery flash and i had to do sereval times the gestures to reboot with /e/ recovery because of i didn’t understood well the gestures.
So :
1/ press volume up + power
2/ when splash screen ( redmi ) appear, release power button
3/ when vibration, release volume up button
4/ few seconds and /e/ recovery appeared
Bye :wave:

1 Like


i need advice how to relock my redmi note 9 pro after the installation of e/os, so i can use banking apps again? thx for all help!!!

Hi @ananananan welcome to the /e/ forum.

The advice is don’t.

You might search the subject of relocking bootloader, it does come up quite frequently. For most of the devices supported by /e/ the bootloader cannot be relocked. :slightly_frowning_face:

Hi all!
I have e-1.6-r-20221202239576 on my Note 9 Pro and I want to install the newest e-1.6-s-20221201239247. Can I do that without messing with Stock Android 12 ?

Thank you!

Welcome to the /e/ forum @caveman

Before following the upgrade instructions to take you from e-1.6-r-xxx to e-1.6-s-xxx

please ensure that the device is currently using Android 12 firmware.
If the vendor provided multiple updates for that version, e.g. security updates, make sure you are on the latest!

Thanks, but this text can be found at every phones’ upgrade description (even at old phones which never received android 12 update from the vendor).

Does anyone has personal experience on updating from R to S without going back to stock android 12, updating it to 13 and insatlling again the newest e/os. I’m totally confused and the instructions are a “bit” overcomplicated :confused: I don’t want to install a new os 3 times for a simple version upgrade.

In the meantime, is there any experience upgrading from Android R to S without the detour via Xiaomi’s Android 12?

I’m on the same boat here, I’m still running mi-atoll 1.8.1 and I just downloaded 1.11 but I don’t really want to go through the hustle of going back to stock rom AND then starting from zero again in order to upgrade to 1.11. Any news, ideas, workarounds… help please? Thanks in advance

True, mostly because we do not know for certain the date of the latest firmware revision.

I believe /e/OS users and potential users can help each other by sharing their Vendor security patch level from Settings > About phone > Android version > Vendor security patch level.

Edited: firstly, if users could share their Vendor security patch level date from successful installs and / also share intelligence on any public notice that the device goes out of manufacturer support …then subsequent users can make a judgement that Xiaomi definitely stopped firmware upgrades, then I believe you do not need to go though the stage of “Manufacturer ROM reinstall” at your own risk as there is no update in the vendor firmware.

I decided to take the shot. I downloaded the 1.11 update and saved it to SD, made a backup of my data and tried the update over recovery. It worked like a charm! I just installed Paypal (didn’t work on 1.8.1) and it’s running flawlessly. I’ll keep testing and reporting.

Cool :slightly_smiling_face: , in light of your success, please might you share what you see at

Settings > About phone > Android version > Vendor security patch level.

(Update) Calling app isn’t working and something isn’t quite right with calling over whatsapp or signal, voice get’s cut off sometimes, I guess I was too optimistic : ( Will keep checking

Just upgraded my redmi note 9s from R to S and my vendor security patch level is 5 June 2022 - which makes me wonder whether I managed to successfully flash the android 12 firmware prior to eos installation.

Does anybody have a more recent vendor patch with the resmi note 9s?

My vendor security patch level for Redmi Note 9 Pro is 5 June 2022.

/e/OS 1.11-s-20230521 works fine except that the battery drains much faster than with the previous release. This seems to be a known issue and should have been fixed for most devices with 1.12. However, builds for v1.12.3 failed for several devices including miatoll, see https://gitlab.e.foundation/e/backlog/-/issues/7112 . When looking at LineageOS, which is the basis for /e/OS, newer versions are built https://download.lineageos.org/devices/miatoll/builds