Xiaomi Redmi Note 8 reboot all alone

Have you tried to upgrade firmware of your device? You had to be carefully though and select right variant from:

First select ginkgo for Redmi Note 8 or willow for Redmi Note 8T, and then it’s up to you to select right variant for your device. After downloaded right variant zip file, flash it from twrp.

Is the zip file on this page is usable directly :
Redmi Note 8 EEA Firmware V12.5.5.0.RCOEUXM Update | Xiaomi Firmware Updater ?

i.e. I don’t need Xiaomi Flashable Firmware Creator ?

If that right variant for your device, it should be usable at twrp => install => select that zip etc.

That’s what I’ve done to my Rermi Note 8T (willow, which uses same unified ginkho build). Last time had to update after /e/ OS V1 R ginkgo, to get camera fully working (for that obviously fw for A11). But there’s always risk when updating fw, so double check everything.

And I haven’t ever even tried Firmware creator or stock MIUI ROM from there. Placed my RN8T to queue to open bootloader at day 1 and have updated fw few times.

Just to agree with @huuhaa … check very carefully.

I did use ROMs from the site quoted first by @huuhaa.

I would not use something where i did not fully understand the supporting words!

I had a different Xiaomi, the fastboot flashable ROMs were more like 3-4 GB, other smaller firmwares were just an update. I apologise for introducing a distinction with fastboot, but that was my only experience.

I upgraded Xiamo firmware with TWRP.
This does change noting : The smartphone still crashes. :frowning:

That’s really shame. I haven’t notice exactly that with Redmi Note 8T. On the other hand I don’t remember not having mobile networksignal.

For a long time ago I had few times phone waiting for pin-code when tooked from pocket, but not for a long time by now.

Please can we dig into the main issue.

Am I right to say that the phone is stable, in most respects? No significant problem exists with home wifi?

The main issue is mobile network.

“A simple drop of mobile network, causes the phone to crash” – is it as simple as that?

This thread traces difficulties faced in the past; so one assumes you already studied though those ideas!

Two new suggestions;

  • Maybe we should just be looking at it as an “Advanced privacy” issue.
  • Assuming this issue arrived the day you first installed /e/ you might have a simple APN issue with your carrier, a bit liked this recent thread: New user: no mobile internet service

Yes. It is the only problem with this phone.
This problem exists with LineageOS too.

I don’t understand what you mean : “Advanced privacy”.

The problem is not relative to the carrier (I think ;-). I changed my carrier (and the network, 3 times). In white zone phone crashing (but not in the same zone) each time.

Advanced privacy is a very new feature for /e/. Some uses have reported various networking difficulties. Some of the issues have been specific to certain devices. Here is the documentation page for it: Advanced Privacy.

I guess if you could create a log, it might help an expert give a clue. Create a log @/e/

Edit looking at /e/ issues

I can see a logcat might be slightly difficult – I think I would try to get the device to crash by excluding it from a mobile signal.

I might try a powered down microwave oven, or whatever you have to hand, to try to simulate a Faraday cage or bag. If successful you might get a useful log! Just a thought.

Regarding Lineage issues, perhaps checkout My phone randomly reboots, network features can stop working, my keyboard can reset on reboot (#4860) · Issues · LineageOS / issues / android · GitLab@BadDaemon might prefer not to see another /e/ contribution! (Perhaps watch to see if the issue appears/appeared on /e/.)

The log there includes cycling
E tombstoned: Tombstone written to: /data/tombstones/tombstone_20 ...

Seems like this problem returned to my device too after V1.1 update. Yesterday and today phone asked pin when I took phone from pocket and looked phone.

I have similar issues with the phone (Xiaomi redmi note 8t, e/os 1.2) rebooting on its own every now and then. This seems to be connected to turning off advanced privacy. Advanced privacy on the other hand drained battery extremely fast.

Now upgrading to 1.3, lets see if there is any change to these issues.

I had it only few times after writed last message, not once lately.

So far (2 days) no reboots after upgrading to 1.3(Q).

1 Like


after some update problems with CarbonRom (Use of CarbonRom was my solution to stop reboots…), I tried to reinstall my redmi note 8 with e/OS/ v1.11 and the reboot problem is still here.

I must point out that before install e/OS/, I reinstalled stock rom with android 11.

I don’t have this issue on Redmi Note 8T with /e/ 1.11 and /e/ recovery, but I vaguely remember occasional Advanced Privacy crashes with something related to no network interface or airplane mode, but it hasn’t happened recently.