Access Point Name settings not available

Hello community, I am trying to troubleshoot a problem with mobile data on my new Teracube 2e. Everything I can find in existing posts points to configuring the APN, but when I try to do that, it says “Access Point Name settings are not available for this user.” The only thing I can do is reset to default with the drop down menu. Any idea how to fix this?


Hi @Cyborg13 welcome to the /e/ forum. I searched this error which I had not seen before and found quite a few results. Please tell us if either of the proposals here throw any light on your issue. How to Fix APN Settings Not Available for the Current User Profile

Thank you for your reply. Well method one there gave me the + symbol on the APN settings page. So I tried to add a new one using the settings for Android found here: Program Your Data Settings for your device - Wireless Customer Support

At first it didn’t work. Nothing appeared on the APN list. So I rebooted the phone again. Then instead of changing the MNC input to 410 like the AT&T page says, I left it at 280, which is what it defaulted to as I went along.

That worked. I am now getting data with the wifi turned off. I thank you again for providing that link.

I had the same issue and was able to follow it by entering the settings below in the APN set up window. In case anyone else has trouble with this in the future.

Name: Ultra
Apn: Wholesale
mmsc: h__p://
Multimedia messaging port: 8080
mcc: 310
Mnc 240
apn type: default,supl,mms

which are similar to what Mint Mobile directs you do to set up APNs, but different enough to work for me.

To clarify this issue:

Under Settings > Network & Internet > Mobile Network > Advanced > Access Point Names

In a screen entitled “APNs”, it reads “Access Point Name settings are not available for this user”.

At the top of the screen, you’ll see a “+”. Click that, then find the APN settings for your carrier:

And enter in the correct data in that screen.

At the top-right of the screen, there’s a ‘3-vertical dots’ menu, after entering in all the data, tap that and select ‘Save’.

Back out of that window to the main screen, then click on the “Access Point Names” to take you back to the APNs screen you were just on.

You’ll see your carrier (ie: the data you just entered), with a circle that you need to tap on to select it.

Now you can exit out of everything and reboot your phone.

As a potentially-related aside, could this be why App Lounge has to have Mobile Data turned on in order to work? Because now my App Lounge doesn’t crash out when I access ‘Updates’ with Mobile Data turned off, it instead says:

Timeout fetching applications!

Some network issue is preventing fetching all applications.

Open settings to look for Open source apps or PWAs only.


Turning on Mobile Data gets the same thing, but at least now App Lounge isn’t crashing.

Turning on Mobile Data shows “H+”. It never showed that before. That’s Enhanced HSPA… providing up to 168 Mbit/sec downlink speed. That’s one step below 4G. I likely get that because I’ve not got a strong signal. Before I manually set up the APN settings, I was only getting 3G at this location, and only about 300 Kbit/sec.

Hi @D.B on one hand you do clarify the issue with intensive work to manually enter the APNs.

Good work, if you can get it right.

Some network issue is preventing fetching all applications.

Is actually problematic.

That’s the thing, though… Mobile Data works just fine. I just fetched podcasts in my AntennaPod app, the update and downloads worked just fine. WiFi was turned off.

There’s something screwy with App Lounge, it’s only attempting to connect via Mobile Data, and for some reason it can do so for loading in all the icons shown in the app, but it cannot do so when checking for updates, not via Mobile Data, nor via WiFi. But at least it’s not crashing now… before it’d crash, then one had to go to Settings > Apps and notifications > See all apps > App Lounge > Storage & cache, then Clear cache and Clear storage to get it to work again.

Yes, one must be careful when entering in the URLs… the keyboard tends to want to capitalize some things. If you notice it doing this, hitting the ‘Backspace’ key once will revert it to the uncapitalized form.

I’m not sure if the servers consider URLs to be case sensitive, but better to be on the safe side.

ok … so off-topic from the OP …

Why are so many of us having to clear App Lounge data ?

Edit, ah, I see. I did not realise that you were making a direct link with the two things.

Your previous APN settings were good enough to work, but not sufficiently good to allow App Lounge to get the very clear line which it seems to require. Nice one.

Thank you so much! This made my day.
(Or my night, actually – here I am staying up way too late jumping down various rabbit holes on Android forums looking for a solution, when all I had to do was leave the default MNC port number alone!).

App Lounge works! (sort of).

I did my usual weekly checks to see if there were any operating system updates, and app updates in App Lounge and F-Droid.

No updates for the operating system or for apps in F-Droid, but the App Lounge had an update for AntennaPod (I’d installed it from F-Droid).

However, it kept giving the usual error that it couldn’t connect (I only had WiFi enabled, not Cellular Data). I tried it a couple times and it kept giving that error.

So I closed App Lounge, turned on Cellular Data, and reopened App Lounge, then, rather than tapping the ‘Update’ button, I tapped ‘Update All’… it worked, the updated version of AntennaPod downloaded and installed.

That’s the first app that’s ever updated from App Lounge.

That’s a huge advancement over the App Lounge crashing so badly that it closed in the past.

Oh, and if you want a great keyboard, get Hacker’s Keyboard. It’s got everything on one keyboard (no having to switch back and forth for numbers / letters / symbols) and you can even do Ctrl-C (copy), Ctrl-V (Paste) and Ctrl-X (cut), just like on a computer. You can even long-press the circle key and enter, for instance ‘oc’ to get the copyright symbol, amongst other symbols. There’s an add-in dictionary for Hacker’s Keyboard that I had installed on my old phone, but I can’t find it now.

And for a launcher, I use OpenLauncher. It’s got the widgets, it’s lightweight and stable and you can set it up so all the app icons are ‘hidden’ and you have to double-tap the screen to bring them up… so the screen is blank (except for the bottom three controls, unless you use Gesture Navigation, then the screen is completely blank). I set my wallpaper to a black image, so when I turn on the screen, all I see is a blank screen except for the bottom three controls. And you can hide app icons so they never show up on the screen… so for instance, I’ve hidden the Hacker’s Keyboard icon and the OpenLauncher icon, since I can access them (in the case of the keyboard) when the keyboard pops up in an app and (in the case of OpenLauncher) by long-pressing on the screen.

Woot! I figured out how to download apps from the Google Play Store without having to sign in to the Google Play store… you do it on your computer.

First, you find the app you want on Google Play Store.

I wanted the Dictionary for Hacker’s Keyboard.

Then you go here:

And enter the URL of the app above into the dialog box on that site and click “Generate Download Link”. It’ll create a link to download the file (you might have to scroll down, it’s the green link with the text “Click here to download XXXXX now”, where XXXXX is the app’s name).

Download the file to your computer, and install it to your phone from your computer via ADB.

  1. Connect your phone via USB to your computer

  2. Issue the command “adb install {app}” where {app} is the path and name of the file you downloaded above.

So ADB on my computer is at j:\ADB.

The filename is:

So I moved that file to the ADB folder, then at a command prompt I issued:
adb install j:\ADB\

And now auto-complete works for Hacker’s Keyboard.