BankID does not recognise/respond to QR codes

BankID is the dominant app in Sweden for signing in to banking and government services. I managed to install the APK from fine, and it works for logging in to services that don’t require scanning a QR code.

However, some services, such as my bank, requires that I scan a QR code with the BankID app. This does not work. That is, the app brings up the camera, but does not respond to the QR code. Other QR scanning apps detect the code without problems. I have the same version of BankID running on an older Samsung telephone with the preinstalled Android, and that works fine for scanning.

Does anyone have any idea why this happens and how it can be solved?


I have a similar problem, only I can’t even get the ID into my phone since QR scanning is required. I haven’t figured out the reason or a solution or workaround yet. Did you solve your problem?

I also had this or a very similar problem with one banking app, but not with two other banking apps!

The QR code was read, after some time came the message “Google Services are loaded. Error: Loading of Google Services failed”. Fortunately, a manual code entry was offered, which made it possible to activate the banking app.

With an Android StockROM smartphone, none of the three banking apps had an error with the QR code.

It’s a known issue and often discussed in telegram group. The qr reader is not working without original play services (because google want’s know what you are scanning :face_vomiting:)

As far as I rember you could add the audentification code manually. Therefore you have to contact your bank if you don’t have this code available

Yep, the option to add a code manually is there in the app. My bank couldn’t provide a code, though. I’ll try to find a bank that can, but I don’t have high hopes. :frowning:

With my previous /e/ phone I was able to use a separate QR scanning app to scan the code and open it with BankID.

Currently my BankID isn’t responsive at all, but that seems to be a different issue.

Hi Stian, I have had the same problem, and the QR Scanner app from F-Droid helped me get BankID properly installed.

The lack of response (at all) from the BankID app is an additional problem, that seems to be with certain versions of microG Services Core.

If you are affected, a workaround may be to:
Uninstall the BankID app. Navigate to Settings / Apps / microG Services Core, and select DISABLE for microG Services Core. Reinstall the BankID app and proceed with configuration, using a separate QR code app if necessary for your device. When a BankID authentication session is started it will show an error:

"Enable Google Play services
BankID won’t work unless you enable
Google Play services.


Tap anywhere on the screen (apart from the ENABLE button) to dismiss the message. Then the BankID offers the normal authentication screen and you can proceed with your BankID password.

This workaround has been used with an LG G5 (H850) /e/ System version 0.7-2019111931239 (Android 7.1.2 with microG Services Core and BankID 7.12.4.

This seems to be a bug with the version of microG Services Core used ( in this /e/ build. My wife’s G3 (D855) uses LineageOS 16 with a later version of microG services core ( and BankID works once it is installed and configured. However, I had to use the QR Scanner app from F-Droid to get it properly installed.

Hopefully the /e/ builds will be updated with the newer microG version soon.

1 Like

Yes! That worked, and I was finally able to install a BankID again. Thank you!

I still can’t use any service that require a QR scan though. The app SecScanQR will try to open bankid:// links with BankID, but BankID doesn’t respond.


I wonder if you have tried this QR Scanning app:

Also, maybe I can do some testing if you give me an example or two of services that need to scan QR codes and use BankID. I can think of some Swish payments maybe, but can you suggest others I could try?

1 Like

Yes, I used that now to get BankID installed, but it doesn’t seem to handle bankid:// links, which is what the QR codes contain. It rather passes them as a string to my default browser.

Most problematic for me is that my bank requires it for logging in.
The best way to test it though would probably be

On the current stable release for FP3 was able to install, setup and use Mobile BankID without any problems. Setup worked without problems via scanning the QR code.

Let me know if you want to know specific versions of any components in order to hopefully make it work for you as well (if the problem still exists).

Slightly hijacking the thread here, but it is relevant:

How do I get BankID, Swish, and other apps that are not found by the Apps tool in /e/ nor F-droid?

I am newcomer to /e/ ; starting using /e/ q beta on Fairphone3, and pie unofficial on Samsung Galaxy S2.

(I am a power user on Linux, but dont know much about handling Android)

BankID and Swish are only available from the Google store. You can access the Google store anonymously with the app Aurora Store. There are also ways to download the apk via a browser.

Than you!
I am getting the hang on this :slight_smile:

Tjena, Stian! Inga problem här. Yesterday I wiped my Sony XA2 Jolla Sailfish phone and installed /e/ instead. Today i extracted the BankID apk from my Samsung stock Android 10 phone and installed it into my Sony /e/. Registration of a new BankID using the built-in camera went perfectly with no error messages nor hassle whatsoever, just like I was using my Samsung.

I also extracted the Skandia banking apk and the Swish apk. Installation and use of those went like a knife in hot butter. This far /e/ works perfectly for me with no bugs and problems. Camera, gps, bluetooth, fingerprint, you name it. “Everything just works”, like the late Steve Jobs frequently stated. That also applies to the /e/ sync services.

1 Like

Great! It works fine for me now, too :slight_smile:

1 Like

This doesn’t work for me with Faiphone that came with e/os.
I get error when registering it.
“To be able to BankID app a mobile BankID must be ordered from your bank.”
This is when trying to register it on phone from swedbank netbank. There is also no other way to register BankID, only QR allowed.

What happens if you install a QR reader and use it to read Swedbank’s QR code?

I’m running lineageos with microg, and it works perfectly now.
Running with this dist that woks perfectly.