Can not phone... Can not create APN entry point - after update to /e/ 1.1. on moto G3 osprey; Can not select manually the carrier

Hey all,

after upgrading to /e/ 1.1 I lost the APN settings and can not phone or write SMS…
I want to create a new access point in APN, but when I click on “save” - the made settings simply get lost… And in the APN list still is nothing…

I already restarted the phone and tested if it works after the reboot, but it does not.

I hope somebody can help me!
Thank you
Kaspar

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Have you tried first to delete useless apn ?
It’s that i did and that resolve for this difficulty.

In this case it is a good idea to try to set APN with a good wifi connection (preferably no VPN involved) while you make these changes. AFAIK your device likes to check that your settings are on a database somewhere before the Save is allowed. Alternatively if your new settings are not a match, it can be expected they will not Save.

I always like to just phone the carrier to auto send the APN, :slight_smile:

Two similar posts in case it does not work first time.

Hi Clame, thanks for your Response. There is and was none APN…

Hi aibd, thank you for your response.
The Wifi-on-setting of APN I did, but without success. And I used two options of APN instruction - both did not worked.

But I need to clarifiy: my SIM card services do not work at all. And on the APN site is written: “Die Einstellungen für den Zugangspunkt sind für diesen Nutzer nicht verfügbar” Translated: “The settings for the accesspoint are not available for this user”
And beside the SIM-Icon is written “Nur Notrufe (SIM-Karte ist gesperrt.)” Translated: “Only Emergency calls (SIM card is locked)”

Hmmm … I think those are fairly standard messages for a SIM which has no connection to your carrier (although more common are the cases I linked with partial connection to the carrier airwaves).

What does your carrier say about this? (He is collecting your subscription for zero service!) I hope your carrier is not one which makes a big charge for this type of call … if so perhaps you can email.

Currently many carriers are changing APN with tiny changes due to changing technologies worldwide. If doing changes manually you have to be sure to have the latest published data.

Edit; If it were the phone and not an APN setting issue … this 20 point list came up in a search 20 Fixes For The "No SIM Card: Emergency Calls Only" Error

I phoned my carrier - all is ok from this side…
And my SIM is well working, when it is in another Smartphone which is not /e/ 1.1, but a normal googleandroid.

Before the upgrade to /e/ 1.1 the SIM worked in my normal Smartphone also quite well.

When I want to switch off the automatical selection of the carrier net - my display gets dark and the settings app hangs up and I have to restart it.

Did you ask for this to be done? As in “Please send the APN to my device”.

I see you have a difficulty when you cannot get a line ( ! ) but the issue is not a defective SIM card, but it is not registered within the /e/ device.

I suggest that, when you speak to the carrier, you need to explain the card is on “Emergency calls only”. The person who takes the call should be able to tell that the SIM card is “live” and be able push the APN to that device.

(Of course there is always the possibility that is is not APN issue but that the SIM has not been accepted/recognised at all by the device, BUT in these circumstances I would expect a different error message ( NO SIM ) and you could not make Emergency calls.)

Yes, he sent me an SMS with the configurations - but in the moment in this Handy I can not receive his SMS…

1 Like

Ok, thank you.

Now I have just seen this post (not finished reading it yet) where Moto G3 is mentioned with a similar issue in LineageOS

Thank you!
I looked at it, but this person has net - only the slowest.

I do not have any net - and my phone neither asks me about the PIN of my SIM card, when I enter it…
So I think really the problem is: How can I bring my /e/ Os to recognise my SIM and ask for the PIN?

Another point in your OP … you mention update to /e/ 1.1 … what was the device running previously?

As I read the Lineage link … is does seem to include others who “performed an update”.

So I think really the problem is: How can I bring my /e/ Os to recognise my SIM and ask for the PIN?

AFAIK while the phone can make emergency calls, the carrier should be able to push the APN.

While the OP in the other thread has a different issue … the answer I specifically link is closer to your situation.

Previously the device was running with the OS /e/ 0.23

Do you think this should work, although my SIM is locked and the OS did not pushed me for the PIN of my SIM?
Mmh… the problem is: The number of the carrier I can only phone using a Alditalknumber… - so I can not have the SIM at the same time in my phone and the same time phoning the carrier. But I can look, if I find another person with the same carrier.

Ah ok.

To answer a question with a question … is it not the same situation as the carrier putting into service a brand new SIM in a brand new phone?

Of course the carrier thinks this will have happened automagically … until you tell him different :slight_smile:

I am not sure: Because in the Brand-New-Scenario the phone would push me to enter the PIN of the SIM. And in my case this did not happen. And the other thing is, that I am not able to create manually APNs.

But I can test it, who knows…

I see that it is uncertain … but please do check out that link to Gitlab LineageOS Moto G5 (&G3) issue(s) and suggestions too. :slight_smile:

This one I looked and I changed the preferred net types - but nothing happens.
Changing APNs I can not - all I want to save gets lost.


Here you can see it: “The settings for the accesspoint are not available for this user”

I get that … there were a number of suggestions … I thought they might provide an idea! Did you try this

Here is a workaround, because cellular data is not working for me after each reboot, update or otherwise:

Switch network type to “GSM/WCDMA”, wait for connection, then switch network type back to “GSM/WCDMA/LTE”, and it connects to 4G network.

/quoting from the earlier “workaround” link

But I am just including this under the heading of “other ideas” … if it doesn’t work … the issue is somewhere else. :slight_smile:

Yeah, thank you. I proofed it. But nothing changes.

  • I still can not enter the Pin for the SIM card
  • I still have no permission working on APN
  • The SIM card still is locked, only option of “emergency calls”

My Phone realises, that in it is my MedionMobile Sim Card, but I do not have any normal net connection, except emergency calls.

I searched for other similar cases in the forum and put in the search “only emergency calls” or “SIM not recognised”.

These articles I looked at and checked, if there is something similar, but in these cases I realised that their problems are of different kind. Nevertheless the list:

https://community.e.foundation

/t/double-sim-dont-work/31428/6
/t/samsung-a5-2017-sm-a520f-call-and-messages-not-working/35255/8
/t/sim-card-not-detected/34458
/t/cannot-connect-to-mobile-network-on-s8-sm-g950f/37754/21
/t/s4mini-i9195-serranoltexx-no-mobile-network/18945/19
/t/samsung-galaxy-a3-2017-sm-a320fl-f-y-a3y17lte/7189/33
/t/unofficial-build-sony-xperia-xz1-compact-lilac-e-0-13-/t/galaxy-note-3-n9005-no-sim-no-network/1860/4