Corrupted Murena Teracube 2e after E/OS update

Hi All,

I had been enthusiastic about Murena and e/OS offering a simple proposition for tech un-savvy users to have a degoogled, privacy oriented mobile phone, so some year ago I got a Murena Teracube 2e with e/OS pre-installed.
Using and updating all going fine. Then last week, this happened:

  1. I had my device update e/os to v1.16. During the reboot after the update, the splash screen showed this message:
    " Your Device Is Corrupt. It can’t be trusted and may not work properly. […]"
    … and failed to boot up, (even when ignoring the message, by pressing start button)

  2. Every attempt at sideloading to resolve this issue failed in the recovery mode of the boot menu, so before being able to actually sideload anything. So I finally did a factory reset, loosing all and everything on the device. :face_with_symbols_over_mouth:
    The factory reset did solve the boot/corruption issue - device booted as it should.

  3. Next, updated again to the latest e/os v1.18 from the update menu. But rebooting again shows the device is corrupted (same message on splash screen), leading me to conclude the updates since v1.16 somehow cause corruption.
    This time however, ignoring the ‘corruption’- message by pressing start does lead to a succesful boot. So I could technically use my device again.

Questions: How can this happen in the first place after a reqularly executed update?! How can the apparent corruption from the e/OS update be solved? Can I trust my device, or what are the consequences of ignoring the ‘corruption’-message?

Kindly requesting your assistance.
(I am a tech noob simply valueing privacy. I have had a hard time - not - understanding all the versions and variations that are going around between murena, teracube, e/os/, android, lineage os(???), et cetera.)

Thanx in advance for your responses

Google do not want to see their “working environment” messed about with.

When users like you and I want to break out we have to be prepared for negative feedback from “Mr big” back at Google.

Yes … so long as you understand what you are messing with !

Indeed … just keep asking questions.

Good luck.

Thanx @aibd for the helpful postlink and your responses. I still have trouble understanding what Google has yet to do with it, as I bought this phone off Murena directly with e/OS installed out of the box.

Would anyone please care to respond to the question on how to solve the apparent corruption altogether? Thanx

This was a Google ecosystem … into which /e/OS tapped …

Also: What am I messing with when I update through the setting/update section, I do not get it? @aibd: did you imply you should have a tech skillset when you opt for something like e/os…?
(I am no tech, nor have the time, and this event leads me to think maybe I am in over my head and should write e/os off together with the compromised Terracube. :sweat_smile: )

Euhw… I just lost my innocence. :confused:
Is there anything out there that is non-google?

There is

that is a dm-verity error message. At least one of the partitions hashes it boots into is different to what vbmeta expected. vbmeta is built by the packager - /e/. Could be a packaging error.

If you bought the phone from Murena, ping them about this at their support email, could be valuable feedback. There’s no entry on 2e dm-verity issues in the public gitlab backlog.

From your post I gather you’re on the stable branch and updated from (?) to 1.16 stable, then 1.18 stable. Either just link your top post or include that info in an email.

These forum posts could be related:


Murena Teracube 2e (2021) “emerald”

with relocked bootloader

Successfully unproblematic OTA-Update from build IMG-e-1.16-s-20231017342507-stable-emerald TO IMG-e-1.18-s-20231207360611-stable-emerald

Thank you @tcecyk. I read your technical words but must confess, only half understand what they mean. Yes, went from (I think) 1.14_stable to 1.16_stable, when the corruption happened. Then after factory reset updated to 1.18_stable, and it also said _emerald, and -s. I just press the update links that are offered in the menu, assuming they are for this phone, worked so far.
I will get in touch with Murena and include your hypothesis, thanx.

Thank you everyone here for taking the time to respond my uninformed questions, greatly appreciated!