Fairphone 3 "cannot load Android system" after Update to e/OS/ 1.5

Hi everyone,

I tried to help a friend of mine to get her Fairphone 3 (bought from Murena two years ago) working again; unfortunately up to now to no avail, since I’m not an android pro myself.
Having ignored several updates, in Dec. 2022 she finally decided to install the latest (of several listed) updates. The phone ended up with a reboot and shows an error message ever since. That’s when she turned to me for help.
The error message is this: “Cannot load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data stored on this device. (e Recovery / Version 1.5 / slot b)”
Available options: Factory reset, Reboot to recovery, Reboot, Apply update, Reboot to bootloader, Enable ADB, View logs.

I guess we could repair the OS using “factory reset”. The main problem is, she has a lot of important photos on the phone - and no backup.
So I tried to access/backup her data using ADB with “Enable ADB” (see above) + ADB on her Win10 computer + USB cable. I could see some folders via ADB, but wasn’t able to find any data or photos. Maybe they are encrypted? Also there is supposed to be a prompt on the phone to confirm ADB access to the OS - which we didn’t see.

I also spent hours reading a lot of articles in this forum (and learnt a lot about android troubleshooting), some of them describing similar problems, e.g. https://community.e.foundation/t/fairphone-3-does-not-start-after-update/45704 and https://community.e.foundation/t/fairphone-shuts-down-after-entering-pin-and-goes-into-recovery-mode/49202.
Unfortunately I still couldn’t solve the problem.

The question remains: Is it possible to access the data/photos at all in this boot mode (“recovery mode”?)? Or is the data on the phone encrypted? Then we would need to enter the user PIN (or “lock code” etc.) - which ADB didn’t ask for.
Are there any tools to accomplish this?
I read about “twrp”, but it seems quite complicated (and overkill for our problem?) …
I also read about “dm-verity” which could “prevent TWRP from being able to successfully restore a normal system backup” - which might also be true if you backup only the user data, not the system(?).

Can you give me some helpful hints or links how to access/backup the data?
Or is it possible to repair the system without loosing user data? (Maybe it’s just the “disk full” problem? Is it possible to check available disk space using ADB or whatever?)
Any help is greatly appreciated - especially as the phone has been out of use for half a year now because of the problems!


Hi, it is an unfortunate isue. I think I have been there also. Do you have the option to try again? When it happend to me after 3 or so try agains it booted to the old version.

Was it OTA Upgrade?

Here’s the old Post:

1 Like

… meaning you could try to simply reboot. Did you try already?
If this doesn’t help …

So, whatever you attempt to do …

  • Don’t factory reset.
  • Don’t wipe or format the data partition (aka userdata).
  • Don’t execute fastboot -w (which formats userdata).
  • Don’t unlock the bootloader (which will force a factory reset).
  • Don’t lock the bootloader (which will force a factory reset).

Yes, the data partition (aka userdata) is encrypted by default.

As far as I know, the /e/OS recovery can’t decrypt userdata.
I just tried ADB with the /e/OS recovery (1.11) on my Fairphone 3, which leads to nothing helpful in this regard.


I’m not sure whether this helps in the context of the recovery, though. Access to anything meaningful might be restricted. But worth a try perhaps.

TWRP would be the solution to your problem, as the current version can decrypt the data partition up to Android 11 /e/OS on the Fairphone 3/3+, but to boot TWRP the bootloader needs to be unlocked already. Unlocking it now would delete the data (see above).

Whether you are in luck (leaving the bootloader unlocked is not recommended and thus not very common, as it has security implications) you can check by rebooting to bootloader (aka fastboot mode), it will display a red line saying “DEVICE STATE - unlocked” or “locked”.
TWRP only becomes an option if it says “unlocked”.

You could try to re-install the installed OS by applying it as an update via the recovery. It would be better to know what exactly is currently installed in this case, though.
If the recovery got updated with the OS, it would be /e/OS 1.5, but that’s an if.
If that really was the latest update offered by the updater, this would hint towards Android 10 (Q) dev, because no FP3 stable build branch ended with version 1.5.

If you really want to try, you would need install files suitable for use with the recovery, which are not the IMG files offered on the download pages.
Instead, you can get links to install files in the so-called OTA format via https://ota.ecloud.global/api/v1/FP3/dev or https://ota.ecloud.global/api/v1/FP3/stable (see the “url:” lines there).

Those were the days.
As the Fairphone 3/3+ is a so-called A/B device, the OS version before the update is still there on the other OS slot …

… which in this case would be slot a.
If the OS can’t be booted after a few tries, booting should revert to the other slot, with an unlocked bootloader you could also use a fastboot command to switch the slot, but in the meantime Android got rollback protection, meaning that the older OS version might indeed boot, but in case the security patch level is older than on the other slot, it would prompt you to consent to a factory reset for security reasons.

I think the best hope for now would be an unlocked bootloader.

Edit: I forgot:

Because you are not accessing the OS, but the recovery.
Notice how adb devices says “recovery” instead of “device” (as it would say when accessing the booted OS).

If that means “Update via WiFi” then Yes.

Yes we did.

So all in all, according to the tips you and mihi provided my plan for the next visit is:

  1. “Try again” 4 or 5 times
  2. fastboot --set-active=a (not sure but I think I already tried this)
  3. df -h to check if disk is full
  4. du -m | awk ‘$1 >= 100’ (or whatever size) - if disk is full - to check for large files which might not be necessary and could be deleted via ADB
  5. Check for unlocked bootloader, i.e. “rebooting to bootloader (aka fastboot mode), it will display a red line saying “DEVICE STATE - unlocked” or “locked””.
  6. If unlocked try backing up user data using TWRP (details?)

Many thanks to all of you!

No, what I meant ls that you might have gotten a ‘Update via WIFI’ which was not a monthly update but a major upgrade. Because last version on Q was 1.4 on the stable build. And on at murena bought devices are usually on the stable build.


If you did get Update from Q to R, it might not work with 4-5 times trying again.

This topic was automatically closed after 60 days. New replies are no longer allowed.