Fairphone 3 : Update

Same for me with Update of October 3.
fastboot --set-active=b did not work out, device rebooted with a factory reset. So all data lost. How can this happen? Really angry about this! In 10 years of custom roms, this never ever happened to me!

Are you sure this was a factor reset? Maybe the b partition just didn’t have any of your data and its still all on the a partition?
Curious about this too because I’m trying to recover as well!

There is an issue with the last FP3 build which went OTA. The build is being removed from the OTA servers

This is kinda bad, @Manoj Some users might prefer stable channel… is it allowed to post link to stable ROM here?

Are you asking for the stable channel build url ?

The phone did a factory reset without any prompt or user interaction?
(I know the phone can boot into such a prompt when something went wrong, but you would still have to actively choose to go ahead with a factory reset.)

No, I already have it :smiley: it is not rocket science to find it… is it allowed to share here so people can choose dev or stable?

Been hit by the nasty update bug. Did the fastboot --set-active=b and was allowed to use the phone again. Thx for the tip. Hth,

1 Like

Need help:
fastboot --set-active=b didn`t work -> fastboot: unrecognized option ‘–set-active=a’

Can I flash the img over even with locked device state?

Yes, power off your phone and do this

Have you booted into fastboot mode?

If you copied and pasted the “” (one dash, looking rather broad) in this directly from your command line/terminal … the command needs “--” (two normal dashes).

Else … make sure you use the current Android SDK platform tools.

Was using ubuntu terminal - Copied the “- -” inside this forum.
Will give windows a try…

There was some trouble with somehow obscure fastboot command versions in some Linux distributions a while ago.
The current tools I linked to should take care of this.

Can you try typing it out instead of copying? If you copied “- -” then that would be a ‘-’, followed by a space, follewed by “-set-active=a”, which would be incorrect.

Ok guys installed it in windows and worked - uff - handy up and running
Thanks a lot for your help

Didn´t know why not working under linux/ubuntu - fastboot version 1.6.0 was installed - I also tried to update fastboot?

Need help:
Tried to change the booting partition from b to a but it puts :

Slot does not exist. supported slots are:

The command > getvar current-slot shows me that the current slot is b.

Is it necessary that the device state is unlocked?

Is there key combination for reset? So only thing what could have to wrong on my side is that I had some struggle going from corrupt system warning into Fastboot mode, because often power buttons just rebooter normal, so I have long pursuing volume down and power etc.

Keeping the power button pressed for about 15 seconds will force a reboot.
Keeping Volume + pressed while starting/rebooting the phone will boot the phone into recovery mode. A factory reset is an option there, but you would have to actively select and confirm it.
Keeping Volume - pressed while starting/rebooting the phone will boot the phone into Fastboot Mode. You would need to connect the phone to a computer and know what exactly to do then to delete user data with fastboot.

When something went wrong, I’ve seen the phone boot into a prompt which offered a factory reset as an option, but you would still need to actively choose or confirm to do that. This was also mentioned in the forum announcement about this update …

I don’t think a key combo would do a factory reset, this would be much too dangerous, there would always be somebody accidentally resetting their phones.
If a data loss without user interaction really happened I would rather think the update somehow did it, which obviously would be one of the worst issues imaginable, but I don’t have the retracted file to try to check this, and the announcement only said …

Please quote the error message with the exact command you ran before.

I have done this so far grafik