Issues with last OTA update

Hi everyone, this is an important announcement for users of /e/OS-dev (not pre-install /e/ smartphones):
Yesterday’s OTA update has been reported to cause some issues. It’s been removed until we understand the situation better.
In the meantime, if you have updated to this update and see an error message at boot time asking for Factory reset, don’t do it.
Please wait for further information how to fix this.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Those who already updated can flash the previous ota update from twrp, that worked for me…

Its in /data/lineagos_updates


It worked for me, too.

Don’t forget to wipe cache/Dalvik.

Indeed. Had to use previous image to get back again. During boot it went back into TWRP.

On an A/B device you can try to just set the OS slot back to the prior one with the non-updated state of the OS …


Hi everybody !
Since the update, I get the issue and my phone doesn’t boot. I unfortunately don’t have previous images since I configured my phone to delete them after install.
I tried install / flash images found on , with “standard” recovery ui or twrp, without success (older timestamp seems to be problematic). I also tried to change slot (A/B device), but the other slot just boots on bootloader.
Do anybody have an idea ? Or maybe some information about the “further information” which should be coming ? :slightly_smiling_face:

I did a clean install of e-0.12 on my Pixel and everything went well. I was using e-0.11. No problems for now but I will keep an eye on this.

1 Like

Hi everyone,

For the ones who faced a problem when applying the last update (v0.12), we are sorry for the inconvenience. To better understand where the problem is coming from, could you please take few minutes to answer to the following questions? Thank you in advance!

  1. Which device do you have?
  2. Which android version do you run?
  3. When did you install /e/ on your device?
  4. When did you try to apply the last update?
  5. How did you apply the update?
  6. What behavior did you faced?
    • Does the device keep bootlooping?
    • Does the device reboot to bootloader or recover after a while?
    • Did you manually to wipe userdata after this caused?
    • Did the device reboot to recovery and ask you to Factory reset data to continue?
  7. Did you faced this behavior previously?
  8. Do you switch to other ROMs on a regular basis on this device, including /e/ test builds?
1 Like

Fairphone 2


About half a year ago.


/e/ updater


Yes, reboots to TWRP (recovery)







Hello, here are my info

  1. Fairphone 3
  2. Android 9
  3. 2 weeks after the official partnership between fairphone and /e/
  4. When it came out, 3.10.2020
  5. Through the /e/ installer
  6. The device rebooted to recovery and asked to Factory reset data to continue
  7. Never faced this behaviour before
  8. It was the first time I switched to another ROM

Hope this help !

1 Like

My info

  1. Xiaomi Redmi 3s
  2. Android 9
  3. About two weeks bevor this e-012 update
  4. When it came out, 3.10.2020
  5. Android OTA updater in /e/
  6. Rebooted to recovery, but doesn’t aks for factory reset
  7. Never faced this behaviour before (but I’m new on /e/)
  8. Second time (LineageOS was the first)

My setup was only two weeks old. When the phone didn’t start after the update, I made a new clean install of this e-012 update. It is still running without problems. The problem seems to be the update from an older version and not the image itself.


1 Like

I already stated my issue here, and on a topic on the Fairphone category: FP3 update gone wrong factory data reset.

  1. Fairphone 3
  2. Android 9
  3. Late Augustus 2020, installed manually
  4. October 30, in early evening (GMT)
  5. I received a notification for OTA update, so I did it OTA
  6. I have not done factory reset
    • By default (slot_a, with the update), the device boots on a (new?) /e/ “Recovery” screen.
      • the error: “Can’t load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data”.
      • The screen shows: /e/ logo, “Recovery”, “Version 0.12 ()”, “Active slot: a”, and the error. All of this on a white background.
      • There is no button on the screen, but tapping many times on the screen or pressing the power button leads to a screen with an android error logo (the android mascot on its back, with its belly open) for half a second, and then reboot.
      • I once got a message asking me to confirm factory-reset, but I don’t know which key combo I had performed, and was not able to reproduce…
      • Sometimes, it switches to slot_b when rebooting.
    • When on slot_b (switched with fastboot command, or when the phone decides to switch on its own), I get the error on a LineageOS screen.
      • The error “Can’t load Android system. You continue to get this message, factory data reset and erase a device.”
      • The screen is the one shown in the gitlab issue above-mentioned (sorry I cannot link directly the image since I am limited to 2 links).
    • When rebooting (not when simply booting from “START” in fastboot mode), the phone seems to boot 2 times (it vibrates and shows OEM logo 2 times) before displaying the error screen.
    • In both cases, I cannot enter the usual recovery screen (that has several options) when selecting “Recovery mode” in fastboot mode (it just boots to the error screen).
      I have to press power+vol_down during boot (not on the error screen) to get to fastboot and then I can get the usual recovery screen.
      • On FP3, TWRP is not preinstalled, so that screen is a LOS recovery screen (image below) when I am in slot_b; and an equivalent screen (i.e. same options) with the /e/ design described for the error, when I am in slot_a (updated slot).
      • When on slot_a and entering this mode, if I reboot the phone switches to slot_b.
      • When I am in the case in which I know that selecting “Recovery mode” will not get me to recovery mode: if I select “Power off” in fastboot menu, it won’t turn off but only reboot. (On the opposite, if I could enter recovery, I can also switch it off.)
  7. I never faced this before. (I might add that I was using version 0.12 release via OTA on September 30, and that I did not face issue with that version/update).
  8. No.

Same goes for me, exactly the same. Unfortunately my bootloader is locked again so that I am not able to flash the 0.11 version again. What would happen if I do a factory reset?
Edit: The comand flash unlock returns: command failed as it is disabled in the android settings I think.
Am I getting it right that if I would do a factory reset the phone would boot stock android again and I could change manually to /e/ afterwards if I wanted?
As both slots seem to be “broken” and the bootloader is locker (I cannot flash an older version like 0.11) I think I have no other choice … :frowning:

1 Like

1 FP3
2 9
3 around june/july
4 3.10.2020
5 settings > system > updater

  • I don’t know what this is, but I don’t think so
  • I don’t think so
  • no
  • yes, I think so

7 no
8 no

1 Like

Do we still not have any solution or at least some news??

Device builds including for FP3 build Pie and Q are under testing. Should be released to all users OTA most probably by end of this coming week earliest.

Any news yet? Or otherwise: at the point when you will have news, where will they be published?

Should be published early this coming week. The testing is almost complete. If there are any changes I will share on this thread.

Update: 16 Nov The release of the OTA for dev builds will be delayed. Users have shared some issues which have been added to the testing .
Expect testing to stretch through this week.


Is there still hope or should we get used to the idea that our data is lost? Can you make any realistic projections concerning a time-span? I really start to miss /e/ and my FP…

We will start testing the next build from today…I have been using same test builds on a couple of our test devices and they work well.
This also has the microg covid tracing framework patch which still needs some work…expect the builds to be available for all user by next week end latest.