Feedback for v1.20

Updated from version: to
Not rooted

Manual update:
Load new recovery ,
did NOT factory reset, did NOT format;
Sideloaded the new OS Firmware.

After reboot, boot hangs on sign “e” with dot bellow.
Try the flash again, same results. To recover I
loaded old 1.19 recovery and sideload old
Phone boots fine on 1.19, all data saved. No harm done.

However upgrade to 1.20 did not succeed!

If you need to unbrick (downgrade):
Note if phone refuse to downgrade (so back to 1.19) load old recovery on both slots
fastboot --slot ‘all’ flash boot ./recovery-e-1.19.1-s-20240112372761-dev-tissot.img

and than side load old e os.

Hi there,
something special to get it running with MicroG?
I have a few apps already paid and used and now on FP5 /e/OS 1.20-t (previous 1.19) again no chance to get “paid” version of e.g. “Automate”, get error message “Google play store error: no premium product”, also uninstalled and reinstalled. MicroG is enabled with the Google account the apps are bought with.
Tried also other apps, no chance…
Any ideas?

Some months ago, I had the same effect when moving vom S to T with my Motorola Moto One Action. Unlocking the bootloader helped because firmware/partitions changed. Without unlocking the bootloader, new partitions cannot be written. But be aware that unlocking the bootloader removes user data! A backup is necessary!

@DietmarT, Without bootloader unlocked I could not have e os 1.19 loaded as base for upgrade. Xiaomi does not support locking bootloader while not using original miui.Thanks anyway.

  • Vendor Name: Fairphone
  • Device name: Fairphone 4
  • Device CodeName: FP4
  • Previous Version of /e/OS: 1.19.1-s (stable)
  • Rooted: False

Tested with Fairphone Checkup, except secondary microphone I do not notice an issue. It continues to connect to Japanese mobile carriers (KDDI and docomo) as well.

With secondary microphone, the phone creates echo feedback loop on both the updated version and the previous version (Reported here) and loudspeaker mode is barely usable.

Vendor Name: Xiaomi
Device name: Mi A2
Device CodeName: jasmine_sprout
Version of /e/OS which existed previously: V1.19.1
The device is Not rooted

The OTA update from V1.19.1 went completely smoothly. A new installation with stock Android 10 Global Firmware V11.0.28.0.QDIMIXM was much more complex because I was unable to get e-Recovery V1.20 to work. Only with the help of an older PitchBlack Recover based on TWRP 3.4.0 was I then able to successfully install /e/OS V1.19.1 - and then update it via OTA update.

I have also successfully installed and tested (disadvantage of my test versions: Gapps are already included):

PixelExperience | Official | Android 13 (T)

DerpFest | Tango | Official | Android 13 (T)

DerpFest in particular shows that AOSP 11 (R) - see [ Sunsetting LineageOS 18.1 ] doesn’t have to be the end and that there are options. In addition, the DerpFest recovery is not a minimal recovery, but has functions that a Lineage recovery does not know.

  • S7 EDGE
  • SM-G935F
  • 1.17
  • Not rooted

Thank you for this update !
I was on. 1.17 and updated first to 1.18 and then 1.20.

All seems ok except Magic Earth. The localisation works but as I start moving it doesn’t follow me and freezes at the starting point. I disabled Advanced Privaxy and still doesn’t work.
The gps is Ok, I tried Waze instead and it works well.

Thank you !

Tested after update:

  • Vendor Name: Murena
  • Device name: Fairphone 4
  • Device CodeName: FP4
  • Previous Version of /e/OS: 1.19.1-s (stable)
  • Rooted: False

All good once I changed account to ( this resolved my cloud sync issues at murena cloud) :+1:

Vendor Name: Xiaomi
Device name: Mi A1
Device CodeName: tissot
Version of /e/OS which existed previously: e-1.5-R
The device is Not rooted

Manual upgrade to /e/OS-T V1.20

First function test successful:
:white_check_mark: Works fine: 4G LTE, WLAN, BT, GPS (GPS, GLONASS, BDS), e-Cameras
:heavy_heart_exclamation: Very pleasing additional functions: Infrared port, FM radio (UKW)

1 Like

@Xxpsilon, Any special action in compare to documented except wipe/ format? Did you wipe cache, data? Asking because I dont know why my upgrade failed.I have two profiles on this phone and wonder if that could prevent booting. Thx

My Mi A1 is not a daily driver. It was upgraded from /e/OS-R (A11) to /e/OS-T (A13). Therefore I did a clean install (irretrievable deletion of all data) to have a perfect installation for future updates.

Vendor Name: Xiaomi Redmi
Device name: Note 6 Pro
Device CodeName: twolip
Version of /e/OS which existed previously: e-1.16-r-20231021343335-dev-twolip
The device is Not rooted

OTA-Update to /e/OS-R V1.20

First function test successful:
:white_check_mark: Works fine: 4G LTE, WLAN (Wi-Fi 802.11 a/b/g/n/a) , BT 5.0, GPS, e-Cameras
:heavy_heart_exclamation: Very pleasing additional functions: Infrared port, FM radio (UKW)

Vendor Name: Gigaset
Device name: GS290
Device CodeName: GS290
Version of /e/OS or Stock which existed previously: 1.19.1-s-20240109372023-stable-GS290
Is the device Rooted/ Not rooted: Not rooted

Updated smoothly via OTA.

There was an increased level of battery consumption. However after a few days the rate of battery depletion reduced but is still ever so slightly more than it was using v1.19.

Overall very happy with the performance of the phone using the /e/OS versions released after December 2023. The phone had become so slow and frustating to use, I was on the verge of binning it and using an old Samsung phone running LineageOS.

Vendor Name: Murena Fairphone
Device name: Fairphone 4
Device CodeName: FP4
Previous Version of /e/OS: 1.19.1-s (stable)
Rooted: False

Won’t update past 81% updater now keeps crashing.

Well, my Samsung A5 is also draining my battery. I have 3000 mAh of capacity, but I like to think the battery is old. Still, the app Accu Battery tells me my battery health is 80%. I am really not a heavy user, in contrary: I use the phone far less than most people do.

I still don’t have 1.20 available. I have a Samsung Galaxy S10+ (currently running 1.19).

Is it the case that the “slotted” release time/date hasn’t reached me yet, or the 1.20 update is not available for the S10+? Does anybody know?

1 Like

Looking at the ROMs published for Galaxy S10+ we see that the final Android 12 (S) was e-1.19.1-s and that your next build now will be e-1.20-t, Android 13 (T) so a manual Upgrade will be required (no OTA Upgrades on dev builds).

Android (T) upgrades should need no Format data and no “Return to stock ROM” just adb sideload as this [Guide]. Always take a back up of essentials first.

Fairphone 5 /FP5
Regularly bought via Murena. Not rooted

“Smooth display” feature (90Hz) makes bliss launcher crash regularly once a day at random. It looks like the phone is rebooting, but uptime is the same.

Today it crashed and displayed the bootloader the first time.

With 60Hz setting no crash, or with 90Hz and KISS launcher no crash.

1 Like

My KISS crashes. What’s the german name of this feature so I can try out other settings?