Feedback for v1.20

I use a Mi 11 Lite 5G with 1.19 (perfect in function)

Will 1.20 be released as an automatic update? Or do I have to install it manually?

Referring to the ROM download page of this device https://images.ecloud.global/dev/lisa/ e-1.20-t is published but it will be a manual upgrade to Android 13 (T).

(OTA upgrades only happen for stable builds.)

• Vendor Name : Motorola
• Device name : moto g32
• Device CodeName : Devon
• Version of /e/OS or Stock which existed previously : Stock
• Is the device Rooted / Not rooted : Not

As a first time user of /e/OS I had some trouble with the the install. After successfully unlocking and installing the recovery-image I could not flash the main part of the software with the ADB command line options. My solution, to put the zip file on a SD card and boot in the recovery → Apply update → Choose from disk. This did the trick for me.

To avoid confusion, it is advantageous to always specify the code name Xiaomi Mi 11 Lite 5G “renoir” of the device used.

Updates and upgrades are often confused with each other. The differences are:

An “update” is an update of the existing version /e/OS-R. An “upgrade” is an update to a higher operating system version: /e/OS-T.

The /e/OS updater app does not support “upgrades” from one version of /e/OS to another, and will block installation to any update for a different version.

See more manually upgrading renoir

Technically it does, but such “OTA upgrades” will have to be meticulously prepared with a lot of development and testing effort for an individual device for an individual upgrade step.
This has been done in the past, and efforts are ongoing. Anybody interested can follow proceedings in the weekly development and testing updates … https://community.e.foundation/tag/development-updates … section currently named “OS OTA Related information”.

But … the default is indeed manual upgrading when an upgrade of the underlying Android version is needed.

As long as an OTA-Upgrade for DEV devices supported by /e/OS is not currently available, the only option is manual upgrading.

Yes, this info is included in the “OS OTA Related information” currently. And it isn’t any different on stable when an OTA upgrade is not prepared for the individual device for the individual upgrade step at hand.

Doesn’t take away from the fact that the updater App can do this in general.
Edit: The feature was introduced in week 6, 2022 with an OTA upgrade for Samsung S9/S9+ … Week 06, 2022 : Development and Testing Updates

OTA upgrades mean a comfortable user experience for e-users and usually a loss-free (personal data, apps) transition to the next /e/OS generation. The sooner it is available for all devices, the better.

By the way @AnotherElk my messages did not refer to Xiaomi 11 Lite 5G NE / 11 Lite NE 5G / Mi 11 LE “lisa” nor Samsung S9/S9+ but to @moeppie’s request Xiaomi Mi 11 Lite 5G “renoir”

I got similar message and issue. But I am logged into WeChat, but it crashes directly. After a couple of crasches it goes to safe mode and (try to) repair. But crashes again directly. So far no success by eg restart, clear cashe etc. I have not reinstalled, want to avoid iy due to avoid data loss.

Won’t that mean you come under Chinese ToC, with data storage and whatever they do for surveillance, spy and whatever the Chinese version of the app do?

Updated OTA both FP3 and Terracube 2e to v1.20-s-. No issues so far :person_raising_hand:

MI A1
tissot
Updated from version: e-1.19.1-s-20240112372761-dev-tissot.zip to e-1.20-t-20240223382228-dev-tissot.zip
Not rooted

Manual update:
Load new recovery ,
did NOT factory reset, did NOT format;
Sideloaded the new OS Firmware.

After reboot, boot hangs on sign “e” with dot bellow.
Try the flash again, same results. To recover I
loaded old 1.19 recovery and sideload old e-1.19.1-s-20240112372761-dev-tissot.zip.
Phone boots fine on 1.19, all data saved. No harm done.

However upgrade to 1.20 did not succeed!

If you need to unbrick (downgrade):
Note if phone refuse to downgrade (so back to 1.19) load old recovery on both slots
fastboot --slot ‘all’ flash boot ./recovery-e-1.19.1-s-20240112372761-dev-tissot.img

and than side load old e os.

Hi there,
something special to get it running with MicroG?
I have a few apps already paid and used and now on FP5 /e/OS 1.20-t (previous 1.19) again no chance to get “paid” version of e.g. “Automate”, get error message “Google play store error: no premium product”, also uninstalled and reinstalled. MicroG is enabled with the Google account the apps are bought with.
Tried also other apps, no chance…
Any ideas?
Regards,
Fritz

Some months ago, I had the same effect when moving vom S to T with my Motorola Moto One Action. Unlocking the bootloader helped because firmware/partitions changed. Without unlocking the bootloader, new partitions cannot be written. But be aware that unlocking the bootloader removes user data! A backup is necessary!

@DietmarT, Without bootloader unlocked I could not have e os 1.19 loaded as base for upgrade. Xiaomi does not support locking bootloader while not using original miui.Thanks anyway.

  • Vendor Name: Fairphone
  • Device name: Fairphone 4
  • Device CodeName: FP4
  • Previous Version of /e/OS: 1.19.1-s (stable)
  • Rooted: False

Tested with Fairphone Checkup, except secondary microphone I do not notice an issue. It continues to connect to Japanese mobile carriers (KDDI and docomo) as well.

With secondary microphone, the phone creates echo feedback loop on both the updated version and the previous version (Reported here) and loudspeaker mode is barely usable.

Vendor Name: Xiaomi
Device name: Mi A2
Device CodeName: jasmine_sprout
Version of /e/OS which existed previously: V1.19.1
The device is Not rooted

The OTA update from V1.19.1 went completely smoothly. A new installation with stock Android 10 Global Firmware V11.0.28.0.QDIMIXM was much more complex because I was unable to get e-Recovery V1.20 to work. Only with the help of an older PitchBlack Recover based on TWRP 3.4.0 was I then able to successfully install /e/OS V1.19.1 - and then update it via OTA update.


I have also successfully installed and tested (disadvantage of my test versions: Gapps are already included):

PixelExperience | Official | Android 13 (T)
PixelExperience_jasmine_sprout-13.0-20231128

DerpFest | Tango | Official | Android 13 (T)
DerpFest-13-Official-Tango-jasmine_sprout-20240211

DerpFest in particular shows that AOSP 11 (R) - see [ Sunsetting LineageOS 18.1 ] doesn’t have to be the end and that there are options. In addition, the DerpFest recovery is not a minimal recovery, but has functions that a Lineage recovery does not know.

  • SAMSUNG
  • S7 EDGE
  • SM-G935F
  • 1.17
  • Not rooted

Thank you for this update !
I was on. 1.17 and updated first to 1.18 and then 1.20.

All seems ok except Magic Earth. The localisation works but as I start moving it doesn’t follow me and freezes at the starting point. I disabled Advanced Privaxy and still doesn’t work.
The gps is Ok, I tried Waze instead and it works well.

Thank you !

Tested after update:

  • Vendor Name: Murena
  • Device name: Fairphone 4
  • Device CodeName: FP4
  • Previous Version of /e/OS: 1.19.1-s (stable)
  • Rooted: False

All good once I changed @e.email account to @murena.io ( this resolved my cloud sync issues at murena cloud) :+1: