Feedback for v1.6

Thanks for your help.

I think I will contact Murena and ask what to do, but I expect the worst (having to ship it back to them).

If I should find an easier solution I will let the community know, maybe someone else is having the same problem.

Thank you for this new release!

FP3 user here. Getting location to work is still hit and miss: I have to activate and deactivate real location and advanced privacy a bunch of times before it works. Also, location is imprecise (it detects me almost 1 km away from my actual location), both with Magic Earth and Google Maps (the latter which I’ve installed just to check whether or not it was just Magic Earth).

Another issue is that the browser will fail to load a webpage via mobile data. Turning mobile data off and on again does the trick.

Note that these issues were already present in version 1.5, so these aren’t specific to version 1.6.

Hi @Asperamanca the device in this case FP3 is now on R and as such the Q builds are not being built. Users should upgrade to R which is available OTA as well. For devices that are still on Q we continue Q builds.

Thanks for the quick update!
How do I update without data loss? I have read into some posts and articles, but they seem more intended for users who want to switch from stock android to e
Also, any reason not to upgrade to S right away?

FP3+ here.
This morning it gave me a scare, because the “e + bouncing dot” boot screen remained for ages (one or two minutes?) and I thought I was running into the issue mentioned by others around here, but just when I was starting to lose hope the boot succeeded. Usually (even after the update) it’s pretty fast. Seems a bit random for some reason.

Also (but perhaps not 1.6-related), yesterday the App Lounge complained about failing to get an anonymous token for the first time ever, but hitting “Retry” fixed it and I could update Signal afterwards. :woman_shrugging:

Via the Updater in the Settings.

OTA = Over the air = via mobile network or Wi-Fi = via updater.

Updater does not offer any updates. And how would I tell updater to update from q to r or s?

Only Stable channel offers an OTA upgrade, if you use a DEV build you have to do a manual upgrade.

I don’t understand. I installed e as per instructions about a year ago, and used OTA updates since. Just that they seemed to stop at 1.5 for q. So the question is how to upgrade to r or s without data loss.

Oh…could it be that prior to 1.0, there were only dev builds, so the instructions back then linked to a dev image? And that I had been on dev channel ever since?
Any way to change that?

I’ve also had these same 2 issues with my FP3+ following update from 1.5r to 1.6r (stable), so not an isolated incident.
Time to restart now seen to vary, with the bouncing dot appearing for anything between just a few seconds (as with 1.5) to (what feels like) over a minute when it starts to cause concern.
I’ve only had the App Lounge anonymous token issue once, not seen before 1.6 update.

1 Like

Did I get it right that I have do the upgrade on FP3 dev from q to r manually with data loss?

Hi, I get the update on my Fairphone 3 with the auto updater.
Unless this error message at the very beginning when each time the Os starts, no problems detected.

com.qualcomm.qti.workloadclassifier stoped working.


so far I am very happy with my eOS on my Fairphone 4 but with the Android 12 Update I have got some issues. If I call someone then I dont have these “calling sound” anymore which makes you (the caller) know, that the phone of the other person (the called) is ringing (I dont know how to describe it better). Before the update that was fine.

Second problem, if I open for example a “open.spotify” link in any app, it will open spotify, but it never starts playing this song. Similar problem with open a wikipedia or newpipe/youtube link. I have installed the wikipedia app and the newpipe app on my phone, but now links will be opened in my browser and not in the special app they are for.

I hope you can help me! Best regards, Jelle

After I upgraded my Fairphone 3 (TWRP recovery, Magisk) from 1.5-q-dev to 1.6-r-dev via adb sideload the crash logger app “Scoop” (F-Droid) shows this crash every time when the phone has booted:

Process: com.qualcomm.qti.qms.service.trustzoneaccess, PID: 8620
java.lang.UnsatisfiedLinkError: dlopen failed: library "" not found
    at java.lang.Runtime.loadLibrary0(
    at java.lang.Runtime.loadLibrary0(
    at java.lang.System.loadLibrary(
    at com.qualcomm.qti.qms.service.trustzoneaccess.TZAccessService.<clinit>(
    at java.lang.Class.newInstance(Native Method)
    at android.os.Handler.dispatchMessage(
    at android.os.Looper.loop(
    at java.lang.reflect.Method.invoke(Native Method)

v1.5-q-dev worked without problems.

Also: Magisk Zygisk remains deactivated although the respective setting is activated.

(I sent this issue to the helpdesk also.)

  • Vendor Name: Google
  • Device name: Pixel 4a
  • Device CodeName: sunfish
  • Version of /e/OS or Stock which existed previously: e1.5r-stable
  • Is the device Rooted / Not rooted: Not rooted

No issues detected over the weekend after installing on friday

  • Vendor Name: Fairphone
  • Device name: Murena Fairphone 4
  • Device CodeName: FP4
  • Version of /e/OS: 1.6
  • Device: Not rooted

I am using a Murena Fairphone 4 in the USA with the carrier Mint Mobile (T-Mobile MVNO), and /e/OS 1.6 has made it possible to enable 4G calling!

I made a separate post here.

Thanks again to all of the developers that made this possible!


Hi & thanks for your great work!

Unfortunately, on my FP3 Q (1.5-q-20221031230909-dev-FP3) the OTA update to 1.6 is still not available, not to mention an OTA upgrade from Q to R.

Any idea what might be the problem?

Vendor name: Fairphone
Device name: Fairphone 3
Device codename: fairphone-fp3
Version: 1.5-q-20221031230909-dev-FP3
Device is rooted
1 Like

_______________ This : :arrow_down:

For me, that means never dev again. Anybody who flirts with the dev build of S should also keep this obstacle in mind when choosing: As an early adopter, installing /e/ when Q was still dev only, you never where updated to the stable channel, but remained dev. I never realized that until now. That seems to unnecessarily complicate updating and upgrading, because one is now stuck on dev channel without OTA updates or the possibility of OTA upgrades.

I really love /e/ and the effort that is put in it by its team and community, but I hate the prospect of completely setting up my phone once again. Meeh, but well, it’s worth the effort^.^