Feedback for v1.8

Just some minutes ago Android felt so loved and complete because somebody out there still thought it was very reliable. It was but a brief dream.

Don’t expect overall software quality on consumer devices. Always expect the unexpected … or at least let’s say don’t be surprised about the unexpected.


About GPS no more working on S9+ for some apps since 1.2 (#5984) · Issues · e / Backlog · GitLab, after updating to 1.8.1 around Feb., 11th or 12th, the bug goes on staying inactive (has been so with 1.7 at least since Feb. 8th) : GPS working as expected in Naturalist and TrackBook apps + no more “Bad GNSS date time” error in GPSTest.
Now waiting for it to be back in a few days, as it always did since the beginning (no more than around 2 weeks inactive) …

Sorry, but that’s nonsense. I work at a software development company and if we were to ship products this reliable for our customers embedded devices - some of them even Android based - then we would soon be out of our jobs.

Of course, your approach to forming expectation is just as valid.
There’s only potential for negative surprises this way, though. Perhaps I just want to have potential for positive surprises. Not that I could recall many of those, but … potential.


Ah, okay. Then this was just a misunderstanding on my part, informed partly by the fear that something would happen to my saved files.

corrupt sdcard after ota update is often reported and I’ve seen it myself. SD card not useable - #3 by Herve5 … it’s hard to debug as you’d need the recovery and system itself on debug settings to print early boot logs to see what’s happening in both environments. Reboots help because a filesystem check on boot is run that can fix things depending on kernel fs driver version


if you’re into docker there’s an easy debug app (“battery-historian”) to see what is waking up the device. Could just be some short sync interval somewhere - Moto battery drain comparison - #15 by tcecyk

After cleaning cache of all apps ui runs smooth again. Try:

Fairphone · FP3+
From 1.7 (Andro 11) to 1.8.1 (Andro 11) via “System updates”
1.8.1-r-2023 02 04  25 70 76-stable-FP3
Bought with /e/ preinstalled, no rooted-or-not-rooted changes ever
(not sure what the default is for preinstalled)

I did not notice a startup slowdown in Gallery, but today I started getting worse: Gallery crashes upon launch, perhaps because it tries to generate thumbnails.

Going through the File Manager and doing “Open with: Gallery” on any picture works, but launching the Gallery directly by itself briefly displays the “Timeline” screen title and instantly crashes.
Tried clearing its cache and even app data, and of course a couple of reboots, but no luck.

I haven’t seen anything anywhere about this issue, but perhaps that’s a more specific case of the lag issue?
Edit: Using Gallery to pick an attachment for a message from other apps (QKSMS for example) fails as well, kinda like in Feedback for v1.8 - #129 by ntp.

1.8.1 was my favorite /e/ version until I ran into this. :upside_down_face: I installed another image-viewing app as a replacement for now.

1 Like

Yes indeed, running “Simple gallery pro” works pretty fine.

No idea exactly where this issue comes from, In my case most on my pics are stored on the SD Card.

It’s hard to understand how this glaring problem wasn’t noticed during upstream testing.

Let’s hope it will be fixed in the next 1.9 release…

I have a mixture of SD and internal, but it only started crashing when I took a couple of new pictures with the default Camera app and then went back to Gallery, as if Gallery choked on those pics when trying to create their thumbnails. NB: Those new pictures were saved to the internal storage.
If that’s the case, deleting the cache and app data maybe made it even worse, as perhaps now even more thumbnails need to be generated from scratch. :sweat_smile:
I used to be able to open Gallery without issues in the first days of my 1.8.1 usage, perhaps because I was taking no new picture (I’m not much of a Camera user).

I made the update 1.8.1 on my fairphone 3
and first it was ok, but then the phone stopped and I got this screen


Can’t load Android system. Your data may be corrupt. If you continue to get this message, you may need to perfrom a factory data reset and erase all user data stored on this device.

Try again
Factory data reset

I clic on try again, and everything was fine, but today, same thing happen, the phone stopped, I get the screen but the “try again” doesn’t work as each time, i got the notification “bliss lancher has stopped working” and the phone swith off to the “try again screen”.
I can’t save my data on the computer and try “factory reset”.
Dunno what I can do to save my phone and data.

Try a different launcher maybe? Rutheless launcher is really good.

Did anyone try to update from 1.6 to 1.8 on FP3?
Not sure if I need to do the 1.7?
I will wait though until 1.8 is fixed for FP3 since it’s obviously unstable on this phone.

i can’t choose the lancher

go to settings, default apps, change bliss to rutheless on the default home setting

I’m not actually sure if this is connected to v1.8, but it just happened for the first time: after a restart of my Fairphone 4, the first page is empty, and all the apps are sorted alphabetically starting on page 2. Also the app dock is empty.

1 Like

Fairphone 3
Android 11 build e_FP3-user 11 RQ3A.211001.001 eng.root.20221129.182930 dev-keys
not rooted
I mentioned before that the GPS accuracy was way off while indoors. The error has gone down from about 100km to about 2km. Outdoor it is a couple metres.

GPS error is also in 1.6 on FP3 indoors, when you go out it behaves ok.
But yes, weird

If you had USB debug turned on, you could try to install from PC another launcher and uninstall Bliss for your user. Also you could try to install another time Bliss from PC too. Don’t be really sure if this solve the problem.