FP3: no internet access

Hi,

I have a problem with my FP3. Today all of a sudden I could not get internet access again. First I was disconnected from my local wifi. Then I could reconnect to the wifi, but it said no internet access. I also cannot connect to mobile internet.

My WiFi is working as I can access the internet with other devices in my home. I can also use my phone for calls, but it is unable to connect to the internet, neither mobile nor WiFi.

I did not make any update or changed settings. However the phone fell to the floor prior to the issue.

I tried several restarts, removed the battery, and re-set the network settings.

Any help is appreciated. I really need internet on my phone.

1 Like

maybe it is a loose contact if you dropped it. You can try to take it apart and re-assemble it . ifixit found some spring contacts in step 9:

1 Like

I‘ll try that. But can it actually be a hardware issue if I get the connection to the WiFi and cellular network but not to the internet?

Update: I did not reassemble the phone yet, but my email and messaging apps are working again. However, the system still says „no internet access“ and Fennec has no internet and the clock is also not able to connect to a time server (since I removed the battery, the phone thinks it’s August).

This seems to be some kind of severe software issue.

You can try another DNS, go to settings>Network & Imternet>dns switch off “use network dns” then “set dns to use” to 9.9.9.9 does that help?

I already have another DNS configured. When the internet did not work, I switched back to network DNS, however no effect.

Shortly after my last post, internet access started coming back. As I wrote, email worked first. Afterwards Threema. Then I manually set the time, a few moments later everything worked fine again.

I am still suspicious though. Are there any logs I can check to get a hint what the problem was? Hours without any internet access whatsoever are not acceptable as this is my primary device and I use it for lots of everyday productivity tasks.

I occasionally get the same problem but it is intermittent. There seems to be no rhyme or reason for it.

I also had problems like this before but it never lasted longer than a few seconds. Yesterday it was hours. This is the first really inacceptable issue I come across since switching to FP/e/.

Hi!

I also have a problem with connection on my fairphone 3 (plus). It connects with my wifi without an issue but when I’m outside of home, there’s no internet connection whatsoever, even though the data settings are set to connect with internet through LTE. Can anybody help me with that issue? Sorry if this is a bit off-topic but it seemed relevant.

1 Like

Sounds like a problem with APN settings.
Did you have a look at e.g. here?


and here:

Hey @ff2u

Yes I tried to modify the APN, unofrunately the example from the forum doesn’t work. Probably it’s because it’s for another career (Bouygues Telecome) and country (France). Im using Orange in Poland so probably APN settings need to be different - I just don’t know how exactly they should look like.

1 Like

You’re on the internet. Orange Polska is, too.

https://www.orange.pl/omnibook/konfiguracja-internetu-mms-sms-w-telefonie

2 Likes

OK, salut tout le monde, je lis avec intérêt vos échanges car c’est mon cas à peu de choses près :thinking::
FP3 acheté préinstallé sur le e.shop
Opérateur B&You
Le wifi fonctionne, les appels aussi, mais une fois dehors, pas d’accès internet (et pas de picto 4G sur la barre supérieure, là où y’a la date, les niveaux de batterie et de wifi, etc…
Alors la préco serait de rajouter un point d’accès avec ces paramètres :

Nom = Bouygues Telecom
APN = mmsbouygtel.com
Proxy = non défini
Port = non défini
Nom d’utilisateur = non défini
Mot de passe = non défini
Serveur = non défini
MMSC = http://mms.bouyguestelecom.fr/mms/wapenc
Proxy MMS = (ne rien mettre)
Port MMS = (ne rien mettre)
MCC = 208
MNC = 20
Type d’authentification = PAP
Type d’APN = default,supl,mms**,ia**
Protocole APN = IPv4 / IPv6
Protocole d’itinérance APN = IPv4
Support = non défini
Type d’opérateur du réseau virtuel mobile = aucun

TOUTEFOIS le site de support de Bouygues (je suis connecté en tant que client B&You) donne :

Ajoutez un point d’accès (APN) en renseignant les champs de la manière suivante :

  • Dans le champ “Nom” : entrez Bouygues Telecom
  • Dans le champ “APN” : entrez mmsbouygtel.com
  • Dans le champ “Proxy” : ne rien saisir.
  • Dans le champ “Port” : ne rien saisir.
  • Dans le champ “Nom d’utilisateur” : ne rien saisir.
  • Dans le champ “Mot de passe” : ne rien saisir.
  • Dans le champ “MMSC” : entrez http://mms.bouyguestelecom.fr/mms/wapenc
  • Dans le champ “Proxy MMS” : entrez 62.201.129.226
  • Dans le champ “Port MMS” : entrez 8080
  • Dans le champ “MCC” : entrez 208
  • Dans le champ “MNC” : entrez 20
  • Sous “Type d’authentification” : cochez “Aucun”.
    • Choisissez “Type d’APN”, entrez “default, supl, MMS”, puis choisissez “OK” ou cochez “MMS, default et supl”, puis choisissez “OK”.
    • Enregistrez le nouvel APN, redémarrez votre téléphone et profitez de vos services internet et MMS.

Il y a donc quelques différences…
Du coup, j’ai essayé les deux mais avec, pour les deux dernières mentions :
Type MVNO
SPN
Valeur MVNO
Bouygues Telecom
(qui y étaient préenregistrées)
ça ne marche pas, dans les deux cas… :confused:

EDIT en fait si je coupe le wifi, le 4G apparait et du coup il semble que j’ai bien internet via le mobile…
Maintenant, mon FP3 redémarre systématiquement 5 mn après un démarrage…

@nastyx Je viens aussi de contacter Bouygues qui devrait me répondre sous 48h pour le même probleme.
Pour moi le probleme se situe au niveau IPV4 et IPV6

1 Like

Pour moi ça fonctionne avec le paramétrage donné par BouyguesTel mais :

Protocole APN, j’ai laissé
IPv4/IPv6
alors que BT indique IPv4

Et parce que je suis B&You:

type MVNO
SPN

Valeur MVNO
Bouygues Telecom

Hey!

Thanks a lot for help. I was looking for that info for couple hours on various forums and even orange website - not sure how I missed this. Anyway, this info got the internet working, so for a tech newbie like me it’s a huge help. Thank you!

2 Likes

Enfin, c’est vite dit, la plupart des applis s’ouvrent sur un écran noir et le terminal redémarre au bout de 5 minutes