Galaxy S7 echo during calls with speaker

The edits in the xml file I mentionned seem to only work on Samsung Galaxy S6 Edge. I suppose the xml edits should be device specific.

Also, I think that if someone has bought a smartphone from the /e/ store, /e/ should provide a fix.

Hi there,
I’ve been using /e/ on an S7 for a year now and I’ve had the same problem with the loudspeaker echos.
Also, phone calls are very hard to hear when there’s background noise, because I cannot up the volume to a level needed. A friend has the exact same phone and I can hear the callers on his phone standing next to him. With my phone I cannot hear callers well without really pressing the phone against my ear and sometimes that doesn’t help either. I have good hearing, btw.
Since calling is one of the most basic funtions in a phone, it would be greatly appreciated if this could be fixed with the next update. Thanks a lot in advance.
Cheers

Oh and…if this information helps and I think others have mentioned this as well:
Speaker works fine when I use messengers like signal or threema…no echo then.

Hi,
The last post in this thread was october 21, but no solution has been posted. I still have the issue with echo when I call someone, but mostly the recipients of my calls that experience this echo have Iphones. I do hear the other person perfectly, but they keep hearing an echo.
Has any progress been made on this issue?

Hello
Same problem with my S7 in V1.2, the people I call have the echo of their voice. Most of them use Android.

Hi,
Same problem. People I call complain about earing their voice in echo. They have all kinds of phone/OS. No problem on Messenger/Whatsapp.
I am using the /e/ OS version 1.2-20220725206061 installed using the easy-intaller a week ago.

Same as other.
Echoes seems appears more frequently since 1.0, even without speaker using.

But maybe there’s a trick to test.

Hello,
I just installed /e/OS 1.5-20221028230220 on my S7 SM-930F. I have the same problem as mentioned above.
Regards

@jean1122 for 1.5 it´s reported over here as well:

gitlab issue reported here: #6210

Hello,
I’ve had the same problem for a long time now. My phone is a refurbished Galaxy S7 (SM-930F) with /e/ pre-installed. All the people I call complain about hearing an unpleasant and disturbing echo of their voice. The only workaround I’ve found so far is using earphones, which is not very convenient.
My brother has exactly the same phone with the same version of /e/ (which he installed himself) and he doesn’t face that echo problem, which sounds strange !

Hello,
In my case, my interlocutor hears a very disturbing echo when I activate the speaker.
When I operate without the speaker, there seems to be an echo too, but it is negligible.
Regards

Hello, this is very surprising! And rather a good surprise.
Did you compare the differences (system version, rooted phone,…)?

1 Like

yes, with speakers on it is least “somewhat plausible” but should not at all occur without speakers.

I second that
@jarival if you find something interesting you might add a comment in the above linked gitlab issue as it might help the developers to sort it out

I confirm that ther is no echo when I use earphones. The echo issue arises when the speaker is on.
I was partly wrong when I wrote : “My brother has exactly the same phone with the same version of /e/”. His phone is a Samsung Galaxy SM-G930S (mine is a SM-G930F). We both use the same version of /e/ : 1.5-20221028230220.
I’m really willing to help as that problem is a real nuisance, so if there is more I can do, I’ll do it with great pleasure !

so it´s rather a “speaker on”-type of echo, right? … which of course fits the thread title… sorry my bad, got confused as some posts also mention the “speaker off”-type of echo.

Hello, for me this thread is about speakerphone calls. It was reported to me by a caller that there was a slight echoes without speakerphone (phone to the ear).
On the other hand, there are no echoes when I use a hands-free kit.

I compared the features between the SM-G930F and the SM-G930S, there are some differences especially the support of additional networks for the SM-G930S. But I am unable to say if there is a link with our problem

1 Like

The SM-G930F and the SM-G930S have almost identical features according to this web site : Galaxy S7 (SM-G930S) vs Galaxy S7 (SM-G930F 32Go) - PlusMobile.
I read some pessimistic news about having this echo problem solved one day. Maybe /e/ developers think that those phones are now old enough to be replaced.
Has anybody ever tried this fix : https://forum.xda-developers.com/t/stable-lineageos-17-1-for-galaxy-s7-build-42.3980101/page-59#post-83368475 ?
I meant to try it on my SM-G930F but the new recovery software of /e/ (which replaces TWRP) mounts the system partition read-only. And I don’t particularly want to root my phone !
I would greatly appreciate if anybody could advise me on how to replace the mixer_paths_0.xml file.

The speakerphone echo problem is found on many devices, but seems to be very difficult to solve.

Having experienced this with several Motorola devices it may be down to incompatibility with manufacturer’s drivers, which are not open-source and not part of the /e/ rom.

Hopefully, once it is solved for one device it will point to a solution for others. It is not just older models, see e.g. the Moto G7 Power.

@obacht @jean1122
Hello !
I made more tests today.
The echo issue arises with the speaker on, but also with the speaker off (phone to the ear).
On the other hand, there is no echo at all if I turn off the microphone, which is not really surprising as it is a feedback issue (sound of the loudspeaker being reinjected in the microphone on the caller’s side). Therefore, a possible workaround is to turn off the microphone whenever it’s the called person’s turn to speak. Not very convenient, I admit, but at least, it should work !

1 Like