Gigaset GS290 stuck in "orange state" boot loop

Hi there,

yesterday I tried to flash /e/OS to my brand new Gigaset GS290 but now it’s stuck in a boot loop, entering the “orange state” and rebooting. I can still access fastboot to flash other images but none of the images I tried was able to recover the GS290. I read various posts, where other user reported similar problems, e.g.:

(third link not allowed to new users)

I believe that flashing TWRP would be my best bet to unbrick the GS290, but unfortunately the download link to an TWRP image - from the second of the above links - doesn’t work anymore. Does anybody of you still have a TWRP image for the GS290? Or any other advice on how to unbrick the telephone?

I tried to flash pretty much all of the images from the installation instruction, but so far none of them brought me back to a working state.

Thanks for any help!

There are so many threads on Bricked or Black screen gs290 that it is difficult to know which thread to follow! :slight_smile: Please review this thread Gigaset - GS290 - gs290 - Documentation Suggestions - #69 by mc21 to see if it is a match with your case. There are several more linked threads, dated from the second part of 2021 which might provide further insight.

Gigaset - GS290 - gs290 - Documentation Suggestions

Thanks for getting back to me @aibd!

Yes, I was quite surprised to see that so many people are reporting boot loops on the GS290. Being an officially supported device I expected a very smooth flashing procedure.

I’ve read your first link (Gigaset - GS290 - gs290 - Documentation Suggestions - #69 by mc21), but am not sure how to this relates to my case. First of all, let me give you some additional information:

  • I’m on a Linux system
  • I downloaded the latest platform-tools (fastboot version 32.0.0-8006631)

Your linked thread mentions SPFlashtool. I haven’t tried yet, because I read threads, that the the GS290 was completely bricked after trying to flash something with SPFlashtool. So I’m a bit afraid of that happening to mine as well.
I’ve been using TWPR with LineageOS on some Samsung phones quite successfully. Therefore, I was hoping for an TWPR image for the GS290 as well. But every download link for GS290 TWPR I found so far was broken.

OK, first thing to look at might be platform-tools! The linked thread includes this

The old version of the Android SDK-tools r30.0.5 is available here: (alternative: …

Are you able to triage whether you have really good two way communication between PC and your device? a) with your current platform-tools, b) with an older version. This issue crops up for many, but not all users. Please keep reading!

The official TWRP was never published, I think it was unreliable in some way. One can build TWRP, but in a quick search (you mentioned that broken link) I have not found another.

I’m trying to flash the original Android 10 rom from the installation guide. But this time I’m using fastboot version 30.0.5-6877874 (not the 32.0). I’ll report about the results, when finished.

Nope, no change. Still “orange state” boot loop. Nevertheless, here is what I did:

./fastboot --version
fastboot version 30.0.5-6877874
 ./fastboot flash --disable-verity --disable-verification boot ../Original_ROM/boot.img 
Rewriting vbmeta struct at offset: 9797632
Sending 'boot' (32768 KB)                          OKAY [  9.973s]
Writing 'boot'                                     OKAY [  0.453s]
Finished. Total time: 10.929s
./fastboot flash recovery ../Original_ROM/recovery.img 
Sending 'recovery' (32768 KB)                      OKAY [ 10.099s]
Writing 'recovery'                                 OKAY [  0.452s]
Finished. Total time: 10.594s
./fastboot flash system ../Original_ROM/system.img 
Invalid sparse file format at header magic
Sending sparse 'system' 1/21 (130172 KB)           OKAY [ 40.610s]
Writing 'system'                                   OKAY [  2.163s]
Sending sparse 'system' 2/21 (128156 KB)           OKAY [ 40.399s]
Writing 'system'                                   OKAY [  1.831s]
Sending sparse 'system' 3/21 (131016 KB)           OKAY [ 40.343s]
Writing 'system'                                   OKAY [  2.264s]
Sending sparse 'system' 4/21 (130151 KB)           OKAY [ 41.086s]
Writing 'system'                                   OKAY [ 11.120s]
Sending sparse 'system' 5/21 (122052 KB)           OKAY [ 37.842s]
Writing 'system'                                   OKAY [  2.041s]
Sending sparse 'system' 6/21 (127956 KB)           OKAY [ 40.168s]
Writing 'system'                                   OKAY [  2.019s]
Sending sparse 'system' 7/21 (129044 KB)           OKAY [ 40.151s]
Writing 'system'                                   OKAY [  1.880s]
Sending sparse 'system' 8/21 (127833 KB)           OKAY [ 40.244s]
Writing 'system'                                   OKAY [  2.649s]
Sending sparse 'system' 9/21 (128956 KB)           OKAY [ 40.334s]
Writing 'system'                                   OKAY [  2.009s]
Sending sparse 'system' 10/21 (128112 KB)          OKAY [ 39.478s]
Writing 'system'                                   OKAY [  2.012s]
Sending sparse 'system' 11/21 (128820 KB)          OKAY [ 39.703s]
Writing 'system'                                   OKAY [  2.373s]
Sending sparse 'system' 12/21 (129004 KB)          OKAY [ 40.296s]
Writing 'system'                                   OKAY [  1.995s]
Sending sparse 'system' 13/21 (128944 KB)          OKAY [ 39.758s]
Writing 'system'                                   OKAY [  2.185s]
Sending sparse 'system' 14/21 (129028 KB)          OKAY [ 40.456s]
Writing 'system'                                   OKAY [  1.881s]
Sending sparse 'system' 15/21 (128861 KB)          OKAY [ 39.742s]
Writing 'system'                                   OKAY [  2.432s]
Sending sparse 'system' 16/21 (129040 KB)          OKAY [ 40.282s]
Writing 'system'                                   OKAY [  1.857s]
Sending sparse 'system' 17/21 (128805 KB)          OKAY [ 40.174s]
Writing 'system'                                   OKAY [  2.667s]
Sending sparse 'system' 18/21 (126953 KB)          OKAY [ 39.589s]
Writing 'system'                                   OKAY [  5.158s]
Sending sparse 'system' 19/21 (127432 KB)          OKAY [ 39.636s]
Writing 'system'                                   OKAY [  4.414s]
Sending sparse 'system' 20/21 (131068 KB)          OKAY [ 41.052s]
Writing 'system'                                   OKAY [ 15.716s]
Sending sparse 'system' 21/21 (24612 KB)           OKAY [  7.713s]
Writing 'system'                                   OKAY [  0.399s]
Finished. Total time: 924.667s
./fastboot -w
Erasing 'userdata'                                 OKAY [  0.214s]
mke2fs 1.45.4 (23-Sep-2019)
Creating filesystem with 13899515 4k blocks and 3481600 inodes
Filesystem UUID: 3ef3d288-239f-4b32-a33e-3e2a6af13dc3
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
	4096000, 7962624, 11239424

Allocating group tables: done                            
Writing inode tables: done                            
Creating journal (65536 blocks): done
Writing superblocks and filesystem accounting information: done   

Sending 'userdata' (316 KB)                        OKAY [  0.136s]
Writing 'userdata'                                 OKAY [  0.290s]
Erasing 'cache'                                    OKAY [  0.029s]
mke2fs 1.45.4 (23-Sep-2019)
Creating filesystem with 110592 4k blocks and 110592 inodes
Filesystem UUID: 373e282f-cb54-488f-bdcd-95e6f5098a46
Superblock backups stored on blocks: 
	32768, 98304

Allocating group tables: done                            
Writing inode tables: done                            
Creating journal (4096 blocks): done
Writing superblocks and filesystem accounting information: done

Sending 'cache' (68 KB)                            OKAY [  0.057s]
Writing 'cache'                                    OKAY [  0.119s]
Erasing 'metadata'                                 OKAY [  0.023s]
Erase successful, but not automatically formatting.
File system type raw data not supported.
Finished. Total time: 1.117s
./fastboot reboot
Rebooting                                          OKAY [  0.007s]
Finished. Total time: 0.057s

What irritates me is the message “Invalid sparse file format at header magic” during “fastboot flash system”.

SP Flash Tool, didn’t do the trick either. I’ve been using v5.1916.00 (latest). Had to manually install first. Then it could be started and I followed the description: Installing /e/OS after removing UbuntuTouch on the GS290

In doing so a dialogue window opened saying:

ERROR : STATUS_ERR (-1073676287) , MSP ERROE CODE : 0x00.

That’s all. The device itself started and entered the “orange state” reboot loop after plugging in the USB cable.

The reason you wisely avoided SP Flash Tool is that the manual is a little hard to follow. If you find those error codes from a reliable source it is likely to give some insight.

Please can you make it more clear; did SP Flash Tool leave the device unchanged?

Yes, SP Flash Tool didn’t do anything to the phone. Still in “orange state”, can access fastboot but that’s all. No success flashing anything.

Hello gs290_brick,

here come some suggestions:

1: to get the phone out of the endless-loop and stabilize it, I would try the following:

first shutdown (long press on power button), then start while also pressing “volume down”

→ the tiny “service menu” should appear on the phone’s display (several options in blue and yellow text, in english hopefully; if you should see chinese text, just let the tests run, or stop it with a long press on power to shut down, and try again until it comes up in english)

Option: wipe data / factory reset

Then (again in the blue/yellow menu): boot to bootloader

2: then start the phone and check/adjust all settings necessary for flashing a new OS:

  • developer options
  • enable usb debugging
  • OEM-unlock
  • usb settings: enable file transfer

3: then I’d try to establish a connection to the computer (phone in fastboot mode) and check it with “(sudo) adb devices” as well as with “(sudo) fastboot devices”. The need for sudo depends on the Linux-distro. Once the connection phone-computer works, I would repeat all the steps I described under “documentation suggestions”.

Some comments:

  • if the connection doesn’t work, it might help to reset the “adb-server”:
    “adb kill-server”, then “adb start-server”

  • the “orange state” message on the phone’s boot screen seems to be normal after an e-installation.

  • bootloader can be unlocked with “(sudo) fastboot flashing unlock”

Best regards & good luck!


@mc21 thanks for your description. But that won’t work anymore. What you describe is how to access the recovery image, which I can’t reach anymore. I already flashed a new image, which essentially removed everything and left the phone without any functionality. I can only get to fastboot. Everything else is gone. All my flashing attempts didn’t change anything about it, so far.
The only chance that is probably left is to flash a working recovery image via fastboot before doing anything else. At least I’m assuming right now.
Also pressing volume down + power doesn’t do anything. Only volume up + power allows me to reach fastboot. That’s all I can do with the phone in its current state.
And yes the “orange state” message is normal as it is indicative for an unlocked boot loader.

If the phone’s OS is gone, there should be a chance to flash a new one using a combination of the 4 remaining tools:

  • adb
  • fastboot
  • SPFlashtool
  • service functions of the blue/yellow menu

I would take the 30.0.5 adb/fastboot tools, and dig deep into the parameters of adb and fastboot.
Adb and fastboot provide a lot of functions that can be used to diagnose and change/rescue the phone.


  • first study adb --help and fastboot --help (or better: the complete adb/fastboot documentation, which is available on the Android/Google sites)

  • then trial-and-error starting with commands that don’t change anything, e.g. “adb devices -l” to check the connection, or “adb pull …” to take files out of the phone (if the file system still exists), or the activity manager “am”

Once you have a working connection between phone and computer, it should be possible to flash the old GS290 stock rom using SPFlashtool.


  • “adb shell” provides a complete shell to work with the phone

  • “fastboot … -v” means Verbose and gives more information

  • Can you still access the blue/yellow service menu? there is also an option that shows log-files.

  • I read that it is important to flash partitions in the right order/sequence, always starting with
    “fastboot flash boot boot.img” which includes the kernel

  • maybe easier to establish a well-working connection from a Windows10-PC rather than from a Linux machine; particularly when SPFlashtool is needed, I’d recommend to do the whole installation from Windows.

Thanks for your reply @mc21.

Didn’t find the time during the week to have a loot at the telephone issues.

With the “service functions of the blue/yellow menu” you probably mean the recovery mode. That mode is gone as well. I have just two states that are left:

  • the “orange state” which reboots after 5 sec
  • the fastboot mode
    Can’t access anything else.

SPFlash tool with Windows is no option as well. I’d don’t have any Windows systems, just Linux and an older macOS.

Also, when booted into fastboot mode, adb doesn’t detect any devices. Admittedly, I didn’t expect it to detect any in this mode.

Just a small point of information; adb will not recognise a device in fastboot mode.

fastboot devices

would inform you if the device will communicate with you.

Yes, that’s the reason for me writing “expect it to detect any in this mode”.

adb will not be able to do anything for me, as long as I don’t have a working recovery partition/image.

But at least fastboot still detects the device (fastboot devices) and the telefone reports about the data transfer, when flashing a new image. But till now, no image worked after flashing.

1 Like

So I just tried flashing that stupid thing on another computer and newly downloaded all of the images. No success. At this point I’ve run out of options.
→ I can only access fastboot
→ none of the images I tried flashing changed anything
→ I can’t find any other images
→ adb is not available anymore
→ recovery mode is not available anymore
→ SPFlash tool didn’t do it
→ TWPR is not available

That thing will go into the trash. Enough time wasted on it.

Thanks guys for your support.

Ps. Gigaset told they will not provide any images or any other kind of support.

Sorry to read about your misadventures :frowning:

If you live in the E.U. I may be of help, please contact me privately.


Thank you. But it seems I’m not allowed to send private messages, yet. Otherwise, I’m incredibly stupid right now and don’t find the button to send PMs. And yes I’m in the EU. Probably your eastern neighbor :wink:

Besides, I found a workaround: I bought a used Samsung S5 and flashing this was as easy as it’s always been. Never again will I buy a phone without TWRP support. The GS290 is still bricked.

Just sent you a PM, please report if you can reply.

1 Like

@gs290_brick I have flashed 2 GS290s using linux and no problems.
You were correct to change to ADB tools 30.0.5-6877874.
Your fastboot commands are all correct (mine are the same, see below).
There are no version numbers on your images (, recovery.img, and system.img)… Have you processed your image files somehow?

If so this post describes what might have happened in your case. It would be worthwhile downloading fresh copies of each of the images and try again, and dont rename/modify the images in any way.

If not, here is another post that relates to space issues on the device.

And another post that was solved by using a different cable.

  • fastboot flash --disable-verity --disable-verification boot /home/…/img-boot.img
  • fastboot flash recovery /home/…/e-21-q/recovery-e-0.21-q-20220122158537-stable-GS290.img
  • fastboot flash system /home/…/IMG-e-0.21-q-20220122158537-stable-GS290/system.img
  • fastboot -w
  • fastboot reboot
  • adb reboot bootloader
  • unplug device from computer