GPS signal not found on Fairphone 3 with E/OS

GPS signal is not found on Fairphone 3 with E/OS . Both in OSMAND APP and in the default MAPS APP which comes with E/OS the GPS signal is not found. It says GPS data downloaded with a timestamp and that is it. It functioned well until last week. I did not change, delete or install anything.

Thank you very much for your help.

Have a good day/evening.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Similar issue with apps previously taking many minutes to find my location. Now they are not finding it at all. For example Magic Earth says “No GPS Position”; Strava says “No GPS Signal”; when i go in to Advanced Privacy Settings (which is turned off, with real location selected, the map indicating my location simply spins.

I’m not sure whether mine is because of the recent update or not. Location in Magic Earth has been buggy for months if not years.

Thank you for responding. I am using OSMAND and Magic Earth but both have the same problem, I understand you did not find a solution?

I have the same problem and use the HereWeGo app. For some reason this app is the only one that works. I raised an issue on Gitlab about this topic.

1 Like

This #gps + #fp3 thread marked [Solved] might offer some clues.

1 Like

Unfortunately the solution described in this thread didn’t help in my case…

Thanks @aibd , i had read many posts but apparently not this one.

I simply had Mozilla Location Service turned off in my microG settings as per the solution. Not sure how that would’ve happened.

It now works faster than before.

With me neither. Really annoying think I am gonna buy an old school TomTom.

Is there anybody on this forum who has another suggestion?

Thanx for your help!

Did you try HereWeGo?

Yes I tried is before. But that was before the GPS problem occurred. With GPS test the problem seems to be with the signal form the phone and not with the OSMAND app itself… but I am not 100% sure.

In my case, depending on the region, it can sometimes take a few minutes before I get a GPS signal.

Since location is supposed to work smoothly (it does for me and has done consistently), if nothing else helps there’s always a factory reset to rule out Apps and data as the culprit, and then there’s always installing the OS from scratch to rule out a deteriorated state of the OS installation as the culprit.

(An Android factory reset will not touch the installed OS, and while an OS installation is no fruit or vegetable, it can nonetheless deteriorate over time, too.)

That would not be unusual for GPS if additional means of getting a location are disabled in the OS or not available in the region.

1 Like

Thank you AnotherElk … You might have guessed :grin: I am trying to avoid that. Takes ages to install all apps again. :upside_down_face:

Have you tried to install GPSTest. This might rule out the edge case possibility that the GPS sensor was not collecting any useful information from satellites, due to hardware defect of some sort ?

We have two FP3 devices in our family and both are since /e/ OS 1.5 not able to give a precise location. Magic earth, Osmand etc are useless. The only app that works is Here WeGo. Therefore the answer cannot be a factory reset if for some reason one app is able to locate the device precisely.

That is great info Niels. Saves me a lot of time trying to get things to work. Thank you very much. Iĺl give it a try straight away.
Update I tried Here WeGo. But the problem is with the Espeak voice. It sounds metallic, awful, can’t listen to it.

Yes I tried GPStest. It could not find a signal.

I know it sounds awful. I use Here WeGo only until the bug concerning the precise location is fixed.

Hi @eosfan if GPSTest really continues to show zero signal outdoors with clear skies for an hour or so, then I would start to think of it being a hardware problem.

1 Like