HELP! Just updated to 0.18 and the Phone App is not working anymore

Just installed a couple of minites ago the newsest version of eOS 0.18. I do have the FP3

I recieved a call but I couldn’t here the other side and the other side didn’t here me as well.
I do have a Business Telephone app in my working profile, I tested it and I could here the otherside but he couldn’t here me.

So Microphone is not working at all in the Phone app.
Speaker is only working in Working profile.

I realy do need a quick solution for this problem. Maybe a downgrade to 0.17 or a setting that I have to do.

Thanks for the help.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


It 's a known problem :


The Fairphone 3 is an A/B device. It has two slots for the OS (A and B). While you use one slot, updates get installed to the other slot in the background, the reboot in the updating process then simply boots the updated slot.
This means after an update the OS state before the update is still there on the other slot and you can revert back to it.

Edit: At least in theory, there seems to be an error preventing this to succeed in this case. Never mind.


Yes, thanks all for the work done. A quick fix would be hugely appreciated.

Ok! I`ve changed the active slot and ran into the “Your data may be corrupt”-scene. But when I changed the active slot back, it was the same. Can I do anything or do I have to confirm a factory reset?

From past experience (Fairphone OS Android 10) I think it would help if people who are affected would perhaps – if you feel comfortable to do so – name their telecom provider (and include that info in /e/ support requests as well).

And as I rarely have phone calls, I’d be interested to hear if anyone’s /e/OS 0.18 phone does allow phone talks right now. I think this might be a compatibility issue of 0.18 with certain networks, not necessarily something about the dialing app.

Hmmm … both things shouldn’t happen.
Did you confirm the slot was actually changed back?
Does fastboot getvar current-slot still give back a or b now, or something else?

fastboot getvar current-slot gives back current-slot: a

When I change to b then it gives back b. After reboot I get that error. Then I choose ‘Try again’ and hold the Volume down-butto to get into fastboot-mode again. Then the getvar still says b. I change nothing and just tap ‘Try again’. After the third time the phone boots into slot a again, where is the buggy OS.

But the buggy OS boots?

I’m having the exact same problem. My active slot was b, I changed it to a and then when I reboot I’ve got a message saying my data may be corrupt.
So I changed it back to b, now I can reboot but I cannot call :frowning:
My telecom provider is Orange France

1 Like

Since this procedure worked for users in the past and this error doesn’t make much sense as the update seems to have worked (only that the OS is buggy) and there was no up- or downgrade of the major Android version … it seems I’m missing something. Sorry.
I edited my earlier post.
This really is a neat feature of A/B devices … if it works. Bummer.

Also - I don’t know if that’s related - the default dialer app has a weird look.

Yes, it does.

And my provider is Vodafone Germany.


I also tried using other dialer apps and same issue. Not even working with apps like Signal, Whatsapp or Facebook

1 Like

Same problem here with my FP3 with both my SIMs, one from Orange and the other from SFR.
Doesn’t look like it’s related to the carrier.
Doesn’t work with another dialer either…

1 Like

Ah, I misunderstood then. I thought you got the factory reset offer on both slots now, which I wouldn’t have understood at all. Phew, world view intact.

First it looked like that it wouldn’t reboot neither from slot a nor from slot b but I was mistaken. It boots from slot a (0.18) but not from slot b anymore.

What about the others facing the dialer-problem? Can you change the slot and boot into the old OS?

I can change the slot but I cannot boot into the old OS

Yes, that’s what it looks like in v0.18 on my Sony XA2 too. (nothing to do with ballet) :wink:

Here’s some weird behaviour, somewhat related, on Sony XA2 running v0.18q and using the default phone app.

Could not make calls. Every number dialled would fail immediately. I made small adjustments to the apn settings to correspond with what they were on android 9 (that’s the last stock for this phone) and tried again. Nope. Restarting the phone in between any changes. Tried calling the phone and it always got the busy message.

Put this sim into another phone: no problem, all normal.

Put another sim into the xa2, same carrier: no problem. Strange. But at least all the sims and phones are working.

Moral of the story: witchcraft and magic involved sometimes.

BTW the sims are PAYG from 3 in the UK. One of only two surviving strictly PAYG options left…