Help to fix problems in i9300

I am using the latest update for rom - []
I noticed some problems for example .

  • I can’t install some apk source programs , I get a message ( App not installed. This app isn’t compatible with your phone )
  • The sound is very low with a maximum selection
  • Sometimes there is difficulty communicating with the network

The OEM-Unlock option is available with Android 5.0 “Lollipop” and higher, but not implemented in every Samsung device.

Especially older “SAMs” like the GT-I9300 don’t know this feature, because their last StockROM version was Android 4.3 “Jelly Bean”.

So in this case, forget the note to “OEM Unlock” and move on to the next step.

Thank you, I will have another go and report back!

Hi again, nearly there! [Installing /e/ on Samsung Galaxy SIII i9300 international]
I have now got as far as pressing the “Install” button in TWRP; I chose zip file and swiped right to confirm flash. I received red message 'failed to map file ‘sdcard/e-0.7-n-2020021541379-dev-i9300-zip’.
I’m a bit confused by the ‘sdcard’ as I copied the zip folder to the phone’s Internal storage, next to the TWRP folder. There is a Micro SD card which still has 7 folders in it from when the phone was being used with Android OS.

@Boudiax, that sounds good to me. Save the file e-0.7-n-2020021541379-dev-i9300-zip in the device either Internal Storage in the directory /download or on an external mircroSD card. This avoids confusion of names.

I have tried deleting the zip file on the phone, and copying the zip file ‘e-0.7-n etc…’ from Windows desktop to both Internal Storage/download/ [same red error message] and then to the external microSD card [red error message again]. In both cases I checked first that there was only 1 copy of the zip file to be found by looking in Windows File Manager. I’m so close! What would cause ‘failed to map’? I have copied the unzipped folder as @anonyme instructed.

“Copy the ZIP folder of the /e/ ROM (without unzipping) (right click on it and then “Copy”)”

Which version of TWRP are you using?

downloaded yesterday, from

Since I don’t know what condition the GT-I9300 was in before, I would try it now:

TWRP Menu > Wipe > Advanced Wipe:
[x] Dalvik / ART Cache
[x] System
[x] data
[x] Internal Storage
[x] Cache

… and “Swipe to Wipe”.

Now execute it just to be sure: TWRP Menu > Wipe > “Format Data”

Immediately following (without rebooting) > TWRP Menu > “Install” e-0.7-n-2020021541379-dev-i9300-zip (from microSD card)

Thanks, I’ll try that now.

I’ve got the same error message as before; there are options at bottom of ‘Install Zip- Failed’ screen to ‘Wipe Cache/Dalvik’ and ‘Reboot System’. Or I can back out and retry?

I can only tell you what I’d do if I were you:

  1. TWRP Menu > Reboot > Download³
  2. Back to StockROM Android 4.3 “Jelly Bean” (Odin3)
  3. install WinTeam TWRP
  4. install /e/OS ROM

(the whole procedure again from the beginning)

³ Samsung Download-Modus

1 Like

OK thank you for your help.

Hi again, I thought I’d update my efforts to install /e/ on my Galaxy SIII i9300 [International].

Firstly I wasn’t sure about how to get back to stock Samsung ROM, so I DDG’d [DuckDuckGo] the error message and found a possible solution on the Github/ TWRP forum; which was to use an older version of TWRP [v3.0.2-1], I did this then installed /e/; this time I got the blue progress bar then then the e symbol with bouncing dot underneath.

I thought it must be installing/ configuring itself but 3 hours later [I had to go out] the e symbol was still there, now it was underneath an error message “ has stopped”. underneath this message is a ‘X’ [close button, which doesn’t do anything.

Back to various forums with various suggestions, none of which worked or were possible e.g.‘Go into Settings’.
I am now thinking of trying to install an earlier version of /e/.

Alternatively, I am a volunteer at my local Repair Cafe [fixing bikes], I could ask one of the computer/ phone guys to help me reinstall the Samsung OS and start again. What do you think?


Hello Bob,

if a custom Rom cannot be installed on a device, installing the Stockrom firmware has proven to be very useful. This way, everything is set to the beginning and offers good conditions for a new beginning.

With Odin3 flashing the firmware is a breeze. You can do this for sure!

You need the following:

  1. Samsung Android → Samsung Driver
  2. ToolSamFirm 0.4.1 to quickly download the firmware: I9300XXUGNG3/I9300 … your | region
  3. Samsung’s → Odin3
  4. Android Firmware I9300XXUGNG3/I9300 … your Region

Look at you too → [HOWTO] Install /e/ on a Samsung smartphone with Windows easily

If you have any questions, just ask, please…

1 Like

Thank you so much Archie- back to stock Android now and all working fine. It took me a few hours even with your help; tomorrow I’ll start again following Anonyme’s howto, this time with 4 days experience!

Very well done, Bob. The first step towards a new mobile system has been taken. If you don’t need an illustrated tutorial anymore, use the text varainate below. It’s proven and successful…

Hi again, SUCCESS!!! and I only took just over an hour this time… The biggest difference between your instructions and Anonym’s was that in his instructions , TWRP WIPE/ Advanced WIPE included Internal Storage, although this time I started with a Samsung stock ROM.
Now to start configuring; I will start by looking for User Help pages on here.
I took photos as I went, in case they are useful in the future.
Thanks again, on my way now!

1 Like

“Swipe to Wipe” ✓ Internal storage is an option that not everyone deems necessary. But I use it myself. The picture above 4. “Confirm by dragging the “Swipe to Wipe” arrow from left to right.” also shows, by the way, that Internal Storage isn’t enabled.

For persistent cases the option 4.2.2 Optional, depending on your needs: “Format data” or “Repair or Change File System” is recommended.

But as we all know, there are several paths that lead to Rome.
Continued success on your mission.