Issues building unofficial /e/ Pie for oneplus3

Hello everyone,
After some weeks of successfully building my unofficial /e/ Pie for oneplus 3/3T, lately I am experiencing an annoying issue, which prevents me from being able to provide updated versions of the ROM.

These are the commands I use to launch the build process:

sudo docker pull
sudo docker run \
-v "/run/media/francesco/Dati/e/src:/srv/src" \
-v "/run/media/francesco/Dati/e/zips:/srv/zips" \
-v "/run/media/francesco/Dati/e/logs:/srv/logs" \
-v "/run/media/francesco/Dati/e/ccache:/srv/ccache" \
-e "CCACHE_SIZE=250G" \
-e "BRANCH_NAME=v1-pie" \
-e "DEVICE_LIST=oneplus3" \
-e "REPO=" \

This is what I get:

Set cache size limit to 250.0 GB
>> [Sun Oct  4 10:51:26 UTC 2020] Branch:  v1-pie
>> [Sun Oct  4 10:51:26 UTC 2020] Devices: oneplus3,
>> [Sun Oct  4 10:51:26 UTC 2020] (Re)initializing branch repository
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 46444  100 46444    0     0   193k      0 --:--:-- --:--:-- --:--:--  193k
>> [Sun Oct  4 10:51:31 UTC 2020] Copying '/srv/local_manifests/*.xml' to '.repo/local_manifests/'
Traceback (most recent call last):
  File "/root/", line 61, in <module>
TypeError: write() argument must be str, not bytes
>> [Sun Oct  4 10:51:32 UTC 2020] Syncing branch repository
>> [Sun Oct  4 10:51:32 UTC 2020] Missing "vendor/lineage", aborting

The repo’s log file contains the following:

>> [Sun Oct  4 10:51:26 UTC 2020] (Re)initializing branch repository
Downloading manifest from
Invalid clone.bundle file; ignoring.

repo has been initialized in /srv/src/PIE
>> [Sun Oct  4 10:51:32 UTC 2020] Syncing branch repository
fatal: error parsing manifest /srv/src/PIE/.repo/local_manifests/proprietary_gitlab.xml: no element found: line 1, column 0

I tried to run the build for different devices and setting different branch names, but without any success.

Could someone help me understand what’s the problem?
Thank you!

Not sure, because I’m not building with docker, but I think there was a change.
Could you try with
-e “DEVICE=oneplus3” \

Thanks, but unfortunately this doesn’t work…
The process doesn’t event start, so I guess that parameter’s not recognized.

OK, than you have used the right command with DEVICE_LIST.
sorry, than I have now idea. I think you have tried it several times. Because it could be, that the sources are blocked,because of the issue of the yesterdays update

I just saw that OnePLus 3T got officially updated to Q release, so I guess I won’t need to build Pie anymore :grin:

Maybe something changed on the repo and the docker image isn’t updated?

Thank you anyway for your help @harvey186

The docker build for Q does have issues as far as I know.
Pks see here

That looks exactly the same error I’m experiencing, but I’m getting it on v1-pie.

Yes, I have seen. Seems there is an issue with the container.

Best you will follow the other post

1 Like

i know how to fix it. Try to set "BRANCH_NAME=pie". I saw in the docker file and found inccorect regexp for BRANCH_NAME label.

1 Like

Thanks, I’ll give it a try soon :pray:

Do you mean line 94 : ?

the is old, very old and no maintenance.

nope. I guess it’s abranch_dir or BRANCH_NAME

Unfortunately ( We need to update it for new conditions and environments

this is the best way for none docker builds

thanks, but i know about it. I want to build a image with docker under wsl2)

but than you don’t need the

maybe, but bugs with a branch variable didn’t allow to build my unofficial image.

if this isn’t working, pls let us know, so Manoj will be check and correct the docu. thx

1 Like

Of course i will try, thanks!