Latest EOs Update on FP3 (08 Dec)

Hello there,

I’m a little bit unsecure, should I update? The last update went wrong but there is a new one from 08.12.2020

Can I just skip the previous one?

1 Like


as you can see here, it seems to run fine.

Yes you can skip the old update.

1 Like

Great thanks, will try it later.

I’ve updated my FP3 with the System updater version from 8th December and it failed. in a sense that i was given the option to try again or go into recovery mode and get my data wiped. After the first option failed several times i swallowed the bitter pill and started with all my data & settings wiped. I have hoped that the new update will enable usage of:

  1. CoronaMelder App -> still doesn’t work and popup says that Google Play Services is still being updated. As far as i understand, it means that MicroG Core is not working with CoronaMelder App
  2. Open Magic Earth -> pop up Operation could not be used because of I/O error.
  3. in Setttings -> tried to disable the haptic feedback when using keyboard. the settings are possible to disable, only the phone does not follow.

These downsides are enough for me to warn you from installing the Dec 8th upgrade.

My phone tells me i am on /e/OS - 0.13.2020120889008. To be fair i am confused. According to forum i need a v0.13-q for FP3, but then the manual update (thus download section: refers to a different version: IMG-e-0.13-q-2020120789006-dev-FP3 than above listed.

So i wonder if i’ve got the wrong release offered in the system updater?

Thanks for the reply, glad I didn’t try it yet.

Just have manually installed from the and indeed end up with a different Image: /e/OS 0.13-2020120789006. According to earlier reply from @Anonyme there is a Dec 7th upgrade for FP3. I can see that date now also in the Image Name after the manual install.

BTW CoronaMelder App not working. Magic Earth is.

I advise not to do the manual install, because again, complete wipe of data. I have had to add my /e/ account to the phone and Wifi, etc.

So unless someone from /e/ support will correct me, I stand with my finding that the offered update in the system updater from the 8th December is not the one for FP3. I think people in this thread have been offered the correct image in the system updater: Does anyone have a working December 7th Update (especially FP3).

I hope /e/ support will react and clarify. As i am an almost newbie to /e/ and am just following the HOWTO’s.

Hopefully hear soon.

About the CoronaMelder App, you need to install manually the Notification Exposure service, available from “Apps”, as described in the main thread about the framework:

and in this specific thread in the Fairphone category:


CoronaMelder works for me now! After installing MicroG Exposure Notification.

Awesome! Big thanks for your help @16NoCo


So, I gave it a try and it did not work (Your device is corrupt). At least it is easy to switch to the old slot on FP3.

This is my seccond try to update the os and it failed (0.12 /0.13) and I don’t know what to do. Updates are important (for security reasons), aren’t they?

Am I doing something wrong? Do I have to prepare the update somehow? Right now I just click on update :upside_down_face:

Is it a slot-related thing? I am now on slot-b again

P.s.: I’m on 0.11-2020082870302 and try to update to 0.13-p-2020120889008-dev

1 Like

yes, same with me. I’m a bit confused as my last update was on 31. August. So I have a little bit newer version than you as it seems.
However, I had also this week, I guess it was the 8th, a notification for an update which didn’t work and now disappeared. When I refresh it says that there are no new updates.
As for security reasons and because Magic Earth keeps on complaining about the outdated version, I think it would be time for an update, although I’m on stable branch…

In my case, it worked perfectly from 0.12-2020102981459
So far, no bugs prceived, everything works as usual. Also, “maps” wants to update again instead of a warning about “old version…”

1 Like