Microsoft Teams high-pitched voices

This is a copy of the same thread I’ve started on the Fairphone forum.

I have a Fairphone 4 with the latest stable /e/ on it. I’ve installed MS Teams for work. Whenever I make a call, everyone’s voice is high-pitched, as in the kind of effect you get when you speed up a clip, or when you inhale helium. It’s such a strange bug. No other app suffers from this behaviour. Phone, telegram, whatsapp calls: they’re all completely fine.

Another user with a Fairphone 4 has commented that they have the same issue. Someone else noted that it may be protocols/codecs which the app uses.

Has anyone else encountered this bug, and can you share how (if) you fixed it?

2 Likes

I face the same issue with MS Teams calls and calls from skype (both from Microsoft).
No idea how to get this fixed.

I have the same. Sound like Mickey Mouse :grinning:

1 Like

same issue also in Skype

Seems this is already known. Does anyone knowns a workaround.
The audio sound like Mikey Mouse both on Skype and MS TEams

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Try using the app in multiple space app or in dual space app that might work

And for open source apk use … shelter from f droid

just linking back to the gitlab issue

I wonder if the high-pitch / “chipmunk” incoming voice is reproducible with any counterparty, or only a specific peer.
If you call yourself over different accounts and look at the logcat, maybe there is a hint.

(The sampling rate speculation in that thread is interesting though :slight_smile: )

1 Like

I also have this problem, both over wifi and over 4g/5g, it’s really annoying.
Would be really nice to find a solution.
But it looks like everybody is point at the other parties that are involved.
For me it’s Telekom Providers.

1 Like

Hey,

I have the same Issue on my FP4 with Skype … Did anyone figure out how to solve this?

There are no Problems when using Telegram Messenger…

Ok - after a lot of testing and research I fixed the problem for me (FP4):

In Settings (Einstellungen) > accessibility (Bedienungshilfen) > mono audio: switch on “combining chanels …” (Kanäle bei Audiowiedergabe kombinieren)

Incoming Skype-call voices sound totally normal now.

(The official Skype Echo Test contact is “echo123” - there are a lot of scammers named “Echo Sound Test” …)

2 Likes

I have the same MickyMouse effect on FP4 and MS-Teams. Does anybody know a similar fix to that Skype-fix for MS-Tsams?

Can anyone point the dev-team in gitlab to this thread? They seem to think, that this problem is fixed.

Thanks for the feedback. I’ve tried this but unfortunately it didn’t solve it for MS Teams.

As for the devteam, I can’t create an account as I don’t have an appropriate email. If anyone does, please indeed point them here.

Getting an error message in new ID creation on /e/OS Gitlab?

Hope this helps.

I am having same issue.
This comment: Microsoft Teams high-pitched voices - #10 by Welcome
solved it <1.5 but since I upgraded to 1.5.1 I am back to the problem. I have written to the Gitlab issue, let’s see whether we can get any updates on it.