No luck of getting /e/ onto my OnePlus8

Hey there community,

I tried the easy installer and ran into the problem, that apparently the checksum doesn’t match the downloaded /e/ rom file. I tried several workarounds and I gave up.

No I tried the “old way” and got to the point after flashing the recovery.

My OnePlus 8 now only boots into fastmode but not into the recovery.

(For clarification: Right now I have Lineage 20 installed on this phone, so the bootloader was already unlocked).

Can anyone send me in the right direction?
KInd regards, Take Care!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

you can go straight to step (8) or (9) as you already have a compatible custom recovery installed

[HOWTO] an Unified Install Guide Project for /e/ - #4 by piero

Theoretically yes, but as I mentioned I can’t get into the recovery. My phone always goes to fast boot.

Should I manually flash twrp or another recovery?

Update: It gets weirder and weirder.

I flashed twrp as recovery in fastboot. But when I tried to get into recovery the phone just rebooted to fastboot.
Then I tried to boot into the twrp recovery with “fastboot boot twrp.img” which was the wrong command. It sent “boot.img” from lineage and gave me the error message “fast boot : error : command failed.”
BUT: I suddenly found myself in the Lineage recovery??

1 Like

Update 2:

After factory resetting using the Lineage recovery I tried to sideload eOS via ADB. As mentioned in the official installation instructions it paused at 47%. The phone gave me two error messages:

  1. Signature verification failes and
  2. Error 21

The recovery gave me the option to ignore the failed signature verification which I said “yes” to.
The phone ran on with Step1/2 and Step 2/2.
Now the recovery said “To install additional packages you need to reboot recovery first. Do you want to reboot to recovery now?”
There I also replied yes. But I am stuck at fastboot mode again.

So this is the status:

  1. Bootloader is unlocked
  2. phone can be addressed via fastboot
  3. Every boot process ends in fastboot mode.

Help is much appreciated!!

Only a technicality, but /e/ does not add additional packages so the answer is really no.

Just a thought, have you ruled out that your Lineage maybe more recent than the (unknown) version of /e/ and you are attempting to downgrade Android SPL.

No deviations from install page ?

1 Like

Hey @aibd,
thank you for your reply.

I only skipped the unlocking of the bootloader because it was already unlocked due to Lineage. Problems began already wit the custom recovery. After flashing the eOS recovery the phone booted only in fastboot mode. The same happened with twrp.

Android version is not the same as Android SPL.

This /e/OS v1.19.1 version includes the Android security patches available until December 2023.

Lineage had the same December SPL.; more recent builds are Jan 2024.

What /e/OS ROM are you installing ?

1 Like

I tried

So from the first link in my last post you can see the /e/ naming convention. The r in e-1.19.1-r- represents Android 11 (R). For a device already on Lineage 20 you should probably try the most recent dev build from

Edit and be sure to use the full contents of the Recovery and boot img.


Dear @aibd,
thank you as always.

I want to have a daily driver, so the dev-version might not be the best idea.

Does it make sense to use the MSM Tool by OnePlus, flash down to android 11 and begin from cluster ne with the goal to flash /e/ 1.19.1 R ?

Well that is a possibility, but the install instructions are written for T and the R install instructions are no longer shown. Although a different device I made the same comment in this thread OnePlus 8 Pro additional partition required but lacks expected images.

Here are Lineage instructions which “bridge” the Android 11 - Android 13 install methods.

If you choose Android 11 (R) MSM and copy-partition would be a sound way to clean up the device in case it was compromised by the attempted downgrade.

Many on the forum here are using dev builds for their daily driver, but I understand how you might be attracted to the stable label.

1 Like

I am going mad here.
I can’t get into the EDL mode which is needed for the MSM Tool. I used all the methods - everytime the phone is connected to the PC it starts into fastboot mode.
I also can’t seem to flash any recoveries although the command console tells me that the flashing process was successfull. When I try to get into recovery mode it is fastboot mode once again.

Do you @aibd have any suggestions? Is this a hard brick?
I flashed and rooted so many phones in the 2010s but never experienced such a case ;-/

Unbrick OnePlus 8/8T/8 Pro via Fastboot Enhance

:crossed_fingers: Try it out Fastboot Enhance Tool from GitHub

1 Like

Thanks @Xxpsilon - but I can’t boot into the FastbootD mode which the tool should do.
I arrive always in fastboot mode.

Should I try to flash the payload.bin anyway?

The tool says: The following partitions to flash may be unknown: odm product system system_ext vendor reserve. You may need to reboot to fastbootd mode.

So you read three times Did you try the third method ?

The last method of getting into EDL mode is using TWRP. It’s the bottom option in the reboot menu. Note: This method doesn’t require for TWRP to be installed. You can simply fastboot boot into TWRP to achieve the desire results.

This is a Dynamic Partition device (partitions are not fixed).

In my experience you can only move to fastbootd under certain circumstances – my guess would be that an existing failed (and / or Android 11) recovery is a potential blocker. Is the presently flashed Recovery Android 13 (despite it not booting), that is does it match the firmware ? Edit … but match of recovery to firmware is not the only issue which a Super partition might bring.

May be worth reading also

1 Like

@ Spaceghos7 if the fastboot mode still works and the bootloader is unlocked - have you tried to install an OxygenOS factory image via fastboot?

Note: I would flash each file separately and not use flash_all.bat.

1 Like

Thanks for all your help guys.

I tried it with this manual:

(Step 6b: Manual method)
But I got only to step 3: fastboot reboot fastboot
I receive the error message
Failed to boot into userspace fastboot; one or more components micht be unbootable

Any suggestions?

Try this: Fix Fastboot: Error: Failed To Boot Into Userspace Fastboot


Sorry, no. No luck. I followed the instructions exactly but the result is the same.