OnePlus 8T Touchscreen Doesn't Work After Install

I updated my OnePlus 8T to Android 13 (the latest update), and installed

After the phone rebooted to e, it displays the “Start” screen, but any taps or swipes to the screen go undetected. The buttons work for volume and the power button displaying the “Emergency, Shutdown, Restart” screen, although I am not able to change from the default selection. The only way I can shut down the phone is to hold Volume Up + Power.

When following the install instructions, the only difference was that my phone never displayed a success message. It showed performing step 1 of 2, then 2 of 2. The CLI showed “Total xfer: 1.00x”

Is there a way to get the touchscreen to work?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

You may have to run the install again if the install did not complete. But first, maybe only First boot failed.

In this case it is worth ensuring the device will charge, then fully charge it. Now boot into Recovery, and select Factory reset. This will allow the device to attempt another First boot.

(If you should have to run the install again, please ensure the device is fully charged.)

I plugged my phone back in, and the battery is full, as I didn’t want any chance of it quitting during a flash install.

I booted to the Recovery screen, and followed the steps for a factory reset again. I continued with the install steps and got the same feedback from the UI.

After using “adb sideload”, the command line displayed:
Total xfer: 1.00x

The phone displays:
Supported API: 3
Finding update package…
Verifying update package…
Update package verification took 49.7 s (result 0).
Installing update…

I left the phone on that screen to see if there are unseen installation steps going on in the background. After a half hour I rebooted from Recovery mode. The eOS started, but once the screen with the blue Start button displayed, the screen still does not respond to touch.

I wonder if it is worth checking that you are on latest platform-tools. I use Debian 11; I prefer not to use system platform-tools but to use a download of latest platform tools.

I do however install platform-tools common as this easily sets up plugdev and udev for me.

Apologies if you already said you were on Windows and I missed it

My tools were two versions behind. I grabbed version “r34” (running Linux Mint), did a factory reset, performed the install, and go the same results :confused:

Sorry I missed the obvious !

Your device was on A 13, but /e/OS -s is A 12.

I think you will need to check out the method to downgrade the device to “manufacturer” Android 12.

/e/OS of a certain version cannot be installed on a device running a higher Android “manufacturer” stock version.

You have the wrong firmware. You need to downgrade to OOS 12 before installing EOS.

I used this on mine for rollback from OOS 13

1 Like

Unfortunately, the instructions are for a working phone. I cannot get to “Settings/About Phone/etc”, as the phone boots to the e Welcome/Start screen.

Would it be possible to load the rollback zip using adb, or something similar?

You will need to use the MSM tool on a Windows machine.

You should find one or two guides …

I won’t confuse you with a general guide – please be sure to read thoroughly more than one guide so that you fully understand the workflow. There may be some threads on the forum covering the subject for another insight.

Good luck

1 Like

I believe it’s possible multiple ways, but you need to flash stock recovery or TWRP first. If all else fails, you can use the msmtools.

1 Like

I was able to roll back to the original (Android 11) OS per the OnePlus instructions.

I upgraded to Android 12, followed the eOS installation steps again.

However, I still have the same result of the eOS start button screen, and no ability to use the touchscreen.

Just to clarify you went to OOS 11, then upgraded to OOS12 … before starting on the /e/OS install instructions ?

Yes. The zip file from OnePlus took the phone back to Android 11. I did one upgrade, which brought the phone up to Android 12.

I then started the install steps for eOS, as if I had just unboxed the phone.

Your problem may be caused by the fact that your dtbo (and vbmeta) partitions were still on Android 13 (more precisely on LineageOS 20.0) when you installed /e/OS, at least if you followed the /e/OS installation instructions precisely. You should deviate a little and take the images to flash into these 2 partitions from your downloaded To extract them use a tool like payload-dumper-go (which you can download from here: Release 1.2.2 · ssut/payload-dumper-go · GitHub).
Good luck!


While reviewing the install instructions, I realized there might be another issue.

Warning: Make sure that you can send and receive SMS and place and receive calls (also via WiFi and LTE, if available), otherwise it will not work on /e/OS as well. Additionally, some devices require that VoLTE/VoWiFi be utilized once on stock to provision IMS.

I don’t have a sim card, or service provider, for this phone. I do have it connected to wifi, but there is no way to send/receive calls/SMS. Would it be advised to roll back the OS, install a sim card, and connect to a cell provider before continuing?

I just want to update this thread. I ran into a similar issue and realized I made the version mismatch mistake as the OP. That being said, I tried to install today as the A13 is out now and still ran into this issue.

Anyone can help with this issue?

Within the Gitlab I see no bug filed on this matter against kebab.

I do see, OnePlus 7T, Touchscreen does not work after command line install of /e/ OS S on hotdogb – #6981.

Hi @nobu, we are asked not to comment on Test builds in the forum, but if you did find a test build I do hope you reported the issue in the testing channels, as it is possible that devs may not know of this issue.

So maybe we should wait until the stable build comes out? Any idea when is this going to happen?