Problem update 1.20 on Samsung Galaxy S7

Hi, I’m new on the forum but old user of /e/OS since 2018 I know.

Up to now, everything’s worked fine, but this morning I updated to 1.20 from 1.17 or 1.18: the system starts up, but a “finalizing update” notification is stubbornly displayed, and apps won’t launch (except phone and SMS)… No access to my files either (which don’t seem to have been lost), Advanced Privacy doesn’t react (all disabled), the Murena account is no longer activated… What can I do?

Thanks for help!

(Translate with Deepl :sweat_smile:)

Did you receive the update OTA (over the air) or did you update manually?
OTA should offer 1.17.1 first and only then 1.20 …(?)

Hum, yes I’ve see 1.17(x) update under 1.20. But I’ve launch 1.20 OTA… oups.

I progress: without SIM and microSD cards, it seems to better works! But less usable… Should I downgrade? Is it possible?

Thanks! I’ve didn’t read this information… How to repair that now… :dizzy_face:

OK, without SD card it works, even with SIM card :+1:

recomandation could be :

without SDcard try to reflash e-1.17.1-q, then upgrade OTA to e-1.20-r, then insert the SDcard…

so simply try to reinsert the SDcard now, and reconfigure apps that must use it.

OK, I will try this, thanks

Some news: until today, the phone worked😵 without SD card. I’ve try to reinstall v1.17.1 with adb. Apparently, the sideloading was OK but after reboot, the phone shutdown and restart on recovery mode, with this message :“Can’t load Android system. your data may be corrupt. If you continue to get this message, you may need to performe a factory data reset [etc].”

Then, I try with install of the v1.20, always with adb. This time, the install was correctly, but I’ve the same problem with SD card. I suppose I should made a factory reset :dizzy_face:

… But without backup anything because some functionnality doesn’t work at present time (after v1.20 resinstall) : home button, access to developer options… (And the dark mode :/) but the installed apps are OK for the ones I tried.

Have you any suggestions before I remove all? (with a little hope of rework)
Thanks for help!

This seems to me the main problem.

Have you considered very carefully whether you ever had the SD card installed as Adoptable storage.

This is giving problems to other users.

Please tell us exactly what you are running now as [HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc.

Please read this carefully

To troubleshoot this issue if you are uncertain, keeping only to the current /e/OS version.

  • Note and report how the phone works with no SD card. If possible take small backups of the most important things while you can.
  • Do not return the previously used SD card to the device, but use a clean SD card and install it as Portable also called External storage. Note and report how the phone works with this card.
  • Take the previously used card to your PC. Can you get a backup off it. Does the PC report anything unusual about the card, or is it reported as corrupted ?

Do not follow the fix advice in the article, right now you may be in a different position from most readers of that article.

OK, here goes:

I’m having a problem with the v1.20 update on my phone
About the phone: SM-G930F
Version /e/OS: 1.20-r-20240221382013-stable-herolte
Problem description:
The phone starts but many things don’t work:

  • home button not responding
  • no full access to taskbar shortcuts
  • no data network (only calls and sms)
  • no wifi (but active icon)
  • no notifications
  • no dark mode (set in previous version)
  • no backup via adb
  • microSD not recognized if I test it

The current v1.20 was installed over the non-functional v1.17.1, itself installed over the v1.20 OTA (without the initial 1.17.1, I forgot about it).

Lots of problems: my smartphone is now a feature phone! :face_with_raised_eyebrow :

One question: if I format and reinstall v1.20 correctly with sideloading, is that a solution? (So much for loss data, not very important)

1 Like

You do not answer my points about Adoptable storage … so I cannot be certain, but … if you go for Format and reinstall v1.20 I would advise to avoid use of the previously used SD card in the first days.

After reinstall do your First start wizard with no SD card or alternatively a brand new one; establish if the phone now works correctly.

Only add an SD card as “Portable” or External storage.

Don’t think it is related butjI remember some users of S8 upgrade reported that after first boot it took hours until the update was really done. Can that be an issue?

Hello, I hadn’t replied about SD card, sorry.
I don’t think she was in Adoptable Storage mode. I had access to it as “external memory” (I think) in the file explorer.

I’m going to try a full reinstall, without an SD card, and from formatted memory.

I don’t think it’s the same problem, it’s been three days and my phone hasn’t changed ! Thanks anyway.

1 Like

Apropos the “special release” of 1.17.1-q-herolte mentioned in Post #2 here is the link to the Release Note just to explain why Adoptable storage might be an issue for some – good to hear that you believe you were using “Portable” that is Extended storage.

Good luck.

Thanks everybody for your help! I’ve format et reinstall all the OS, it works completely now. Just one or two hours for reconfigure all apps ans parameters!

For information, I’ve format the SD card, it works too.

Despite my inattentive worries, /e/OS remains a super easy system to install (well, not as easy as Linux, there’s still a small degree of anxiety during sideloading). But well done to the whole development team and to the courageous men and women on the forum who guide the inconsistent like me!

(Deepl power!)


This topic was automatically closed after 60 days. New replies are no longer allowed.