Samsung Note 10+ Exynos 975F - /e/ Recovery Image Fails Boot


I am unable to boot the /e/ Recovery image “recovery-e-0.18-r-20211003138900-dev-d2s” after successful download. Error is “recovery: Public key used to sign data does not match key in chain partition descriptor.” as shown in the image.

Trying the latest 3 versions of TWRP “twrp-3.5.2_9-5-d2s”, I get “recovery: error validating footer.” and “recovery: Error verifying vbmeta image: invalid vbmeta header”.

Any ideas?

Thanks, and regards,

Windows, MacOS, Linux ?

Linux, flashed with Heimdall. I verified the hashes, and just had great success flashing my S10 5G using this method, but not on the Note.

This is the TWRP error:


Have you flashed the proposed vbmeta before or when flashing TWRP ?
According from twrp

If you wish to install TWRP without rooting, there are numerous pitfalls to consider. For example, a stock device is protected by Android Verified Boot. This is implemented as a vbmeta partition that contains cryptographic digests for verifying the integrity of boot.img, recovery.img and other partitions/images. Flashing TWRP without first flashing a vbmeta image with verity disabled will render your device unable to boot.

According to :
it is an additional step for recent Samsung’s

sudo apt-get update
sudo apt-get install heimdall-flash android-tools-fastboot android-tools-adb libusb-0.1-4 libusb-1.0-0 libusb-1.0-0-dev

sudo heimdall flash --RECOVERY /path/to/recovery.img --VBMETA /path/to/vbmeta.img

( Replace "/path/to/your/downloaded/files/” )

Oh, wow, not sure how I missed that step in the guide! Thanks for the info, I’ll try this and report back.


Also the bootloader unlock process looks more complicated than for older devices

Yes, it was…the S10 5G was a small challenge to unlock, and the Note 10+ required quite a few more attempts to get it unlocked.

Ok, so I moved past this issue and encountered what is hopefully the last part to getting this working.

In summary, the latest boot verification mechanism includes checking the signature on the vbmeta.img, regardless of whether boot image verification is disabled therein. There are ways to generate new or copy existing certificates for this, or ways to bypass the signing altogether.

For reference:

I will go through one of these solutions and share my findings.


1 Like

Very informative links,
But our vbmeta comes from the official twrp builder for this device, and must have the right key…

You bet!

I’m glad you mentioned that. I have tried probably 7 or 8 different vbmeta.img files for the 975F from various sources, including the official TWRP (which I was sure would have the correct key) with no success. Perhaps I’m doing something else wrong.

I don’t think so, i am sorry, but don’t have more ideas…

Thanks again for all the help!

So I started again from scratch, and I still get the “HASH_MISMATCH”. I wonder if there is a possibility that one of these files was updated and the keys were never updated to match.


I just see on the photo, that your device is no more a SM-N975F, but now a SM-G973F (by flashing a wrong file ?)

Best advice is :
! Flash back to stock rom and redo the process !

Oh, interesting. I used the file from this link:

This is the first time I have seen the model number change like that. At least now there seems to be an obvious reason why it is not working.

More to follow…


About the Galaxy s10e :


Very interesting, thanks. I’ll give that a shot!


Please @tcecyk have you got an understanding of this situation ? (many devices concerned)

This one : Samsung Note 10+ Exynos 975F - /e/ Recovery Image Fails Boot

Others :
Installation /e/ sur Galaxy Tab S5e

Install TWRP on Samsung Galaxy Tab S5e