SeedVault Restore Backup

I’m using a FairPhone 4 (FP4) with /e/os on it.
I’ve done a backup with SeedVault, save it on my laptop and an external microSD.
After reinstalling Android11 back and then going back to /e/os I was willing to restore my backup but I can’t find any way to load the backup from the microSD or the internal memory after copying it in.
I’ve tried to factory reset many times to restore during the setup wizard but it never proposes to restore.
I’ve also tried the solution propose here but it only creates a new backup.

I’ve also tried to launch com.stevesoltys.seedvault/.restore_backup command from adb shell, but got an error.

If anyone could help me it would be nice to restore my backup instead of reinstalling everything.

Hello, I had the same problem, it is annoying. The solution is not to set up a new backup after a fresh factory reset. Just after factory reset, go in the telephone app and type ##restore## = *#*#7378673#*#*, you will then be able to restore your backup
The normal android startup wizard after factory reset does offer to restore a backup but not /e/ os at the moment, though I guess it is being solved.

I am using a usb flash drive or SD card to do my backup. Though I have noticed that saving on a usb drive or nextcloud drive does not save as much as on sdcard or internal storage … For example, the internal storage will not be included. This is a big problem because using nextcloud or usb flash drive as backup media will make you lose some data. When I use internal storage as a backup directory location, it is saving both the app ddata and the internal storage data like pictures, as instructed in the options of the backup setup , which is what we want. Yet, you must copy the backup from internal storage to a PC, which is really painful as it takes hours because of small files.


I don’t know about your PC-configuration.
To me it is quite easy as I use Linux Mint and there is Warpinator available on the machine as well as on the phone doing this work. Just sharing the backup directory over Wifi.

Thanks for your answer,
But I don’t understand how to type on phone app,
I have only numbers # + and * on phone app.

What else do you need?
(Have a look just below the digits in the dialer, the letters are assigned to the digits.)

(R=7, E=3, S=7 etc. …)

1 Like

Did you try to copy it via adb, which is afaik much faster than using mtp.

1 Like

I will use adb next time ! Thanks !

1 Like

Just remember that adb pull does not support wildcards. So you’ll have to use something like adb pull /directory/

~$ adb root
ADB Root access is disabled by system setting - enable in Settings -> System -> Developer options
~$ adb root
restarting adbd as root
~$ adb shell am start-activity com.stevesoltys.seedvault/.restore.RestoreActivity
Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.stevesoltys.seedvault/.restore.RestoreActivity }

I tried a restore with a USB Drive and the internal storage was included (though I am missing some pictures, will look into that).

Also alot of apps were not installed even though when backed up it and shown as ‘ok’…