Set up and troubleshoot a mobile data connection (3G/4G)


Learn to configure and troubleshoot mobile data connection issues with your prepaid or postpaid 3G/4G SIM card on your /e/ phone.


  • A phone running /e/OS inserted with an active 3G/4G SIM card and a data plan.

Let’s roll.

Generally, an active SIM card with a data plan works out of the box. Still, there are a couple of things that might go wrong. Let us focus on those rare issues one at a time.

1. Ensure that the SIM card’s is active with a valid data plan and check whether ‘Mobile data’ is OFF by any chance

If you bought a new SIM card for your /e/ phone, make sure it has been activated by your mobile carrier. The best way to check it is by making a successful voice call or by asking customer care directly. Upon affirmation, if you paid for a data plan online or immediately, it is best you try a reboot of your smartphone.

Also, make sure ‘Mobile data’ is active. In order to do so, you need to access quick settings tray by swiping down from your phone’s top.

Turn ON Mobile data from quick settings tray by tapping on the ‘Mobile data’ tile as shown in the image below. Upon activation it would show network access type or mode viz. LTE, CDMA, WCDMA, GSM etc. For example LTE in the image below.

If Mobile data tile shows ‘No Internet’ continue troubleshooting.

2. Enable ‘Roaming’ and set ‘Preferred network type’ to multiple modes

Open /e/OS Settings and navigate to Mobile network from Network & Internet settings to enable ‘Roaming’ as shown in the image below.

Roaming is enabled as seen in the image below:

Tap Advanced in Mobile network settings to set ‘Preferred network type’ as ‘LTE/TDSCDMA/CDMA/EvDo/GSM/WCDMA’.

Pro tip: Make sure ‘Automatically select network’ is enabled under Network in Mobile network’s Advanced settings as seen in the image below.

If you still face issues, please continue.

3. Reset APNs to default

In Advanced settings of Mobile network settings, scroll down to the last option Access point names and open it to access APNs list.

Tap on the top-right icon to select ‘Reset to default’.

It restores default APN settings and that should fix your mobile connection issues.

Always consult with your mobile carrier’s customer care or website forums for APN related help. If it does not restores itself. Customer care is technically able to transmit mobile data APN settings to you directly over the cellular network.

4. Smartphone’s SIM slot related issues

Some of the smartphones only offer 4G data connection on 1st SIM slot or primary SIM. Please ensure that you have inserted your 4G SIM card in the 1st or primary SIM slot only. It can fix all your issues with a 4G only mobile carrier.

5. Network coverage related issues

If you have your setup in the basement or in lowest floor of an area surrounded by sky-scrappers, you might not get a data connection owing to signal issues at all. Make sure you have tested the mobile data on an alternate device to rule out any range or coverage related issues. Try it out on a different flower or on terrace once.

6. Broken or bad cellular chip

If you have tried out everything and still cannot get a mobile data connection on your phone. The chances are you have a broken cellular chip on your smartphone. Contact /e/support or your phone’s service center immediately for a quick resolution.

Thanks for reading!


I have followed these instructions and it does not improve the situation.
For a few hours yesterday I had mobile data. Other than that I have the little ‘x’ on the 4-bars of mobile signal strength and I am burning through battery.

pre-loaded galaxy s9.
Google Fi network that is on T-mobile.

1 Like

This indicates mobile data is off. First would be to double check it has not been switched off inadvertently, then I would phone your carrier. If there is some reason that they cannot serve your device, I think support would be able to spot this quickly. :slightly_smiling_face:

I have been turning on & off the mobile data, trying to troubleshoot.
In other words, my mobile data setting is ON while I am having this problem.

I am guessing that google-fi will force me to use the google-fi app on my de-googled phone, which sounds completely backwards.

I will look into switching to T-mobile or Verizon.

1 Like

Yes, google’s suggested solution was to install all the google service apps.
I just switched to T-Mobile. Everything seems fine so far.

1 Like

Hi Shepherdcrane, I seem to have the same problem. Do I understand correctly that your problem was solved by switching to T-Mobile? If so, which provider were you using before? I’m using Vodafone in the Netherlands. You’re talking about Google-fi. I do not have a google-fi plan, but I suspect I have the same problem with Vodafone. Could that be the case?

Hello from Boston!
I think the basic problem trying to use Google-Fi phone service. There is no way Google-Anything will be compatible with e-foundation OS.
I hope me trying Fi did not forever compromise my phone.

It certainly seems always worth checking with a provider if they are somehow involving

I had never checked out this site (in fact I still not read it) but third party link suggests it would be totally unwanted on an /e/ device!

1 Like

I just installed eOS on my Samsung S9 through the easy installer.

Unfortunately, I am unable to connect to mobile data, therefore, I cannot send and receive MMS, email, or browse the internet when I am not connected to Wifi.

I have followed the above instructions, but when I go into “preferred network type” only: LTE, 3G and 2G appear. What has happened to LTE/TDSCDMA/CDMA/EvDo/GSM/WCDMA and the other options? can I fix this?

1 Like

I have the same issue. It’d be great to hear if you found a way around this problem, or if you solved your issue in another way.

1 Like

In phone dialer




No mobile data LTE/TDSCDMA/CDMA/EvDo/GSM/WCDMA does not exist?

Hi CheffMB,

I did attempt to flash different versions of eOS and TWRP, that might allow mobile data, on my S9, but kept getting ‘error 7’. After this happened a few times I decided to go back to the easy-installer an reinstall eOS from there. When I did this the mobile data started working again?

After a week of everything working perfectly, the mobile data stopped again? This time I contacted my Telco’s technical support. The problem was escalated. While I waited I turned my phone off for a day. When I turned it back on the mobile data worked again, and hasn’t stopped?

I don’t know what fixed the problem?


My Samsung S9 now won’t connect to mobile data, I have the little cross in the signal strength bars.

My phone had a moment today, where it wouldn’t unlock the sim, but now does. The card works fine in the iPhone, so don’t know what else to try.

Well for an hour I turned settings off and on and soft rebooted. It now works, but I don’t know why.

Curiously one phone shows the signal bar normally, the other phone has a little cross in the bottom right. Both now work, so what does the little cross denote?

The little cross is “no mobile data”!

You can turn on the little cross by turning off mobile data, then you can reverse it by turning on mobile data.

1 Like

I have the same issue. No mobile data on my galaxy s8. I have tried eveything suggested here and nothing works.

I can make calls, send sms but no mobile internet.

Looks like is a /e/ os ROM issue with Galaxy s8.

I reflashed stock and mobile data works. I hope this issue can be solved soon.

I also have these problems with a S8 phone (Android 9). Doing telephone calls works, but I have no internet.
The SIM card is working in other mobile phones, but not with /e/. Maybe with a newer Android version (I am wating for the OTA upgrrade for Android 9)? Someone with experiences?

The first thing I would look at is your carrier’s Access Point Names (APN) (perhaps they got changed, and the update did not get to you automagically? idk)

A recent question was answered like this